Flight simulator will not launch!

When I launch Flight simulator, A black screen pops up and poof. It goes away!

Can someone please help? It was working just fine yesterday, now today it will not even launch.

Ditto, same thing

same problem, help please

I was getting artifacts with no addons so i tried reinstalling my drivers after a DDU - now the game no longer can load - crashes half way through.

Same problem!

Edit: after trying everything incl. Windows Setup i fixed the problem by viewing the eventmanager. Something happens with audio settings and sonic studio 3. Change audiosettings, no success. Deleted Sonic Studio 3 —> FS is launching again!!!
I also tryed to delete FS und install it new…so now i have to download 120GB again.
I have fast internet, but download is very slow today :frowning:

I’m looking for clues on how to fix this too but so far… no luck…
I am downright frustrated. I don’t fly as often as I used to (two kids, wife, tons of things to do with the house and what not. I’m lucky I get a break now and then) - but when I do I’d like it to be effortless to get in and fly a little.

I’ve installed the update from MS Store.
I’ve started the sim, which instantly crashed.

I uninstalled the sim. Reboot. Installed again. Reboot.
Starting the sim, now at least I got to the “update” window and it downloads for hours.

Then it crashed.

I restart the sim, and it downloads the last bits, then just CTD.

I restart the sim yet again, it loads a little, I can hear the music play and I see a new loading screen. After a minute or two; CTD.

I’m LOST! What’s going on? How can I fix this?

1 Like

You’re not alone.
No way to start it again, after the first 620 MB download and update from the store it never started.
In my case it crashes a few seconds after displaying that infamous black window.
The OS event viewer detects the application error, find report below (sorry, OS in Italian): it mentions FlightSimulator.exe and WwiseLibPCx64P.dll as executable/module that cause the crash.
Moreover even the Community folder was deleted (I guess right after the kit update downloaded from the store).
Feeling very disappointed, any previous installation and update was absolutely a ‘piece of cake’, it CAN’T a problem caused by our installation or set-up.
Hope someone can shed light soon on this.


Nome registro: Application
Origine: Application Error
Data: 28/07/2021 18:13:49
ID evento: 1000
Categoria attività:(100)
Livello: Errore
Parole chiave: Classico
Utente: N/D
Computer: DESKTOP-LUCIANO
Descrizione:
Nome dell’applicazione che ha generato l’errore: FlightSimulator.exe, versione: 0.0.0.0, timestamp: 0x00000000
Nome del modulo che ha generato l’errore: WwiseLibPCx64P.dll, versione: 0.0.0.0, timestamp: 0x60532b0b
Codice eccezione: 0xc0000005
Offset errore 0x00000000001a279f
ID processo che ha generato l’errore: 0x7888
Ora di avvio dell’applicazione che ha generato l’errore: 0x01d783cb6df515e9
Percorso dell’applicazione che ha generato l’errore: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.18.13.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Percorso del modulo che ha generato l’errore: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.18.13.0_x64__8wekyb3d8bbwe\WwiseLibPCx64P.dll
ID segnalazione: 8490293b-1dd1-4721-a177-4b654aeed424
Nome completo pacchetto che ha generato l’errore: Microsoft.FlightSimulator_1.18.13.0_x64__8wekyb3d8bbwe
ID applicazione relativo al pacchetto che ha generato l’errore: App
XML evento:

  • *
  • *
  • 1000*
  • 0*
  • 2*
  • 100*
  • 0*
  • 0x80000000000000*
  • *
  • 55849*
  • *
  • *
  • Application*
  • DESKTOP-LUCIANO*
  • *
  • *
  • *
  • FlightSimulator.exe*
  • 0.0.0.0*
  • 00000000*
  • WwiseLibPCx64P.dll*
  • 0.0.0.0*
  • 60532b0b*
  • c0000005*
  • 00000000001a279f*
  • 7888*
  • 01d783cb6df515e9*
  • C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.18.13.0_x64__8wekyb3d8bbwe\FlightSimulator.exe*
  • C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.18.13.0_x64__8wekyb3d8bbwe\WwiseLibPCx64P.dll*
  • 8490293b-1dd1-4721-a177-4b654aeed424*
  • Microsoft.FlightSimulator_1.18.13.0_x64__8wekyb3d8bbwe*
  • App*
  • *

Close FS2020.
Search for „Services“
Look for a service with the name: „Nahimic“
If you have it installed, it is very likely the culprit
Disable Nahimic and set start mode to: Manual
Reboot

That tip helped me to overcome the problem of a black screen at startup, followed by CDT

Good luck!

This seems to have fixed my issues, removed Sonic Studio 3

Thank you for your advice but in my case even after stopping the ‘nahimic’ service and setting it to manual start (and rebooted PC) still the same problem occurs and the same error recorded in the event viewer.

immagine

Makes sense.
Sonic Studio and Sonic Radar (both by Asus) seem to use Nahimic…

Eventually it starts again, downloading the full kit right now (as in the meanwhile I removed and reinstalled from MS store).
No issue related to Nahimc sound tool, the problem at least in my case was seemingly caused by Process Lasso running in background, now it starts and does nor crash anymore.
Process Lasso is an excellent tool and I used it among other things to exclude MSFS from exploiting one CPU core (to save some CPU for other tasks), never had such a conflict either with any previous update or MSFS session).
Give it a try in case you’re running the Process Lasso utility.

i tried the Nahmic fix, didn’t solve,
tried the process lasso fix, and that fixed it. whatever they did they borked the ■■■■ outta this update. thought we had testers MS?? I can’t fathom none of them didn’t have processlasso running

In my case, I have to disable all audio devices to launch MSFS. After the succesful launch I can re-enable the audio devices :roll_eyes:

Nice to hear this.
Indeed, Process Lasso has always been a must-have for me and never given a single fault.
QA@MSAsobo, where are you?

Found nahimic service and stopped it. Didn’t help.
Don’t have process lasso installed.

Frustrating. :unamused:

Hello there…

I have the same Problem, MSFS stop a few seconds after I start MSFS…also after I have stoped Process Lasso…and i don’t have Nahamic…

Are you sure that Process Lasso is not active at all? Check in the running processes because closing the Process Lasso dialog does not quit the background process.
Then close/kill as many processes as you can in the task manager.

Thank you so much, That was my problem. I uninstalled process lasso and flight simulator loaded up just fine.

Lasso was not my hint, but anyways, I‘m happy you‘re all set now!

Meanwhile - I am still downloading the update - 2 days now, and counting. By now, the installer must have quit on me at least 30 times. Curious to see, what kind of Frankenstein FS2020 that will breed…