Fokker Southern Cross Problems

Please tag your post with #pc and/or #xbox.

Are you on Steam or Microsoft Store version? MS Store

Are you using Developer Mode or made changes in it? No

Brief description of the issue: On the Fokker Southern Cross (1) - the “set / remove chocks” switches are non animated or functional. (2) The climb / descend indicator (to right of rpm gauges) is non functional. (3) there is no way to set a heading on the compass. The top dial should rotate and able to be locked to indicte the heading to fly. (4) below the “set chocks” switches is what looks like a bank indicator - if that’s what it is it’s non functional. (5) no kohlsmann knob on altimeter so you can’t set local pressure (perhaps accurate although the instrument bezel appears to have a place for it) (5) very difficult to steer on the ground although rudder pedal brakes work even though they don’t appear to be a feature of the aircraft.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:

PC specs and/or peripheral set up of relevant:

Build Version # when you first started experiencing this issue:

The Fokker is a tail dragger, it doesn’t have steering.
Use the brakes (like in a tractor) to steer it
This article talks about most of your other issues.

  1. Some light gauges didn’t work properly
  2. You can start the old 3 engine only if you use mixture and rpm (the plane doesn’t have it)
  3. You can start the “modern” 3 engine even if you don’t turn on battery
  4. pump lever on the back has click spot completely wrong
    and a lot more… too much to want to continue writing on

Subsequently found the manual which may help…

1 Like

for turning apparently the secret is to push the stick forward (??!) while taxying but haven’t tried it yet…

the anouncement doesn’t seem to have any issues apart from fuel burn rate for the Southern Cross, the other stiff relates to the retrofit version

1 Like

It works only on retrofit

Not having purchased it I didn’t realize which version was which!
Thanks for letting me know.

You will still need to use the brakes.
Those front wheels don’t turn.
Don’t hit the brakes hard or you’ll end up on the nose.


Zendesk bug report #146664

MS Store

Are you using Developer Mode or made changes in it?` No

Brief description of the issue:
Southern Cross Original Cockpit:
Fuel/starter panel on rear cockpit bulkhead is largely non-functional and what is functional doesn’t appear to work correctly. I doubt I’m getting the fuel turned on because I cannot get the engines started.

Provide Screenshot(s)/video(s) of the issue encountered:

The pic above is from the PDF manual provided in the download of the plane. For me, these various knobs act as follows:

1-4: Totally inoperative. Cannot be moved by dragging, clicking, or mouse wheel.
5-7: 5 itself doesn’t move but clicking on it toggles both 6 and 7. 6 and 7 cannot be moved at all by clicking, dragging, or mouse wheel on the knobs themselves. They only move in unison when clicking on 5.
8: Seems to behave correctly. Can be clicked and dragged between on and off positions.
9-11: Each can be clicked from off to on. Switches stay in on position for several seconds, then switch themselves back off. While on, starters run, props turn, RPM needles move, but engines do not start.
12: Totally inoperative. Cannot be moved by dragging, clicking, or mouse wheel.

Detail steps to reproduce the issue encountered:
Begin flight with Southern Cross-Original cold and dark. Go through all the checklists until you get to starting the engines. Attempt to turn the fuel on and observe the incorrect action of the various knobs on the fuel/starter panel. Observe that engines fail to start

Build Version # when you first started experiencing this issue:

1 Like

Bear in mind Asobo/MS does not monitor the forums to find and fix issues.
If you want this looked into, you need to enter a Zendesk support ticket from the Support tab at the top of each forum page.
In there look for Submit a Request.
Cross refer your post to your request and add the request # to your post.
After that, the more votes here, the closer to the top of the triage list it gets.


I’m aware of that and have done so. I’ve been here since the alpha :wink:

Anyway, the retrofit and the /1m start no problems. The ski and float original cockpit planes have the same cockpits as the Southern Cross and share the same issues with the fuel panel, and cannot be started, either.

Interestingly, the /1m has the same fuel panel as the /3m originals, which seems odd because the /1m has the fuel valve, fuel pump, and starter on the central console, so you’d think this panel wouldn’t be there. You don’t touch or even look at it in the checklists. Even stranger, the /1m’s panel has holes where the starters for the /3m’s wing engines would be, even though the /1m was built first and adding the wing engines was an afterthought.

But anyway, all the knobs on the /1m’s fuel panel just seem to be fuel cocks, not pumps, and they default to the open position. If you click on any of the knobs, they all simultaneously toggle between on and off, except the 2 on the bottom row which are noninteractive and stuck in the on position.

What happens when you CTRL E to start the engines?
Do any move in sequence then?
1 thru 4 look like fuel to the engines, while 5, 6, 7, and 8 seem to be tank selectors.
Odd that 11 and 12 are both labeled as Center Engine.
Why does it have two starter switches?
Are there magnetos that need to be turned on that aren’t modeled?
Is that why they don’t start?

It does make me wonder what kind of research/quality was put into the production of the plane.
It seems to me to be just another default aircraft, but one you have to pay for.
I really hope they put a good effort into making it better.
This sim needs to concentrate on being more into quality than just good looks.
They’ve pretty well got the good looks part mastered.

Sorry about the support request thingy, you’re about the third or fourth I’ve mentioned it to in the last few days. The rest had no idea.

Don’t know. I’ve never used that and in fact don’t have a key defined for it.

The PDF doesn’t explain how the fuel system is plumbed so all I have to go on is the caption of the picture and what the tool tips say. Also, I note the plane has 3 tanks on the weight and balance page, with the central tank being about the size of the left and right tanks combined.

1-4 have no tool tips but the PDF says they’re valves for the left and right tanks. There are no similar valves for the center tank, and I don’t know why the left and right have 2 valves each.

5-8 are all identified (both by tool tip and PDF) as fuel pumps, 1 for each side tank and 2 for the center tank (which are labeled port and starboard).

My complete guess as to how the system might be intended to work is that normally all engines draw from the center tank, and the side tanks refill the center. Then maybe the nose engine is gravity-fed while the pumps in the central tank supply the wing engines. The left and right pumps (and hence the 2 separate fuel lines for each tank) might then be for running the engines off the left and right tanks directly, or maybe just to move fuel around between the tanks. But I really have no idea.

9-12 are all the starter switches. Yes, it is strange that the nose engine has 2 starter switches but hey, only 1 of them is functional so… :stuck_out_tongue:

[quote]Are there magnetos that need to be turned on that aren’t modeled?
Is that why they don’t start?[/quote]

The mags exist and can be switched on. They’re on the central console.

The engines don’t start because they’re not getting fuel, but the reason for that might have nothing to do with the broken fuel panel. See, there’s a known issue about the mixture control. Strangely, the /3m original cockpit DOES NOT HAVE MIXTURE LEVERS although the /1m and retrofit do. This is weird but seems legit because I’ve found some contemporary cockpit photos which only show 1 lever per engine, like it’s a DA62 or something. HOWEVER, despite seemingly not having any mixture control in real life, under the hood in the game mixture control IS modeled, and it spawns in the cut-off position. So, you can use the mixture control on your throttle to open this invisible mixture valve and the engines will then start, EVEN WITH the broken fuel panel.

Still, the broken fuel panel can’t help matters and certainly limits the amount of functionality the fuel system should really have and this will come into play when they fix the mixture bug.

I don’t get this bias against “default aircraft”. I’ve gotten a dozen or so 3rd party planes, mostly from “big names”, and none of them are really any better than Asobo’s. They all of them have stuff that doesn’t work correctly or at all in about the same amount as Asobo’s, and often Asobo’s visuals and sounds are better.

In any case, apart from the inability to start the /3m original from cold and dark as intended (although there is a work-around), it’s actually a pretty solid product. It flies well and as expected with no weirdness like the Ju52, it looks and sounds great, and comes in 3 significantly different versions with all the types of landing gear. For only $15, it’s a WAY better deal than most 3rd party planes IMHO.

1 Like

You are right, it is not very expensive, and if it flies right, I would suspect they will iron out the issues.
It really isn’t a bad deal for the price.
My bias extends from the older sims (FSX and prior) where the default planes were not very well done at all.
I must say, the default planes in here are substantially better than those!

1 Like

How do you get the single engine Fokker to climb off of the runway? AvAngel’s video shows it has almost no power. I cannot get it into the air. The trimotors do not have this issue.

Jorg did not follow up on his Q&A statement that he had no objection to making the flight model files user available on Premium, Deluxe, and those purchased in the Marketplace.

There is therefore no way we can fix broken stuff ourselves.

Nobody expects all the files to become available, because then the planes could be stolen without payment.

With only 1/3 the amount of power of the B model, it will take a fair bit of runway.
Did you follow the Normal Takeoff and Climb checklist in the manual ?
It is important to set the proper manifold pressure and RPM with the A version.

CTRL-E worked for me to start up all 3 engines on Southern Cross Original!
Took of and flown 30 min and it was good. Straight out to sea…
But manual do not help out with controls!
Compass is worthless. Did use outside view to see course.

Get the tail up immediately to reduce drag and friction, then boil up a pot of tea while the thing slowly accelerates to flying speed :wink:

Yes, the compass is pretty annoying. It’s pretty much a binnacle stolen from a ship, not something designed for a plane. Neither bug nor needle, just some weird T-shaped marking whose purpose I have yet to discover.

Funny thing is, Asobo seems to admit the compass is crap. Have you noticed the historical flights for this plane? If not, they’re in the Activities / Custom Contents section. There you’ll find 4 new bush trips for it. The introductory text for each says to use the external view compass to find the course to follow :rofl:

BTW, the legs of 3 of these 4 bush trips (going to the North Pole and back, crossing the North Atlantic in several hops, and flying from California to Oz) have INDIVIDUAL LEGS ranging from 10 to 36 hours in duration. All hand-flying. You definitely can’t do any of these if you have a real-life job :stuck_out_tongue: And even then, you’d probably still have to team up with another player in the flesh who could physically take turns with you at the controls. But only you, under whose account this is happening, gets the achievement, while the copilot gets nothing, not even hours in his game logbook.

And BTW, you’ve probably noticed that no version of this plane has the ferry tanks necessary for any of these trips. So the instructions say to use the refuel command as needed during these long legs.

what happen to wind generators clearly seen here just below cockpit window ?

1 Like

It’s probably an earlier version than THIS but may help you figure out the compass.

They added that note to use external view, because it is old school, very very old school. No need to disparage it or Asobo for recreating original equipment. What do you expect from a 1920’s aircraft, and yes, if memory serves me right, the compass did come from ships originally.

I haven’t bought fokker yet, but the compass I have used.
edit: downloading it now…

1 Like

This is a good video and explains the use of the compass very well. Unfortunately on the FVII, the heading ring doesn’t rotate, so you can’t set the direction you want to steer and there is no compass needle card, so you can’t see which way is north.

1 Like