For those of you locking frames at 30, try this out

I lock my frames at 30 because it gives the most stutter free results. I appoligize if this has been brought up, but saw this article on AVSIM. Cpt_Piett posted a video showing how using Nvidia’s “Maximum Framerate” setting improves FrameTimes.

FrameTimes have definitely improved. Since I use Tobii & FaceTrackNoIR, I put motion blur on “Ultra” and it makes looking around smooth too.

2 Likes

Or you can have VSync off in the sim. And use the “Fast” Vsync in the Nvidia control panel, to practically let the framerates go smooth, while also eliminating tearing.

And I turn off Motion Blur, that’s a useless function from my perspective.

5 Likes

Rivatuner Scanline /2 is better than nVida lock.

AFAIK the NVidia “fast” vsync settings let your machine run at its full capacities CPU GPU RAM etc. but only display a frame when in sync with the monitor, so no tearing and lower latency.
It sound cool like this, but IMHO, it is not (cool).
Your machine run full all the time, temperature raise, to compute more frames that what you are able to see. In the contrary, limiting frame rate via vsync (or frame limiter) slightly below your machine skills will give headroom as it can “rest”, and all will cool down, for the nearly same result. It also smooth all, as it limit the apps thanks to the gpu, so you don’t have a waving fps when the sim have more, or less, things to compute.
No offense, just giving my 2c :wink:

2 Likes

That’s good to know… but I’m fine with it. I let it run on fast vsync on my 12 hour long haul flights. Hahahaha

Can you summarize in a sentence what improving FrameTimes means and does versus leaving it as it was?

Frametime is the pacing of frames between each other. You want that number consistent…i.e. 1 frame is not equal to another. You can have 30FPS but they can be spaced apart like |. . . . | . . . . . . |. . . | . . . . | . . . . | This makes it look microstuttery.
You want a frametime of 33.3ms for 30FPS |. . . . | . . . . | . . . . | . . . . |

Are you specifically saying that using the built-in Vsync implementation locked to 30 fps does not produce consistent frame times, but that this other technique does?

correct.

FS Vsync locked at 30:
Microsoft Flight Simulator Screenshot 2021.04.05 - 12.12.36.49

Nvidia Control Panel MaxFramerate:
Microsoft Flight Simulator Screenshot 2021.04.05 - 16.51.33.76

2 Likes

Thanks for explaining! :slight_smile: I’ll check out the links for details.

1 Like

How are you measuring frame times? Is there a particular tool you’re using?

Curious why most posts regarding improving frame rates, fps, stuttering come from Nvidea users. Are there just that many more of you trying to work with your drivers than AMD users tweaking Adrenalin 2020? Or are there just more problems to work out with Nvidea GPU’s than AMD GPU’s?

MSI Afterburner’s OSD with RIvaTuner

I think it’s largely because nVidia represents 82% of the GPU market share, so it’s more likely to come up in any PC gaming forum.

Ok, so I was unable to reproduce your results:

  • MSFS V-Sync is on and set to 30 fps
  • with NVIDIA control panel setting the MSFS max frame rate at 30, I get a solid 33.3 ms frame time, plus or minus a fraction of a millisecond
  • turned it back off, restarted MSFS, and I still get a solid 33.3 ms frame time, plus or minus a fraction of a millisecond

So the NVIDIA control panel max frame rate is not changing my performance at all.

Note I’ve been unable to get the frametime history graph to display at all, even though I have enabled it and set a size of 1000x500 pixels.

Thanks. I had no idea.

Ok I somehow managed to get the frametime graph to display (this seems to involve closing Afterburner because according to this Can't get frametime graph to work | guru3D Forums the frametime graph deliberately does not display if you run Afterburner.

Doing some more testing, but keep in mind that I found absolutely zero visible difference between the two just from flying around.

Ok, I can see somewhat less variation in presentation times (but not a complete evening out) and a pretty good, but not complete improvement in start times. However I literally can’t tell the difference looking at it, I have to open the graph and look at the graph to tell which mode I’m in.

Msfs vsync must be off. Limit the fps via nvidia control panel only.

Why do that then? (I literally always want vsync to happen, because I don’t want frame tearing.)

To clarify:

  • v-sync on w/ 30 fps limit in MSFS gives me the results I want
  • also setting max fps gives slightly better results on the graph, but looks the same
  • what would improve further, exactly, if I disabled v-sync?

More consistent frame times.