Forever loading issue after Sim Update 6

Deleting the Content.xml file solved this for me.

3 Likes

thanks for the tip, will have that a try after work!

1 Like

Hmmm - not a complete solution as I’ve now had the issue again. ORBX is suggesting deleting the the Simulator .dat files as well - in here:
AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\SceneryIndexes*.dat)
so that’s my next port of call.

1 Like

Let me know how that works for you

1 Like

Will give it a try thanks

1 Like

Everyone, I suspect they are having server issues, based on the number of times the system has gone down over the last few days. Also, some issues with Windows 11 and AMD chips. Printer driver on network system as well. I have NOT experienced issues, but then mostly fly UISA, and have not flown since SU6, just made sure it started. Now, aint no expert, but for over two days I could not even get the update because of server issues. If any of the locations you are having issues with are dependent on contacting a server, my guess is that is the reason, however, some tried in Safe Mode, and still no success. I dont think it is totally related to SU6, but might be something which was broken before, and and now has come to light. I will try spawning at the locations listed above and see what happens, but wont be till this evening East Coast USA time. I will use the F-14 because it’s the most fun plane, as fall back, Boeing 747 as well, since trying to make that one work right too.

As aside, massive Windows 11, update downloading now.

2 Likes

I tried this after everything else left me still stuck and deleted the .dat files and instantly saw a huge improvement. I am not saying by any means I am fixed as was one airport I tried but going from not being able to load into a airport to being loaded in 30 seconds, with community folder installed is hopeful. Thank you so much for sharing!

Edit: So loaded for another flight in another country and was basically a 30 second wait then instant load. This seems to be worth doing for sure!

1 Like

I had it yesterday, small airport near Monaco, nothing in community folder ever. Restarted sim, now fine at same airport?

1 Like

Happens regularly, but not consistently. Sometimes an airport loads fast, a day later the same airport gets stuck on the loading screen. Only solution so far is ctrl-alt-del

4 Likes

Same here. [BUMP].

1 Like

Did not work :(. Still have to wait for ages…

1 Like

OK so I have investigated further and what I tried earlier sadly failed on every other occasion under the same set-up.

In my case it was the ORBX ENSD scenery which I couldn’t get to load and eventually I found it will work … by removing another Norway scenery item.

So if the other suggestions don’t work, at least in my case it was resolved by looking for other add-on scenery covering the same area; it appears that perhaps SU6 is more susceptible to this?

1 Like

I experienced this as well. Thought this was fixed after reinstalling the sim. Tbh, I could probably benefit from a complete reinstall anyways as over time I’ve accumulated so many 3rd party add ons that I never use, I wanted to clean them up and save the space. Will make future updates a little cleaner, too.

But any 3rd party areas won’t load at all. In particular, I can never load Cityscape Sydney and YSSY.

1 Like

I wasn’t aware of this issue when I started FS (SU6) and after a couple of minutes of the sim loading the visual became blurry but the music continued. There was no blue loading bar showing. It remained like this for a long time and I gave up after about 7 minutes and closed FS. I did have some new aircraft fix mods and a utility (Toolbar Pushback) that were linked into the Community folder with FS Addons Linker.

I then started FS again without removing any of the links in the Community folder. The startup proceeded to the main menu, but did take somewhat longer than what used to be normal - about 3 minutes on my PC system.

During the long aborted attempt to start, I checked my PC monitoring software and it showed the CPU running only at its reduced idle speed rather than its full clock speed.

1 Like

Guys, this has nothing to do with the airports or add-ons, this also happens to a few w/o any add-ons and in safe mode. What can be said for sure is that location (a different one for everyone) plays a role. This is entirely random (and hence hard to fix).

However little changes in the system (I assume shifting stuff in the memory mapping shifts the problem as well) often have at least a temporary effect:

  • Deleting Content.XML cleared the situation for a few hours

  • Turning off detailed multiplayer aircraft fixed it for a few flights

  • Loading a nearby airport that works, then on the cinematic screen when the flight loads, ESC exit the flight and try to spawn on the malfunctioning location again. This seems to work quite often, but not reliably as it seems.

  • Turning off online functionality before starting the flight, then turning it back on seems to work.

  • Uninstalling the G1000NXi seemed to help (but that may just be yet another red herring, this problem is packed to the rim with those)

I’m observing this for months now but I wasn’t directly affected because I don’t usually fly where similar issues happened. The summary of my observations is that the problem used to be a full freeze during loading a flight (under similar circumstances), now it’s more often slowing down the loading process to a complete halt, but FS appears to remain responsive to the system (no “not responding” tag in Task Manager). There’s also a rare 3rd variant (flight loads but doesn’t load anything (any scenery components) after takeoff that I assume is just yet another manifestation of the same problem.

What’s bad is that this problem (in all of the 2 (3) variants) is incredibly elusive and hard to replicate, I assume that much more computers are affected than ours, it’s just that their owners don’t fly where the problem rears its head. For me it’s my home airport now but so far that’s the only one that doesn’t load. SU6 solved it for many of the people affected by the first variant, and shifted it e.g. to yours and mine.

You should be able to simply click the X to close FS. Otherwise FS is not responding → that would be the older manifestation what I can only guess is the same problem.

1 Like

You have made a very good observations as i also obverse down this when this started happening after update No matter weather your community folders are empty it does this safe mode too wear all conflicting addons are disabled . This update has brought this new issue that needs to addressed by hotfix. I am seeing people on reddit too experiencing this long loading issue.

I had empty community along while testing deleted content.xml does temporary work i wasn’t able to load at paris Airport but after deleting content.xml file it loaded perfectly theb i restarted the sim it didn’t load stuck at fully blue bar

Hope devs sort this issue out

1 Like

MSFS won’t even load for me… Just tried restarts.

1 Like

had the same here, launching with admin right worked for me

1 Like

Have had this a few times since previous update usually works after a sim restart.

1 Like

Yes, having the same issue. Couple Sim restart did it for me, but it keeps coming back.