Found one cause of stuttering


SInce couple I found that my MSFS start to stuttering, I make couple reset of my computer, play my setting and no succes. SO I remember that I had re enable multiplayer in Data connection. So I switch it OFF and my stuttering disapear but not my juddering.

I can clearly see the difference between ON and OFF

Nvidia Driver 457.30
MSI 3090 Gaming X
AMD 5800X
HP Reverb G2
1.5 gb Internet speed

Can you reproduce or it just on my system ?

Yes, it could be a cause of stuttering if your internet connection is slow.

Nope I got 1.5Gb of download, so it not a problem… I think it more a problem of multiplayer data optimization.

What about your latency? What is your RTT/Ping to the Asobo Servers? If your latency is ok, then the other possibility is the cache files getting corrupt.

1 Like

Anything that puts an extra load on your CPU will contribute towards stuttering. I found enabling any of the live gameplay features effects FPS in VR quite dramatically. That being said the OP has a decent enough CPU so I’m quite surprised.

We all need to wait for Asobo to optimise things for VR I think. I’m done going round and round in circles trying to iron out performance issues which are never going to be ironed out until Asobo sort things.

1 Like

I got 33ms on the EAST USA, and I had deleted my cache files already… I still got stuttering when I switch to Multiplayer…

Have you tried checking your “Xbox Networking” in Windows? See if you getting any connection issues there. I’ve seen a video of someone explaining that this could be causing some data streaming issues, in particular blurry textures, but it could be a cause for stuttering as well. Use “Fix It” in that window if you are seeing issues and then “Check Again” it should open up whatever connections it needs to open up. Don’t close that window as it seem to reset everything if you do, keep it open and you will have to figure out how to solve it more permanently if you see that it was the issue. It will reset every time and you have to go through “Fix it” every time.

btw - I undestand the stuttering part as I get that too sometimes. What do you mean by juddering? are you experiencing violent shaking in cockpit or something?


Yes I have check that and evrything is fine, My connection is open, and is true that I need to fix it every time.

It hard to discribe juddering, but when I look on the side window of A/C, I see the scenery moving but it not smooth. It lock like you have a small lag. Microstutter is when my scenery pause for a millisecond and continue

Apparently, not the case. See my post here:

I think he’s referring to the juddering motion you get when you turn your head in the cockpit with motion re-projection disabled in OpenXR.

Go to windows advanced settings>Performance>change prioritize programs to background and services. Restart PC. Load game all the way. Ctrl-Alt-Del In task Manager right click FlightSimulator.exe. Change priority to low.

That’s it. Try it out.

Low?? Why low? Are you trying to decrease performance??

Just try it

I remember that I was using Low in the Alpha/Beta test, and I don’t know why I switch to High… I need to try again…


Edit: I just try and it the same thing, so I’m back to high…

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.