Freelook with mouse SERIOUSLY broken since Update

It is no longer possible to PRECISELY adjust a view with the mouse since last update.
If I move the mouse small movement only the view doesn’t move. Need to move the mouse faster and further now to get the view to change. Then it’s too much.

This is SUPER ANNOYING.

BEFORE IT WORKED FINE.

And no it’s not my mouse.
If right click and go back to the mouse arrow in cockpit. The mouse arrow reacts PERFECTLY to small tiny slow movements.

Right click again to move the view. No reaction unless I move the mouse a lot

Not everyone wants to use track ir or VR

Please this needs a hot fix.

well, i installed this sim again to give it a second chance just to find out that its in worse shape than before.

I have the same problem. Changing sensitivity doesnt do a thing.
Its like if there is some mouse acceleration setting turned on. Sim doesnt register slow movements at all !!

I lowered my mouse polling rate from 1000Hz to 500Hz and it improved stuttering quite a bit.

Not sure if it is the same issue you getting.

Hi guys.

I’m glad in not the only one NOTICING this.

I’m pretty sure evrybody has this issue but many of them just don’t notice. As many of them are just arcade kiddies nowadays. I like to position my view EXACTLY at certain spot in the cockpit. And it’s not possible anymore now.

Actually the same issue exists in external mouse view now. But there it’s not that important and annoying as inside the cockpit.

It seems to me as if it has something to do with the sensitivities settings. They changed it for joysticks jokes. Which is good. Gives more options. But as USUAL they ■■■■■■ something up.

They make one thing better or fix a thing. And brake thing as they go along

I seriously wonder who’s testing there?
:joy: :joy: :joy:

Actually not funny.

Let’s just hope they’ll fix it again.

1 Like

Yes, since last update there is some kind of threshold in the mouse moves in freelock. All very slow mouse moves are not detected. Maybe some kind of visual smoothing for VR. At first i thought my mouse is broken. :astonished: The normal mouse pointer works perfect.

Zendesk ticket created.

Asobo, please fix it (after your holiday vacations :wink:).

1 Like

Please let us know when they reply

Exactly that’s what I think also.

I also opened a Zen desk case right after opening this thread. Let’s see

No response yet?

I only got an automated email after I opened the Zen desk report

And I checked a few days ago on Zen desk then I they marked the issue as solved. Without telling me about it.

So I opened another case same matter.

What i noticed: My first case was number 85 thousand something. My second case a week later was already number 89 thousand something.

They’re never able to fix all this with only 200 people.

I hope I’m wrong. …

Mouse look now looks like it is purposely speed-sensitive on how fast you move your mouse. Cannot think of any reason why this is an improvement for any issue, or fixes any other problem. Needs a hotfix.

1 Like

I received a meaningless answer. Unfortunately, the mouse problem was not understood at all and incorrectly referred to VR. Very unsatisfactory. :angry:

Please vote up!

Zendesk answer:

Hi Gaobizi

Thanks for contacting Microsoft Flight Simulator Support.

Most issues can be solved by following these two steps:

Step 1. Update or install OpenXR

A new runtime (104.2012.9003) for Windows Mixed Reality headsets is available since December 22nd. Before running the sim in VR you must update to the latest runtime.

Step 2. Activate VR in the correct order

Launch the game in desktop mode and activate VR in the game:

  1. Launch your VR headset application.
  2. Launch Microsoft Flight Simulator
  3. Put your headset on.
  4. Enter the command to switch to VR (please check your bindings for VR in the ‘VR Mode’ tab in Options > General) or click on the button in the ‘VR Mode’ tab in Options > General.

Note: HTC Vive Cosmos users can run the sim using SteamVR.
Please ensure you are running the Beta versions of both the Vive Console and SteamVR.

If you’re still having issues after following these guidelines, visit our knowledge base articles
VR - Frequently asked questions,
Troubleshooting VR,
or visit the VR forums.

Best regards,
Microsoft Flight Simulator Support Team

No, it’s not stuttering. It is an enforced settings that means slow mouse movements are ignored. This has the effect of feeling like negative mouse acceleration. If you move your mouse slowly enough, you can traverse your entire desk, and not have your freelook view move an inch.

It doesn’t affect just the cockpit view either, it also effects the external camera view i.e. not drone.

I received a slightly different response to my ticket, thanking me for my suggestion, and suggested creating a topic in the “Wishlist”. At least it isn’t an auto-response, otherwise I would have got the same response, I assume.

One thing I would add here is I don’t think the update did this. As far as I recall, it has always been like this. I bought it on August 18th, and one of the first things I noticed was the mouse inertia, momentum in the options, which was promptly set to 0, and this, which cannot be disabled.

My assumption is that this is on to facilitate trying to access small, fiddly cockpit controls.

If that is the case, simply give us an option to disable it, just like momentum, to keep everyone happy.

2 Likes

I never took notice of this till yesterday when I tried to line up the tower to the toolbar menu down arrow.

Basically impossible.

Hello boeingtom68,

If I understand correctly, it seems that your issue is related to the freelook speed option:

Try changing this setting and let us know if it helps or not.

Makes no difference. If you move your mouse slow enough (to do fine adjustments), nothing happens.

1 Like

Hello Ollie

I tried that right away after I noticed that (new&funny) behavior, but it didn’t work unfortunately.

If you move the mouse arrow in the cockpit to click on something, it is perfectly fine. You can PRECISELY position the mouse arrow with SMALL MOVEMENTS.

Before this was also possible when using the mouse to look around in the cockpit.

Now if you move the mouse to move your head in the cockpit it works but it does NOT react to SMALL PRECISE inputs. Try it. It’s easily reproducable.

Compare it to how precise the mouse moves if you’re clicking a switch in the cockpit

Before the VR update it was PERFECT.

Now the mouse seems to have some kind of deadzone when looking around. You have to move the mouse maybe half centimeter and then it will start moving your head. But it will be a BIG initial movement. Try to move the mouse only 1 millimeter. Then another millimeter. And so on. The view will NOT change

Hope you understand it now?

Its not possible anymore to PRECISELY positionin the view.

Greetings from Nürnberg Germany

Yeah, it 's not that sadly.

The two options you have there are speed, and momentum. Speed is like adjusting this option for your mouse.

image

Momentum adjusts how long the view will continue after you stop moving the mouse, kind of like a trackball.

The issue we have is where small movements of the mouse are not detected at all. It’s more like that option you see in my image, “Enhance pointer precision”, in that your mouse inputs are being “filtered”.

I believe this option exists to make it easier to control with a joystick controller, which makes it easier to apply constant input in a direction, in effect acting as a deadzone for the stick. You apply a little more constant input, and the view moves. That might feel fine with a controller, but its awful with a mouse.

I’d like to see some separation between the control schemes for mouse, and joystick controllers. Ideally just leave the mouse alone, and don’t interpret its inputs at all, and stop trying to make an absolute position device behave like a relative one.

I would have to disagree. This issue has been there since I have been using the sim on August 18th. I don’t think it’s any better or worse.

One thing we may have all seen at some time or other, is where the sim has one of its little hiccups, and suffers a micro-stutter for some reason. If you were in the middle of dragging your view with the mouse, your view is suddenly thrown all over the place, way more than you actually move the mouse. My assumption here is that sim continues to apply that acceleration you had initially applied, but is magnified.

Not the same issue discussed above, but another sign of the “consolitis” we currently suffer, to allow for console controllers to drive the interface.

1 Like

Seriously. No.

Then you didn’t notice because you’re NOT trying to set your view precisely to have something certain perfectly in the picture you’re seeing on the monitor.

For example. Bottom left of pfd EXACTLY at bottom left corner of monitor.

It work PERFECTLY before the Vr update

Its also still working PERFECTLY in fast in PREAR3D and in X-Plane

They changed something because of VR. Has probably to do that the Vr picture isn’t that jerky with tiny head movements.
And that slipped into the mouse look funktion also.

I know exactly it’s just that what happened.

And it’s big difference.

Maybe your mouse isn’t very precise to begin with? So you didn’t notice?
Is your mouse arrow also hard to position PRECISELY in the cockpit? If yes. Then it’s your mouse. Or something in your windows

???

That means nothing I’m afraid. No one is disputing this is an issue with MSFS. And no, it’s not my mouse. If it were, it would be doing it on the main menu screen, which it does not.

It was doing it before the VR update, so we will have to agree to disagree. I would accept that it has perhaps got worse, I’ll grant you that only, but it was still there.

Perhaps we could simply agree we both want it gone, and leave it at that?

Back to the issue at hand, it’s not something that easily comes across in video, as you can’t see the mouse pointer, or feel the mouse, as the view moves, but this is a section of video I recorded back in September 2020:

Added timestamp. I’m using the smart cam at first, then zoom with the mouse, and attempt to track by hand, leading to those jerky movements.

You’ll see these short, sharp jumps in the view point. That’s not my mouse, that’s me having to overcome the “friction” of the imposed dead zone the mouse has. Small, precise movements of the view cannot be done until you overcome that deadzone, which then leads to those jerky movements.

Ues we need to agree to disagree hahaha. But still it’s weird. Because I and a few others noticed a big difference.

Weird.

I was on Windows 7 untill 3 days before the sim came out public.

Then I fresh installed windows 10
Its all updated. Alll newest drivers. Rtx 2080 ti. Ryzen 5 3600. 32 gigs of dual rank memory. And since 3 days
RTX 3080 and ryzen 5 5600x.

Really weird that you had this issue since the beginning.

1 Like