Fresh Install Windows & FS2020 CTD


I’m using that version, updated today.

Oh ok so it wont be that, stupid me for reformatting lol l had it install with a few CTD should have left it alone lol…


Also check to see if the MSFS installer (or Windows) installed the VC++ 2015-2019 Runtimes.

Oh yes will check this too.

Just downloaded the latest… will keep u up to date with the outcome


Off-Topic: I see you lost your Alpha title! I’ll get that back for you!

Oh didnt notice but yes Thanks for that.

1 Like

The problem still persists, even with VC ++ 2015-2019 Runtimes installed and updated.

im only at 20% redownloading will let you know what happens

Check your Alpha title. :wink:

LOL fantastic thanks for that

Did your problem get fixed?

lm waiting on my download lve installed it to a different HD but a few updates i installed will see l`m at around 50 gig download. let u know


I was going to send you this but saw your LOL response and didn’t
know if it was solved.

This may be helpful in the future.

I install:
C:\ with Win 10 and Office 365 only
D:\ with FS2020 only (D:\FS2020)
I had a problem and reinstalled Win 10 on C:
Since I now had lost any reference to FS2020 on C:\

I went to MS Store and downloaded FS2020 again.
I was dreading having to download that 127 GB again.

It downloaded FS2020 again but only the initial 9 GB (don’t remember the size)
It then asked where to download FS2020 again (don’t remember what it said)
I told it to go to D:\FS2020

It kind of flickered quickly and then started FS2020 on my PC.
I guess it saw it already there or ran a file check or whatever.

But FS2020 started.

Cool thanks for that… let see what l did fixed it Thanks again

Does your windows username contain Unicode/special characters ?

No not at all.

Thanks mate

Part 2

Ok guys so what l did was the following:
Formatted all drives again.
Instead of using Microsoft`s settings to reinstall my windows l went into my old usb stick to delete the drives and reinstall windows 10 from that.
Install all windows updates and Nvidia driver updates.
Reinstall flightsim 2020 for the 4th time on its own HD.
when l launched the game came up as an error Flightsim ran into a problem, now l restart it again and it CTD at around 80%.

l have never in my life had this problem with any flightsim this is a complete joke… This has to be from Microsofts/Asobos end. The way l see it, when l had the old version installed it worked when l got the updates it still launched but on the occasion l had CTD…
So now that l installed the full install of MS2020 i just get CTD with no error.

This simply cant be from my end, its such a clean install of everything.
Any thoughts would be most welcomed, Asobo Please look into this, this is in no way fun anymore.

Thanks All.

this is the same with me did a small update yesterday in steam i think it was around 350mb sim wouldnt start .deinstall it and formated hard drive reinstalled it starts but flickers on the bottom of the screen and nothing never had a problem with it before might be the update that did it for me …ive got all the latest drivers installed

Yep seems to be the same do a full install and its done wont work, IF you have the old sim and do the small updates it will be fine till it CTD…
Sorry its happening to you but it helps me…

Many Thanks mate