FS only detects analog input in "sensitivity" module & not in game

CH Flight Sim Yoke USB is detected by the system & is properly calibrated. All axis & buttons function in other games including FSX. In FS2020 the Flight Sim Yoke USB is detected but inputs are not working for actual game play. When I hit the “Sensitivity” button in-game, the axis inputs all appear to function (see attached). However, when in the controls mapping dialog, the inputs are properly mapped but no motion of the yoke or throttles is detected. During gameplay, no control surfaces move & throttle, prop & mixture actions do not function.

When I attempt to manually select the known/correct axis for flight control surfaces I get an error that says “Warning: selected axis is not recommended for this action.” (see attached)
When I validate the choice, despite the warning, there is no change & the axis inputs do not function. Only when I go back to the “sensitivity” dialog, do the inputs appear to work, never in the control mapping dialog & never for actual game play.

In this example I’m attempting to configure the “Aileron Axis”, but the outcome is the same for which ever axis I try to configure.

By default, in the controller mapping dialog, the Aileron Axis is defined as “Joystick L-Axis X” & as mentioned I get no input. When I move the yoke, the slider indicator in the control mapping table remains centered and does not move (again, analog motion is only ever detected in the “sensitivity” dialog) (see attachments).

If I select “Aileron Axis” & choose the option to detect an input by clicking in the “search” field. Then I move the yoke handle to the left and the game detects that action as “Joystick L-Axis X-”. When I validate the choice, the analog slider is gone and movement of the analog yoke axis is detected as a button press, on or off only, not as analog input. (see attached)

In FSX, & X-Plane, the CH Flight Sim Yoke works perfectly. The Windows 10 Joystick calibration utility (joy.cpl) detects and calibrates successfully every time. I also tried using the CH Products calibration utility and that also works perfectly. This is definitely a software issue with FS2020.

Again, analog motion is only ever detected in the “Sensitivity” Dialog & nowhere else. The same is true for all analog axis on the CH Flight Sim Yoke.

For good measure I tested with a Saitek Pacific AV8R Joystick & analog axis do function correctly in FS2020 with that device.

I made a video of all this to demonstrate, but apparently “new users cant upload attachments” (FML)

I would very much prefer to use the Flight Sim Yoke, since it very clearly works everywhere else.

Please advise & Thanks!

Hi there. No attachment is seen in your post.

Also - a massive thread here with the same error might have answers:

I’ve read the manual setup threads & tried that. it doesnt work for me. my issue is different. see the youtube video i linked to. Would upload the video here (and screenshots) but no uploads for new users on this forum.

I use the CH Yoke, no problems, never even ran a calibration. I’ll fly later today and get snapshots of my setting for comparison, but from your video, something is clearly wrong. My yoke is probably 5 - 10 years old. Maybe try CH Products support, there must be a ton of these in use, maybe they have a solution…

Yeah, only thing I can think of is my yoke is closer to 20 yrs old & is probably a very early revision (s/n 13513).

Still though, my yoke works perfectly in the windows calibration utility (joy.cpl). It also works perfectly in every other game including FSX. Very frustrating & I do NOT want to buy another yoke. :face_with_symbols_over_mouth:

1 Like


I called CH Products (APEM) & spoke with John who helped me get this sorted out.

Steps to fix were as follows.
-Start game
-Click “Options”
-Click “Controls”
-Click “Preset Manager”
-Click “+” to create an entirely NEW & BLANK profile
-In a completely NEW profile with ZERO assignments, assign axes & buttons as desired.

The issue I was having was that I was only ever attempting to modify the pre-defined “Default” profile. John from CH explained that the default profile is bugged & the only way to set things up is to create a NEW & COMPLETELY BLANK profile and work from that. John also advised that Microsoft is aware of the issue & supposedly a patch is forthcoming…

The CH Flight Sim Yoke USB is probably the most widely sold yoke on the market & the fact that I’m still using mine after 20+ years is a testament to its quality of construction.

John from CH said he’s taken thousands of calls about issues with FS2020 since its release in August. Shame on Microsoft for failing to properly implement a working profile for this device & foisting the troubleshooting onto the limited resources of CH(APEM).


Thanks John & CH! You really helped me out!