FW Aircraft Throttle Problems

I have 3 add-on freeware aircraft, all from the CBFS hangar (or their mates) and since SU10 I’ve not been able to fly any of them - the throttle just does nothing.

I’m talking of the Seahawk, Meteor and Vampire. All of them will start and run, but none will respond to throttle input.

Switch to one of the default aircraft or 3rd party ones such as the Twotter or Kodiak and all is fine.
It’s logical to think that this may be due to something changing in SU10, but I think one of them was released after that update (though of course, it could still be only SU9 compliant).

Anyone else? It’d be nice to have confirmation it’s some kind of bug.

edit: I did have the right engine suddenly jump to maximum power once in the Meteor, and even managed to take off in it on one engine, but it soon dropped back to idle again.

Have you tried with an empty Community folder, and only one of the three aircraft in the sim.
This could be a mod conflict.

I haven’t yet because all that’s in my community folder is up to date payware models and these three freeware ones.
I really just wanted to know if others where having the issue with these planes so that I could prioritise the troubleshooting steps.

I’ll try them separately though, but if no better I’ll just have to delete them, though I will report the issue on Flightsim as well. I know they are more “dipping toe in the water” than dedicated products, so it’s not really a surprise if issues arise.

1 Like

No - I tested them this evening and the only freeware model that works properly is the OZx Goose. All the others respond to all control inputs except the throttle. I tested them all individually with the others removed.

Vampire FB5
Meteor F8
Hawker Sea Hawk
Restauravia Fouga Magister
Restauravia Nord 3400

Maybe they need the legacy flight model? If so I won’t use them. I know I won’t remember to switch it back and forth.

1 Like

Certainly worth the try to find out, just switch it right back after the test.

1 Like

*With Honda Jet for start or cut out the throttle I need to use a mouse. It’s not a problem, but usually I just only use the Xbox control for everything. It’s like a posición that is easy using a mouse.

By default MSFS maps the “Throttle Axis” command to your joystick for the throttle, but this doesn’t work work with some 3rd party aircraft which require a different command.

You just need to map commands “Throttle 1 Axis” and “Throttle 2 axis” both to your joystick throttle axis. Luckily this works for default aircraft as well, so there is no need to swap joystick profiles back and forth after you have done this.

That’s how I’ve had it from the start. I use a Virpil T50 CM throttle (which splits to two throttle grips) and always assign the 2nd throttle when one is available like it is in this sim, so I doubt if that is what the problem is here. However, I will check it hasn’t been unassigned in an update as I don’t think I’ve checked for quite some time.

Encouraging, if a little confusing, news.

I checked the 2nd throttle assignment and found no change - still assigned and responding.
I then switched to legacy flight model with the Vampire and it worked. I then switched back to Modern flight model and it still worked!

I’ll test the remainder of the older models and see what happens.

No, I won’t bother with these models, they are too much of a pain and in all honesty wouldn’t get flown that much anyway.
When I restarted the sim the Vampire wouldn’t work again. Had to exit and restart and then it would - only in Legacy mode. I switched to the Dragon Rapide and found that it would only work in legacy mode - and then only one engine, and even that would regularly flip back to zero throttle until I worked my throttle controller through its axis again - then it worked for a few seconds before flipping back to zero again.

Weird thing is that I converted these models myself and they all worked well, with the modern flight model. Mind you, that was a year ago, so maybe updates have changed things. In any case, it’s not worth it to me, messing around and them being unreliable, so I’ll just keep using the default and payware aircraft in my sim. I have enough of them, but it’s still a shame.

1 Like