G Hub Installed Games Scan doesn't find MSFS

Scanning for games doesn’t find MS FS 2020 so where do I “browse” to find the “exe” so G Hub autosenses MSFS and its assigned profile? This is the MS Store version. Not the steam version nor the non-DVD version.

1 Like

If purchased directly from Microsoft:

drive letter:\WindowsApps\Microsoft.FlightSimulator_1.7.12.0_x64__8wekyb3d8bbwe

If through Steam, you can right click on the item in your Steam Library and look at the properties - one of them will be the Local Files tab. You can browse the local folders to see the path.

If you are referring to Logitech Gaming Software, no it does not only earlier versions of FS. It also does not find the G13 game pad in FS2020 controllers.

New Problem: Now that I can browse to the :\WindowsApps\MicrosoftFlightSimulator_1.9.3.0_x64_8wekyb3d8bbwe\FlightSimulator.exe location G Hub cannot save the location due to ownership problems… I am very fluent in changing file permissions but none of the old tricks seem to work with MSFS…

This appears to be a problem unique to the Windows Store/GamePass version. Not sure what can be done for that, I believe they’re protected and/or encrypted as opposed to Steam version.

Guys, I found the st graal

do the second method, put your session username in the box to “check names” (typing administrator doesn’t allow your current session the authorisations)

EDIT : actually, you can access the inside of the windowsapps but the logitech g hub still can’t have access to it… guys buy it from steam, much easier, not the ms store…

Correct about diving right in but being able to select the exe is not allowed and all attempts to change ownership or permission to the app fail…

I got an update for G Hub today and it said MSFS2020 is now supported. But again, “Scan now” does not work and adding MSFS2020 manually gives directory permissions rejection.

FlightSimulator.exe is 0 size.
C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.14.5.0_x64__8wekyb3d8bbwe\FligthSimulator.exe
Blocked by permissions.

Googling how to fix this.

I have tried PowerShell Admin permission hacks to no avail…,

What exactly do you expect to gain using the G-Hub profiles? I have the G502 gaming mouse (have had for several years) and although it’s a very good mouse, I’ve always found the Logitech software to be pretty sad and at least for me, it’s not worth the trouble of configuring. It maybe though, that I simply don’t know how to use it properly.

PropDust - Yes we can now set mouse action to FS but have to manually select the profile before flying and switch back after flying… Could have done that without them naming a profile… It is all about permissions with this file…

danzio56 - I am sorry you have had difficulty customizing Logitech devices - a difficulty I do not share. My other Logitech profiles work perfectly for digital painting and photography. My goal is to never have to rummage around in the cockpit and five extra buttons on the mouse help.

I have been working with Logitech technical support. They raised my support ticket to 2nd level support. 1st level just wanted me to uninstall and reinstall GHUB.

I did some more digging. I believe I know what the problem stems.

When I upgraded to Premium Deluxe, the install program moved the files to my D: drive and the directories in the above path show a link that goes to.
Secondly, my C: Drive is encrypted with Bitlocker and the new install on D: drive is also encrypted (green).

I believe GHUB wants to see the executable but it cannot in this case.

I checked permissions and I can take ownership of the directories but not flighsimulator.exe. I cannot change or take ownership of that executable. It is owned by Administrators and when I check Edit, everything goes greyed out.

Or, may be I just don’t know how to get past the Advanced File Permissions. I am guessing now that Logitech support will want me to disable Bitlocker, which I will not do because I know that is a bigger hassle than wanting to use the mouse buttons for some MSFS features.

I do not have bitlocker and I can do advanced permissions with so many other files but MS has this exe locked up tighter than a drum and seeing it is not enough for GHUB. So until MS unlocks this exe or GHUB gets happy with just seeing it and not accessing it then we are toast…

1 Like

BTW I did get an email from MS on my bug report asking for details but so far nothing after that…

1 Like

Well, after 20 back-and-forth emails with Logi Tech support, they gave up. They suggested I work with forums and Microsoft to solve their problem. I sent the details back and explained my level of understanding is higher than theirs and copied Logitech CEO.

They re-opened the closed ticket and will “… escalate this to our product specailist and see if they can provide us an additional troubleshooting steps” (with Spelling error).

A lot of people hate G-HUB, as I did when I first got the G604 mouse. But I have been able to make it work for other games and know it has some good potential.

Patience may prevail? I just have to remain persistent.

OK, I finally got some answers. The problem exists because of Bitlocker. The solution for me would be to disable Bitlocker. Not going to happen.

He told me an alternative that will work. In G-Hub, create a duplicate copy of the Desktop profile and name it MSFS. Change one of the buttons to switch profiles. Change the other buttons’ function as needed for MSFS. So far, this is working for me. I just to have to remember which profile is active. There is a G-Hub notification-popup whenever the profiles change.

I’m glad I found this thread and I’m not the only one having this issue. Not happy to hear this issue still exists even after adding “MSFS support” to G Hub.

@PropDust I believe what they told you about BitLocker is not true. I do not have BitLocker enabled and I have the same issue.

By the way, I wonder why other applications, including Discord, can detect MSFS is running, but G Hub can’t?

Not sure how they “search” for games, either.

I tried that solution and switching back and forth was not a problem. I haven’t used it since getting a new Logitech X-56. There are enough buttons on this controller to handle what I need.

Good luck.

The Bitlocker theory is nonsense and simply their excuse because they apparently don’t know how to fix it. The real culprit are Microsoft’s permissions. I don’t use Bitlocker and I’ve got the same issue.

P.S. Please don’t mess with the permissions. I tried and all I achieved was messing up the permissions completely to the point where MSFS wouldn’t even run anymore. I had to restore a system image to get it working again. I think the best solution would be to open a support ticket with Microsoft as they are probably the only ones who can actually fix the permissions thing.

1 Like

I have the same issue. No matter what do, even manually trying to find the file my G hub just won’t connect. I really don’t understand what I can do if anything and not sure if anyone got a fix? If not guess will file a support ticket