G-SYNC causes subtle yet rapid flickering

Are you using Developer Mode or made changes in it?
No
Brief description of the issue:
When G-Sync is turned on in full screen or windowed mode, the sim window flickers between normal and slightly darker. This only started happening after World Update 3. Issue can be worked around by turning off G-Sync globally or for the game.
Detail steps to reproduce the issue encountered:
Use G-Sync/Freesync monitor and turn on G-Sync in NVIDIA settings as well as for the game. Load into the game. Observe flickering.
PC specs for those who want to assist (if not entered in your profile)
RTX 2060
I7-9750H
32GB RAM
VIOTEK GFV27DAB 27-Inch Monitor

There are no GSync settings in the game. It is generally recommended to have GSync and VSync enabled in Nvidia Controller, and VSync disabled in the game settings.

2 Likes

Try to set VSync to fast on Nvidia control panel, I have it set to that and I haven’t noticed any flickering.

My G-Sync setting:
image
V-Sync:
image
V-Sync ingame:


Still getting flickering here and there.



I am working with these settings and I am not getting any noticeable jaggies or tearing or flickering.
(would love a few extra frames doe)

Noticed this now too. Yesterday i haven’t noticed it though. I changed nothing too my ingame settings or nvidia settings(all default/gsync enabled)

Anyone who’s using gsync together with vsync doesn’t get the point of gsync though.

Gonna try g sync off now. Hope it helps. Specially with clouded weather is’t really annoying. Gsync doesn’t seem to work properly with msfs anyway in terms of smoothness so…

Flickering is gone with gsync disabled. Though i want to take back my words about gsync not working woth msfs… Stutters are more noticable now and overal experience is less smooth… Specially when fps drops below 60.

Anyway flickering only seems to be present in aircraft with glass cockpit or in the menu. Analog cockpits seem to not be affected.

We’re gettin to spoiled with these 144hz gsync monitors and games that are actually optimized to run smooth👌

I’ve noticed it too. And only after I installed the latest update today. It flickers on the main setup screen before the flight and on the load screen (quite a bit) as the flight is loading. It flickers inside our outside of the cockpit so I don’t think the glass cockpit has anything to do with it. I was in the Cessna 172 with the G1000.

I’ve managed to reduce it using CRU (Custom Resolution Utility). It allows you to set your “v-rate” which is some hz range the monitor’s g-sync/syncing capabilities can take. I’ve lowered it from 48 to 20 and this seems to have eliminated most flickering. I’ve also set VSYNC to off ingame, and fast in NVIDIA.

I had this issue after yesterday’s update - it’s more common with VA panels.
I also read about a recent Nvidia driver update changing how things are rendered and v-sync so downgraded to the driver version before and it has resolved the issue for me.
I was on the latest 461.40 but read in the following article about a change in rendering with 461.09 onwards so I went back to 460.89.

Older drivers:

https://www.nvidia.co.uk/Download/Find.aspx?lang=en-uk

1 Like

I turned off G-sync on my Nvidia control panel and that got rid of the fluctuating flicker. I don’t know how much a difference that’s making in performance. I don’t see any noticeable difference off the bat. I have a RTX2080 Super with an i7 9700k

Same problem here, worked fine before this latest patch (nothing changed here same drivers same settings etc.) Not going to turn anything off except MSFS :wink:

1 Like

G-sync never worked for me until this update. Using the ‘is G-Sync on overlay’ was always hidden with FS2020 but since World Update 3 it shows up. Could be you were using Vsync before and now you are actually seeing the frame rate adjustments which could be explain the flickering.

This seems likely. However since G-Sync now “works” in the sense that it activates in FS2020, I wish it would actually work and not flicker, lol

I downgraded my Nvidia drivers to 460.89 and flickering and stuttering issues are gone. Might be worth a try.

Thanks, I’ll give it a try

This is a well known issue with GSync in windowed mode.

My Dell 144Hz gsync does the same if I turn it on for windowed mode and running app with GPU-acceleration. Notably I saw this very bad with PowerBI Desktop.

Given the avg FPS of the game is so low, I would just turn it off. Also you really dont need the latency benefits on a non-combat flightsim.

Edit: It seems to be an artefact from the change in the rendering pipeline. I read (somewhere else here) they changed some part to flip instead of copy (the former being much faster) in the latest update.

1 Like

Huh, that worked for me too. It’s not ideal… but I’ll take it since I can leave G-Sync on :slight_smile:

Reported up to see what we can do on our end.

Best,

Royal

3 Likes

Ive also noticed, for the first time after the update that my mouse feels very sluggish with gsync enabled in the sim. I’ve always had it enabled and just assumed it always worked. Perhaps it only started working after this update? The sluggish mouse is making the whole experience feel weird and slow. The mouse is now tied to the FPS/refresh of the sim and not the native monitor refresh rate?