G1000 Issues, (I think its a G1000 lol)

Hey there, Ive been having this issue in a group of aircraft. I have no community addons installed and its happeneing no matter what I do.

Try to remove the aircraft from your content manager. Exit the sim, then restart the sim, and redownload the aircraft from the content manager again.

1 Like

Will do, Thankyou very much!

Getting this also, not mid flight thank god. But upon starting aircraft sometimes nothing on any of the mfd’s. Flight restart fixes it but annoying none the less.
All vanilla game

I also have this problem, does anyone have the solution?

Ik heb het zelfde probleem bij al mijn propeller vliegtuigen. Heeft iemand een vriendelijke en/of duidelijke oplossing?

Already hit this from time to time, sometimes it’s just 1 screen that is off
With both G1000 or G3000 (C172, Longitude), I also saw that on 787
Can be when starting on runway or Cold and Dark
It is as if something does not get loaded correctly at start, or in the correct sequence
I suspect but not sure, that if you leave the video playing a bit, before clicking on the “Ready to Fly” button, this is more likely to happen

Like that, for instance:

Only way I found then is to abort and restart the flight

I could not get the G1000 to work in any of the aircraft that has a G1000!! Tried to abort and restart without any luck. Is there another work around?

Hello - there are many things to try. One is to remove all your Community Mods and see if one of them is conflicting with the Garmin.

This is also the G3000 you’re asking about (as the cockpit indicates you’re flying the Daher TBM), so it’s not exactly the same Navunit, but the troubleshooting concept is the same.

If your community folder is emply, does this situation persist if you use Assisted Checklist (AI) and let the AI complete all the pages automatically for you? I was going to suggest the quickstart CTRL-E, but it’s not working in SU5 for some reason.

Once you get the screens back, as a quality of life change - I suggest upgrading to the Working Title G3000 0.7.4a mod, which greatly improves on base functions.

Thanks for your suggestions. I will start troubleshooting!!

I removed all the Mods from my Community folder and now everything is working ( G3000 unit ) perfectly. I will now upgrade to the Working Title G3000 07.4a mod. Thanks again for your help!!

Have you tried to go to the marketplace and claim and install the free G1000 NXi content?

Yes, which is a little confusing, to me anyway!! I downloaded the Working Title G3000 0.7.4a Mod and installed the G1000 NXi. It seems to me that they should not be compatible - G1000 vs G3000?!!

But your initial post was asking about not getting the G1000 to work, not the G3000 which you seem to have installed. Are you asking about the G1000 or the G3000?

OOPS!! It looks like I upgraded the C-172 from a G1000 to a G3000, if that’s possible!! I was having a problem with the C-172 G1000 not loading - screens were blank. I then downloaded the WT G3000, and it’s working perfectly in the C-172. Should I delete the G1000 NXi or the WT G3000?

I’d say just pick one that works for you. Don’t put both in.

OK!! Thanks!

Is it possible to enter Airways in the G1000 NXi ? I cannot find how to enter the Airway. Thanks!!

For NXi questions, please join the Master Thread.