G2 and OpenXR Developer Tool

Running the OpenXR developer Tool with latest preview on, custom render at 80% and reproj disabled…using the G2 reverb - not particularly happy with smoothness (reproj off and on) so was just wondering:
1)I have the display frame timings ticked - and I noticed with reproj disabled was getting a reasonable framerate 30-45fps - although the display box is usually red (have seen it go to green or blue sometimes in low intensity scenes or even in menus) - just wondering what this means and how the performance can be improved with reproj off?(note have a 2080ti gpu)

2)Have tried enabling reproj - but despite reasonable fps (seems to jump around 30-45fps(top left digits) )does not feel very smooth with reproj disabled feeling much smoother - notice the fps screen also seems to displays red and I notice on the compiler section seems to jump between reproj depth to reproj motion? - the later being the smoothest but its not always achieved with full reproj depth the most common display …just wondering what all this means and how I can improve (smoothness+performance) with reproj enabled which I assumes should give the best result?

3)By enabling use latest OpenVR runtime assume this just means its using a beta runtime?

Ok try and turn openxr down to 70. What do you have your renderscale in game set to? And what are all your other settings set to. If you keep the readers ale set to 100 in the sim and reduce it in openxr you will notice better performance as you go down in openxr. You have to try and find a balance between frames and visuals at the moment.

You can also try and roll back your GPU driver to July 2020 and that seems to help me and others on performance in VR. Good luck


1)thanks will take the render down to 70% in OXR…whats your experience of reproj in OXR? (my on is it seems broken or do you need to hit 46fps for it to work?
2)assume you mean keep render at 100 in game? - note in game most of my settings are close to the default (mix of low and medium)
3)in the OXR frame overlay any idea what some of the things I am getting mean? - the overlay appearing in red might suggest to me something is wrong (there is a blue and red version but still unclear on the significance of these colours) - also when I do try reprojection in the the compositor section of the frame counter its jumping between “full motion reproject” and “full depth reproj” again this is suggesting to me something is wrong - as this is not smooth means for the moment I am not enabling reprojection - this all can not be low FPS related as since the last update my avg fps has gone from around 30 to 40!

1 Like

Openxr 50, Reprojection disabled; FS 100

I find 50% in useable because I don’t get enough depth perception and the screen twists and distort when moving my head. Doesn’t seem to render far enough away.

thanks - these are the settings will try (currently have issues getting into the menu screen but will try them when I finally get in!)
out of interest what fps are you getting to make everything run smooth? and do you have any idea what the different colour and compositor settings in the OXR fps tool

Between 30-40. I dont know or use other tools except the render scale slider.

actually gave it and try at 50% and 100% in game and it ran well (very smooth) - strangely I didn’t get especially higher fps (think in the OXR frame count app this is the two numbers (post and pre I think) with the hz at the end of them) - but it ran much smoother.
did you try and run with reprojection enabled and if yes how were the results?

Reprojection made it jittery for me so I turned it off.

had a similar experience with reprojection seems to jump between red and blue/green on my frame counter- which I think means its struggling to work so it sometimes appears very jittery (especially over cities or big airports) - so have disabled

Hi, I give a try to the OXR tool. Reprojection on automatic and 50% render scale. It is really smooth but clearly unplayable for me because of the motion sickness. Does it come from the render scale or the reprojection (I guess repro). Maybe it’s the automatic option that move disabled to enabled and produce that sensation ? Did you have the same problem ?

Ok, So I reply to my post just in cas it will help somebody. Turning the reprojection ON (or automatic) in OXR is responsible of the sickness and the “zoom effect” when you move your head and also the reason to smooth experience when you look the ground. So sad, I can’t have a great experience without motien sickness. Just for the record (AMD Ryzen9 5950x+3090FE+32G 3600 mhz RAM and Reverb G2).

Do you think it will be better with futur update ? Or it’s just the VR and the power needed to run MSFS2020 ?

Edit After 3 hours : just turning on the first option to get the pre-version of OXR and stay all the other option by default help a lot for a smooth expérience. Just move the render scale to 60-80% in the game option si smooth at 30-45 FPS all over the world

Check out this thread. Lots of good info with regards to performance and tweaks.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.