OXRDevTools- Frame Display and Reprojection not adjusting

I am afraid that my DevTool settings aren’t actually changing my simulator experience. When the sim is running, and I change the render slider setting, Reprojection setting, or the Frame Display setting, I don’t notice any change, and a window doesn’t pop up in headset or on desktop for me to see frame data.

Have I possibly installed it incorrectly? How can I verify the program and the settings are running?

I am running MSFS VR through WMR, and Steam (not SteamVR) and OpenXR Dev Tools on a Reverb G1. I followed CptLucky’s WMR setup guide.

Have you tried to switch out of VR and close WMR after you made the changes? Then alt-tab back into VR and the changes should be active.

Thank you for your reply!

Ctrl+Tab in and out seems to be the key to activating new settings in OpenXR.

1)Set setting in OpenXR Dev Mode
2)Ctrl+Tab to activate VR mode
3)Ctrl+Tab to exit VR mode and then change OpenXR Dev Settings

Unfortunately, doing that in flight seems to crash the program, but I can do that as much as I want in the main menu.

Now, with reprojection I am noticing a very weird rendering effect I think? The world “warps” when I move my head around, and doesn’t seem to act in a euclidean manner in which I inhabit a space that i can move around in and other objects positions don’t change relative to my position.

It seems in this post, it is referred to depth reprojection (which may be what I am experiencing?)

As well as reference to this phenomena from a couple members in this thread

And now that I see it, @CptLucky8 mentions it in this post, though his description didn’t immediately pop out to me at first as it being this phenomena

Unfortunately as of today, this still seems to be an unavoidable issue when using reproject.
Edit 1: Make sure OXR Render Scale is >= 65% to avoid the warping

I had the same issue with reprojection initially. The trick was to lower OXR render scaling to allow the reprojection to add frames, as CptLucky points out the reprojection adds extra load so you can’t just switch it on you need to buy back some performance first. After that it’s trying to make frames as smooth as possible so reduce graphical settings which increases CPU load.

I think some planes have a better reprojection experience as well, the JMB VL-3 prop messes up more than the cessna 172 or the robin dr400 for me anyway but if you have a plane which doesn’t have a prop out the front window like the icon a5 even better.

Overall I like reprojection and I’ve got to a state were the smoothness of the flight trumps the reprojection artifacts so I’m happy but it wasn’t always the case. I have a G2 and 2080 Ti.

1 Like

I think I just ran into a post of yours a few days ago saying that this depth perception warp wouldn’t happen if OXR render scale was >65%… I’ll try that when I wake up and report back.

1 Like

if OXR render scale is >= 65%

1 Like

I can’t get VR flight to run with a render scale in OXR set to 60% or greater, it just keeps crashing. I am able to use the main menus though.

I was able to exit and reenter VR successfully ONE TIME in flight when OXR and MSFS Render Scales were set to 50%. What is making this increasingly more difficult is the fact that I experience a CTD anytime I re-enter into VR Flight on the same session, or set OXR to 60% or greater and the begin a VR flight.

This is also further complicated by my lack of trust in the stability of the software and any results I report here if I don’t fully reboot my computer between any parameter change, but I don’t know exactly how much I should be worried about that idea.

I think I’ve decided that the artifacts I observed in the main menu when OXR is at 65% and motion reprojection is on is not be something I could ignore. The stable and smooth experience I get with OXR at 50% and MSFS at 100% is still something I think is really great overall. I just wish I could experiment with the different Render Scale Ratios posted in the G2 guide without crashing.

For those who come back to this page in the future…


Follow the CTD guide on Zendesk all the way. My rate of CTD has decreased dramatically and now the game is way more flexible for me than it was when I was writing the above posts. I did three things (I haven’t done further testing to narrow down exactly what fixed the problem though):

  1. Make sure your Windows drive has ample room (my drive was practically full)
  2. Remove any partitions you may have made on a seperate drive for Page File purposes (remember the FSX tweak days?)
  3. Page File/ Virtual Memory Allocation

The Zendesk guide says to have Windows automatically manage paging file size for all drives. If I remember correctly, that didn’t quite fix my problem, but I may have only selected it on my Windows drive, as well as only booted in MSFS once after a reboot (maybe that wasn’t enough info to properly automatically build a page file?)

Anyways, I know this is inefficient and borderline stupid, but it is also part of the actions I have taken to reduce my CTD and right now I don’t care to change it: I have a custom page file size of 32 GB on each one of my drives. My system has 16 GB of DDR3 memory, and the partition I had set up beforehand only had 5 GB of data set aside for the page file. I do not remember whether or not other drives had page files, I am guessing that they did though.

Additionally, I found the motion reprojection artifacts to be minimal and practically non-intrusive. What I had initially observed in the main menu was wiggling lines, but I definitely am not experiencing that now. I have motion reproduction set to always on.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.