GA Flight Training lesson 2 bug can’t advance in lesson

Hello -

Just installed msfs 2020 finally and going through the GA lessons. In lesson 2, there is a step where you have to maintain altitude and adjust rpm to 2300. There is a brief cut and the autopilot hands over the controls.

Under no circumstances have I been able to add power and get those rpms up. It’s handed over with the rpms below 500 at full throttle despite displaying 2xxxrpm in the instruction setup. Inevitably, the plane crashes.

This means I can’t pass the ascent phase, and go to the descent phase and finish the lesson. I have viewed the lesson on YouTube and the person was given the plane at the appropriate power. (Also, some of the instructions are slightly different. In the video on yt, the plane is pegged at 6000’ when the copilot says it is at 6000. In mine it is between 5800-5900 every single time.

Curious if this is a bug or I’m missing something here. Could the update have broken some of the relevant flight dynamics? I can skip over the lesson, but I want to finish them all.

Hadn’t seen this on the forum. This was a clean install and the. The big update overnight.


(Reference video on YT that I’m comparing against)

Did you assign a slider for your throttle? If not then try F1, F2, F3, F4.

I am using the appropriate keys and see the throttle animation moving. In, out, midway. Crash.

I had my Son-in-law run through the lessons. Lesson one went fine but on lesson 2 which said it was 7 minutes in length completely shut down the program at around 2 minutes. We restarted the program and tried again with the same result. The next day he came to my house and tried again with the same result. I then decided to affect a free flight in the Cessna 152. Once cleared for take-off I couldn’t make the airplane take the active runway. After a couple of minutes, the program once again completely shut down. I am not sure this post is appropriate if not please let me know where and how it should be addressed. It appears this is the same issue mentioned above.

Was just able to complete the lesson without any issues, If I had to take a guess you likely having something bound to the mixture controls by default that is effectively shutting down the engine when it hands over. What controls do you have plugged in to your PC when flying?

I am only using a Honeycomb Yoke and the keyboard and mouse.

I do not have my throttle quadrant yet and I can confirm the mixture rod can be pushed and pulled, but with no result. Even if I set the throttle and mixture exactly to where the lesson starts (as it is supposed to be when you get the controls handed over), I just continually lose power.

There are no circumstances where I can power up the plane.

My program stays open and I have the option to retry the lesson. I have restarted the computer, the program, etc. Computer is one day old, all updates applied, same with MSFS. My crashes are into the ground, not CTD, so I’m unsure if the other poster has a similar issue as I do.

Boy, I’m a real ■■■■■. I’m going to leave this solution for other Honeycomb users.

The lessons use your mouse and keyboard as controls, but the Honeycomb Yoke does work in pieces. One of those pieces that works, despite being dropped into the lesson with a fully powered plane…is the starter switch.

Resetting the position of the knob and switches on the yoke allowed me to fly and continue the lesson.

1 Like

Please advise if there is a solution when the only controls I have are keyboard and mouse


Every time I try the GA Flight Training lesson 2 (Attitudes & Instruments) the teacher has control on the aircraft but he doesn’t hold altitude and crashes.

He explains me the instruments but while doing this the aircraft crashed every time.
It is not possible to take control to avoid crashing.

I have no such issues in the other lessons until now.

Is there a general known issue with this flight lesson 2 in GA?

Thanks for your feedback.

1 Like

Hi - this is a known bug. Just continue with the other lessons for now.


Hi. Thanks for your confirmation :+1:

After the recent upgrade to I experience exactly the same problem as there is no user interaction with controls. The Attitude Indicator shows about 3 degree below horizon and there is no way to pull the yoke back to correct the decent. When is the fix due?

One possible work around is to use your mouse to pull the throttle in the cockpit at the beginning of the lesson.


I was dubious of you resolution, but I tried it and did not work. The main controls are locked out including pitch and power.

Have the same damm problem … how about all lessons

I noticed this problem too today, glad others are having it too I just thought I was being stupid. Hopefully it gets fixed soon.


Hi, I have just purchased the Deluxe version that took a while to load but as a beginner I headed for the training section, I did the camera views first bit ok but on the second bit a box comes up saying that the Co-Pilot is flying, then the woman starts telling you about the instruments, however she never finishes because the plane crashes every time, even from the beginning I am watching the Altimeter going down, surely this is wrong or has the Co-Pilot passed out, please Help I haven’t got very far…


It’s fair to say the trainings have a few bugs. When I did the second training session, she would lock my controls out and dive into the same house each time. Not helpful.

Only way round it was to quickly use the mouse to manipulate the flight enough to keep it in the air until she passed me controls.

Secretly I think that’s what a real teacher would do in real life. Would definitely keep it interesting

Wow that’s brilliant £100 for a piece of software that doesn’t work, so I have to try and take in everything she is saying about the controls and somehow try to learn how to fly the thing on my own at the same time ? It tells me it has been around since 1982 but in that time they haven’t managed to get the first part of the software to work ? It doesn’t really impress me


Noob here…thx in advance for help.

I am flying the second training mission. The instructor has me look at some of the instruments…which is great! But while I am looking, she flies the plane right into the ground.

I do not have any control of the plane…I can look around all I want, but the result is the same…death.

Any way to get the instructor to not crash the plane?