Game Crashes at Launch

Both topics describe the same crash to black screen on start up…? Dont see where you think I’m talking about 2 different problems…?

It did actually manage to start yesterday randomy, 1 in 50 chance to work? Sounds to me as if its a wider issue? Changed nothing in between it working then back to normal crash within 2 secs of getting a black screen on startup

Checked both windows update and game update

i can tell you that im up2date with windows sincd 14.07. and this changed nothing with the blackscreen and ctd

the OP describe a new install on a new PC system.

You describe now a random issue, which also differs to what the OP reported in the other topic.

Black Screen can caused by different reasons, therefore I mention it :slight_smile:

There was a server issue, as the moderator mentioned, but this is marked as fixed.

If you still have the issue, just check the windows event log and post the error. A lot of things can happen, who knows :wink:

Thanks for your reply
Where can I find the error log?

When I open the game it shows a black screen for about 5 seconds then closes without any pop ups, or warnings. I have also installed the English US language pack but that makes no difference. Do I need to set it as my Windows display language (I currently have it set as English UK)

currently errors are only logged within the Windows Event Viewer ( example howto https://www.howtogeek.com/123646/htg-explains-what-the-windows-event-viewer-is-and-how-you-can-use-it/ )

Go throught the folders shown in left panel and search for Flight…Sim Errors. May be you have a summarized “Admin… View” :
image
Important is then the message printed in “General” Tab right side.

no… precondition is only that US is installed. Your windows can still run in your main language.

If installing was not helpfull… hmm… but let us have a look into the error message first :slight_smile:

I found the most recent error. Here it is:

Faulting application name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x60c0b1e3
Faulting module name: ucrtbase.dll, version: 10.0.19041.789, time stamp: 0x2bd748bf
Exception code: 0xc0000409
Fault offset: 0x000000000007286e
Faulting process ID: 0x375c
Faulting application start time: 0x01d77a54cea1f231
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.17.3.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\WINDOWS\System32\ucrtbase.dll
Report ID: 9f9382f8-1ba1-4475-89a4-e9ef58e27015
Faulting package full name: Microsoft.FlightSimulator_1.17.3.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App

image

Doing a DISM scan now, to see if it will make any difference.

the 0xc0000409 & ucrtbase.dll … normaly, former, I had said it must be because of the Eng…Lang…Pack…US. But since short while some users report this error and install it will not help. It points then often to issues related to windows audio service. May be the old sound-driver horror is back.

The users helps in that case:

  • disable the Windows Audio Service
  • start the game
  • enable the Windows Audio Service

( windows → services → Windows Audio → Stop / Start )

I assume, if this help, the sound-driver is again the bad-boy.

May be you can check whether your sound-drivers are up2date.

Another user disabled the Nahimic service in msconfig:

deinstalled flight simulator. deleted all files.

crashed during installation (downloading files)

Name der fehlerhaften Anwendung: FlightSimulator.exe, Version: 0.0.0.0, Zeitstempel: 0x60c0b1e3
Name des fehlerhaften Moduls: FlightSimulator.exe, Version: 0.0.0.0, Zeitstempel: 0x60c0b1e3
Ausnahmecode: 0xc0000005
Fehleroffset: 0x0000000001cecdd8
ID des fehlerhaften Prozesses: 0xe54
Startzeit der fehlerhaften Anwendung: 0x01d77a68cd40a6fd
Pfad der fehlerhaften Anwendung: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.17.3.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Pfad des fehlerhaften Moduls: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.17.3.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Berichtskennung: c587371b-9912-43a0-b532-40a1b49559de
Vollständiger Name des fehlerhaften Pakets: Microsoft.FlightSimulator_1.17.3.0_x64__8wekyb3d8bbwe
Anwendungs-ID, die relativ zum fehlerhaften Paket ist: App

1 Like

@MazeRunner800 … another hint I forget… I mention it already in big CTD thread and it’s also mentioned within the FAQ.

If you have tools like Asus Sonic Radar, Studio installed, please remove it. These tools use these Nahimic and cause the errors too.

1 Like

Thanks for the tip, but nothing (including what the support team said), is working.

I have exactly the same error like you. Came out of the blue two days ago. I tried everything that is written, but doesn’t work…

It’s really annoying. If anything I try works I’ll post it here

ok, I installed the English (US) Language package and tried to launch FS, nothing happend. Then I did a restart of the pc and it worked. Everything running smoothly again… It’s wierd…

yep… a Restart is a good choice after install of the lang pack.

On other side also other users reported that a Windows Restart would help, indep. of lang pack installation. Most users are not aware that “Windows Shutdown” is not same as “Windows Restart”. Only in case of Restart some “clean ups” are done. We recommend sometime also to disable settings like the Windows Quick-Start.

Thanks for your reply. Yes I know, but in this case restart only didn’t do the trick…

In my case, Nahimic is the main suspect.
After the Nahimic service be disable, everything comes normal.
And you don’ need to stop or reactive the audio services.
(Before that, all driver or windows were up2dated.)

Same. Not sure what started this. I suspect it was the Windows update to 20H2. After I installed it my audio settings started acting funny in windows, I was able to fix it. Had not tried MSFS until today, when I realized it was crashing. Disabled Nahimic and it’s working again.

yes… but these service is mainly used only in case that tools like Asus Sonar / Radar / Suite ( all these useless sound tools ) is installed. ( Therefore I asked you about these, within the other thread :wink: ).

I checked PC last night, found that there was a MSI audio program be installed.
And the Nahimic was hided in there, no ASUS Sonar/Radar/Suite related be installed.
It’s weird that I don’t have any MSI equipment in my PC. :thinking:

1 Like