Game says mandatory Microsoft Store update needed, but no update available

As per title, when launching FS this morning, it tells me there’s a mandatory update that needs installing from the store. But no update for FS is available in the store. Anyone know what causes this? I updated the game to SU5 on Wednesday and the game had been working fine since then, until today.

6 Likes

Have you clicked on the 3 dots in the top right corner of the store page and then selected ‘downloads and updates’ from the menu? Then click on ‘Get Updates’. If not, I’d try that.

1 Like

Thank you, but yes I should have said that I’ve already tried the ‘get updates’ button numerous times. There were quite a few updates but none of them were for flight simulator :frowning:

Seems like yesterday’s hotfix is not installed yet.
Try rebooting as a first measure, sometimes it picks up the update.

Further try resetting the store (it won’t delete anything, just reset the state of it):
Open start menu, type “cmd” +enter.
In the window enter “wsreset.exe” and press enter again, wait until it completes.
Then open the store, search for Flight Simulator and see if it picks up the update then.

These are the easiest troubleshooting steps, if it doesn’t work still, there are more, I think Zendesk has an article on it.

1 Like

Have you tried signing out, rebooting and then signing in again. That has worked for me in the past.

1 Like

This just happened to me. To get it working I signed out of the store and the Xbox App. I didn’t reboot. Once I signed back into both apps the update was there. I’m downloading it now (390MB).

2 Likes

Thanks for all the suggestions, none of them have helped though unfortunately.

I downloaded most of the SU5 update over VPN as it was downloading so slowly. I hope that hasn’t confused the game into thinking I’m in a different country/region to my actual one (UK), and caused this issue with the hotfix update.

Same thing is happening to me. Signing out, then in, reset store, reboot all to zero avail. This entire SU 5 has been a huge mess. In fact, every single update has caused me some sort of grief, some an inconvenience, others major disappointment. This update, in particular, has been up there amongst the worst I’ve experienced. To say that I’m frustrated would be a major understatement. My Saturday evening of flying has officially gone up in smoke. I was so looking forward to flying tonight. It’s now 8pm in Western Australia and all I now have to look forward to is Netflix/Stan or an old DVD from my library. I so want to use expletives but they’d only be automatically redacted. Perhaps I’ll strip off to my birthday suit and go outside to yell profanities at the moon. Knowing my luck, I’ll get arrested.

There is one saving grace for me this weekend;
I’ve booked 2 hours of solo aerobatics in the Avion Robin 2160. It’s been raining heavily here (ICAO = YPJT Western Australia) every day for over 3 weeks with 6 to 7 octas cumulous at 500’ to 700’ AGL nearly every day. A squall just passed and I can now see a nearly full moon and a copious amount of stars and the southern cross constellation for the 1st time in ages. Weather radar now looks very promising with a crisp, clear day forecast for tomorrow. So, I really look forward to honing my aero sequence all by myself. Last time I did that I had a friend in the right seat; this Robin 2160 has 2 side by side seats with dual controls. It’s black with gold stripes and originally owned by the Sydney Aerobatic Flying Club. It is similar to the CAP 10 Robin in fs2020, but without the split dihedral wings, with a huge slide-back bubble canopy, wheel pants almost exactly as the Robin in fs2020, a very effective, flying horizontal stabiliser and an enormous rudder (hammerheads are easily performed). Rated at +6G, -3G maximums, it’s a fairly solid aerobatic machine, however she’s a bit underpowered with the same Lycoming 4 banger & fixed pitch prop as a Cessna 172. You need to dive until reaching 145 knots before rolls or loops. Hammerheads also need the same initial speed before pulling vertical. Upon reaching 40 Knots, as you kick in full left rudder, you need to push the stick full right to prevent the right wing from lifting (thus causing unwanted inverted flight), then immediate full forward stick to stop the tail from flattening downward, thus preventing a tendency for a flat spin. A good hammerhead in this bird requires near perfect timing of power application and reduction plus the right amount stick and rudder at the right time. Once you get it right, it’s very easy to duplicate clean, consistent manoeuvres in this bird. The BIGGEST reason I like to fly her alone is that I had the extreme displeasure of being vomited on, in the middle of a loop, not once but twice by friends who said “I have an iron gut - you can’t make me sick” :joy:. I always make a point of telling my “prey” (passengers) to not drink heavily (at all if possible!) and to not eat a big, heavy (muesli is the worst) breakfast before aerobatics - but they don’t listen - and they’re very bad at getting the bag over their mouth in a timely fashion. I say this from personal experience - flying a plane with slimy, smelly vomit covering the stick, throttle and rudder pedals isn’t easy. In the pre-flight briefing, I make them sign a caveat saying that they are solely responsible for cleaning up their own messes. :blush:
Sorry I veered away from fs2020. Honestly, I needed the diversion - I’ll tackle the sim tomorrow night. Time to get some sleep :kissing_closed_eyes::zzz:

EDIT
The clouds and squalls in Perth aren’t conducive to a VFR aerobatic flight. So, no sim and no RW. What a boring thing to

1 Like

Glad it’s not just me, although sorry to hear you have the same issue.

I’m just doing some googling and found this thread. Sounds like quite a few other people have it too.

Linky

One guy suggests to rename the game folder, uninstall the game, rename the folder back to correct name again, and click ‘install’. Supposedly took him 2 minutes and resolved the issue, however I can’t rename the FS game folder in my WindowsApps folder as I don’t have sufficient permissions (even though when I check the file permissions, admins have full control). I think the WindowsApps folder and its subfolders have some funky restrictions on it, as I can’t even take ownership of the FS folder.

Was the same for me. After launching, MSFS wants an update, auto launches the store → no update. Tried the XBox App as some suggested no update either. Reset all apps from the settings menu, rebooting. No success.
After repeatetly (like 5 times) hitting the “look for updates” button and signing in and out of the MS Store app, it finally found the upadate. I think it’s just really buggy and the sim probably is confused with the new XBox integration (XBox App - MS Store app).
So try again a few times, it should work eventually.

1 Like

Yes, I tried signing out and back into the Store one more time about 15 minutes ago. Clicked ‘Get updates’ - no update. Went and had some lunch, and have just come back to my PC to see that FS updated itself a few minutes ago. How bizarre.

So, @CatapultF4E , all I can suggest is what @FlyinChaucer suggested in his post above - just keep trying. The only other thing I did this time was installing and opening the XBox app from the store, before signing out of the store again. Whether that made any difference I have no idea, but worth trying?

1 Like

Try > https://forums.flightsimulator.com/t/where-are-people-downloading-the-hotfix-from/431265/8

1 Like

Thanks @dannyboyy1975
I’ll give it a shot tomorrow afternoon. I have some R/W flying to do in the morning. Can’t wait to smell a real airport and push a real throttle :blush:
EDIT
Decided to try one more time before hitting the sack - it still hasn’t found the update!

I’m about to give up on this sim.

@dannyboyy1975
I still cannot get this update. Tried 15 times over the last 24 hours. Reset Windows store… Not helping.

Can anybody please advise how I get this patch? It is NOT in the MS store! I’m exhausted after staying up all night trying to fix this stupid game. Nothing I do gets me that- update. NOTHING!

Please contact support via Zendesk.
People have written the common tips how to get it to work, if you didn’t succeed, Support might help.

Also check the FAQ:
https://flightsimulator.zendesk.com/hc/en-us/articles/360015760660-Download-Installation-issues-Windows-Store-troubleshooting

Same here: at 29.07.21 I updated MSFS and play successfully with it.

Now if I launch the game, it says there is a mandatory update and the game quits itself. But everything looks like up to date…
Message:

Microsoft Store:

System:
image

Bad implementation of the patch system. Rarely has any of my update for this product gone without some sort of incident… :frowning:

1 Like

I had the same problem, 1.18.13.0 is not the up-to-date version, I tried dozens of different things on here and nothing would trigger the update to 1.18.14.0.

What did work was;

Find the MSFS folder (likely in C:\Users<your name>\AppData\Local\Packages
Rename the folder (just add something like ‘X’ to the end)
In Windows Settings > Apps select MSFS and choose uninstall
Rename the MSFS folder back to the original
In the Microsoft store reinstall MSFS

I’d seen a similar method mentioned on here but it stated that the uninstall is done in the Xbox app, I couldn’t find an uninstall option in there. The above method though did work for me and resulted in about a 2gb download / installation, then an update in-sim.

Good luck.

2 Likes

Use the search bar in the Store app to bring up the game page. The “update” button is there. Selecting the app in my store library had me in an endless loop of opening the store, checking for updates, clicking the app logo in my library, which opened the xbox app, which opened the game and said update required.

Using the search bar to open the flight sim page takes you to the right place.

1 Like

@FoolishBull1303

What comes after “packages”? I don’t see “Flight Simulator” just other folders like “wp” etc… What is the flight simulator folder’s name?