Game stuck on checking for updates after restarting machine w/SU5

I decided to restart machine after installing SU5 and on launch MSFS is stuck on checking for updates. CPU and GPU are idle. looks to be frozen. i tried restarting again to no avail. Please dont tell me i have to reinstall this again? thx

I can’t even DL SU5. It tells me the server is down.

had this happen several times…I don’t have a clear solution but have tried with an empty Community folder and I think that might work.

my community folder is empty. i think it may be just the server being unresponsive since it’s stuck on checking for updates. Wish it was possible to completely disable updates in this game.

1 Like

Same here within last five minutes.

Same for me. Server issue then?

Yep, same here. must be a server issue :-/

I have the same problem!!!

Same here. Community folder empty.

Yup same here :confused:

Same here… stuck on Checking for Updates, although it appears that the servers are up and running. Perhaps they’re overloaded??

Same here. Yup.

i see this error on launch, not sure if it’s related

I was still downloading when it happened

i see then it’s probably the server ya

Actually, before this, I hadn’t been able to get into a flight…the progress bar goes all the way to the right, then nothing…

ok i passed the update check. just have to wait (3min)

I have this too!

same here :frowning: Certainly they wil fix it soon!

You know how people tend to have a lot of problems on launch day … it appears today is like that, except on steroids.

1 Like