Game stutters like crazy, is memory the issue?

Hi. My game is stuttering like crazy when I’m playing in VR. I recently built a computer with all the latest hardware and it’s stuttering like crazy, even with my all new ASUS TUF Gaming 3090 GPU. It was stuttering also on my old computer. I used Oculus Tray Tool to fix it then, but now with my current gear I expected performance to improve but stuttering still persists. This is my current setup:

  • ASUS TUF GAMING X570-PLUS (WI-FI) Gen2 AMD Motherboard
  • AMD Ryzen 9 5900X Desktop Processor
  • ASUS TUF Gaming NVIDIA GeForce RTX 3090 OC Edition
  • Western Digital Black SN750 1TB NVMe M.2 PCIE 4.0 SSD
  • 32GB of 2400 Hz DDR4 RAM (4 sticks)
  • EVGA SuperNOVA 1000 G5, 80 Plus Gold 1000W Power Supply
  • Windows 10 Professional
  • Oculus Rift S

I’m playing the Steam version of the game. Today I realized it could be the memory, since more and faster memory could resolve stuttering. Could that be it? If so, how much memory should I get and at what speed do I need for smooth gameplay? This was also the same memory that was in my old computer, and it was stuttering then. It was Sim Update 5 that started the stuttering and it hasn’t resolved.

Thank you in advance.

Moved to VR, hardware and performance.

Get a copy of hwinfo to see how your system is doing. You can set it out and get a full view of everything that is going on.

1 Like

One thing for sure - don’t buy more than 32GB, it won’t be used either way :slight_smile:
And as @syldon13 said - check with hwinfo about your thermals, monitor CPU/GPU and how frequencies change - it might be some throttling happening. Also check if your memory cannot run faster - bios and try to set XMP profile.

1 Like

So you think my memory speed could be just fine, that my speed may not be the cause of my stuttering?

1 Like

You didn’t posted what memory model/brand you have, but since you have 5900x Ryzen, x570 mobo and 3090 it sounds unlikely that your memory works just in 2400 MHz - that’s why I asked for checking XMP in bios.
Did you selected parts for your PC yourself, is RAM from your old PC?

Also big question is how are your resolution settings in steam, in MSFS and so on. Many factors can effect performance and introduce stuttering. Also - do you use any mods? If so, remove them and trhy again.

I’m not on the AMD Zen train myself yet but I have read that the Ryzen platform is a bit more sensitive to memory latency than Intel.
(Not sure if that’s for regular use or just when Overclocking)

Are you sure about your memory specs? The speed that you have quoted seems a bit slow. Is that maybe just the standard Jedec profile for what might otherwise be DD4 3600 or something if using the XMP profile?

A little more info about the Ram would be helpful if you know it.
(Manufacturer, model, rated speed, how many sticks etc)

1 Like

I believe server issues contribute a lot to stuttering, I’ve been having a lot of stuttering and poor performance as well lately.


Yea j have little micro stutter when panning camera and moving the mouse from left to right in the cockpit I sure it’s a msfs thing…

Hopefully after SU6 it will work better.
VR could be so beautiful with this SIM.
I spend more time tweaking than flying…

1 Like

Yea hopefully

Fingers crossed Flying in VR will be a lot better once SU6 comes out later today

I have 4 sticks of 8GB DDR4 2400MHz (Two with Part Number TIMETEC-UD4-2400, Brand is Team Research and Two with Part Number HMA81GU6AFR8N-UH, Brand HK Hynix). The Team Research ones came with my last computer, I added the other two early this year, all were transferred into this computer. This is a custom built computer. I selected all the parts. The RAM is the only old thing installed.

I installed hwinfo as per syldon13’s instructions. I found my memory is running at 1200MHz, which is quite slow, even if the JEDEC profile is at 2400MHz. There doesn’t seem to be an XMP option in the bios (DOCP for AMD motherboards).

Anyways over these past few days I have been working on things and today was able to fix most of the stuttering issues, though there is still little stutter, but mostly smooth. Stuttering is more evident in faster planes. I may need faster memory to fix those issues, or still use Oculus Tray Tool, right?. How I fixed it was I figured out how to default Open XR in Steam and I upgraded my motherboard’s BIOS. Over these past few months I was using Oculus as default Open XR while using Steam. Games were still playing fine, I didn’t worry very much about defaulting under Steam, but performance improved a little when I figured out how to do that.

Now the next thing to figure out is how to make gameplay smooth on a Reverb G2, which I got one of recently. A Reverb takes more power and has a higher res screen, therefore the gameplay is not as smooth. I don’t think there is any stuttering though, just a lower framerate. Any ideas?

are you able to check what fps you are achieving in VR? You can enable it in MSFS developer mode but it can be hard to read in the goggles

Although I’ve got 3600 ram, I have similar system. I think you should be getting between 28fps and 45fps with no reprojection turned on

Yes I am. I am achieving about 18fps while using the Reverb G2.

I recently watched a YouTube video of someone using an app called OpenXR Developer Tools for WMR. It’s similar to Oculus Tray Tool in that it smooths gameplay. In that there is a Custom Render Scale setting. With that at 70% I can achieve frame rates that look like 60fps with little jitters here and there, but it isn’t bad, though the resolution is downscaled and not to the potential of the G2. I can play smoothly, but details are not as sharp.

With Render Scale check box ticked off (Original Resolution) and Motion Reprojection turned off in the app (Is this where you found the Motion Reprojection setting?), I can achieve about 26fps. It’s full resolution, but nothing still in the range you are talking about.

These are my VR settings:

try hitting Ctrl+keypad1 which will force ASW to turn off, I had severe stutters with SU6 and disabling ASW solved them for me!

I think the keyboard shortcuts are just for oculus headsets

1 Like

Hi Don,

Set the OpenXR Dev tool scale to 100% (before starting MSFS), and set reprojection to “always on”

Try these settings below just to see if you can hit 23fps for fairly consistent reprojection. They are what I use except I set both LODS to 200.

If it’s stuttery - while remaining in VR, go into msfs VR graphics settings and change render scale to 105, hit apply, then return it to 100, hit apply, return to flying and see if that fixes it (it’s as if it clears buffers or vram or something. i need to do this before almost each flight, or if exiting VR) It’s a pain, but it becomes smooth and clear in cockpit and to the horizon

yes the author has an oculus headset :slight_smile:

1 Like

oh, sorry, my bad. I mis read and thought Don was now using G2.