Game will not update hotfix 2

Cant start the sim it says new update available sends me to MS Store which says im up to date with version

I click on get updates but nothing there to update…Perhaps instead of fixing the Sim from SU5 they should fix the installer first??

Same problem


Same for me


Same here for me


The fix downloaded for me in the windows store only and didn’t need to update anything in the Sim. The sharpness of ground textures on airliner altitudes seems to have been fixed. However, there is still the issue of the LOD distance rendering. It seems they fixed the ground texture sharpness in the immediate vicinity of the position of your aircraft (see bottom half of the picture), but anything outside the 10km range is still washed out… I hope they can fix this with the rendering slider they are working on. We should be able to see crisp textures at least 50km out on a high performance gaming PC!

Same problem. I have and there are no updates to download.

Same. Tried signing in/out of store, Xbox live and rebooting. Nada.

Shutdown your PC and reboot.
Open the ms store app
Go to the msfs page

An update should be installed


I’ve done that a couple of times, including ensuring Windows is up-to-date. The problem is the MS Store does not seem to know there is an update available regardless of how many times i ask it to check.

1 Like

Same problem for me too. Sim sends me to the store for the mandatory update; store says I’m at Logged out of Store, logged back in. No go. Restarted PC. No go. Back to store… Tried updating. Says "you’re good to go! … which is exactly what I’m thinking of doing…lol

It’s a nuisance, but they’ll fix it. Just have to wait a bit longer.

I have done all the above and still not getting the download update to find the MSFS update in the MS store.


The difference is the shutdown instead of reboot. When fastboot is enabled it can make a difference.

1 Like

I have powered down my computer multiple times. That’s not working.

Hate to see this. The update took about 20 seconds for me. Currently reloading my Community folder with my mods. Fingers crossed.

That did not help.

Shut down. Powered off. Discharged MOBO. Cold boot and no joy on the hotfix in the store. Still waiting patiently.

This hotfix is off to a good start.

1 Like

If you can’t update try this. Open Microsoft Store, Click the dots top right side, Choose My library, Click Microsoft Flightsim. Update will begin.

Tried that nothing working I’m ■■■■■■ Asobo have screwed us completely


Thanks for the try RW but still no joy. Been with this sim since January 2020 with many little things like this. They all work out with time. Back to waiting.