Ground services and vehicles went missing

Hi :slight_smile:

yesterday I did clean installation of MSFS on new drive and I cant see or use any of the ground services except jetways. I also dont see any idle catering or baggage trucks on the airports.When I try it via default ATC, it just says something like “we cant send you XXX”, via pushback helper it does nothing. This kind of behavior was okay, because these vehicles spawns next to the airplane ready to be used on next request, but now its just completely gone.
Problem persists with empty community folder too, I tried many airports where I usually use these services with no problem and result is same.
I have latest version of MSFS with Benelux/France update + 2104 Airac update. Windows 10 20H2, build 19042.928 and latest drivers for my GPU.

anyone else? :frowning:

It happens to me on occasion but it isn’t consistent. I haven’t figured out what’s causing it. There was one time when I checked my traffic setting where all the airport workers and vehicles were set to zero but that only happened once.

Ground vehicles and workers density are set to 50 both

Ok so I reinstalled whole game for 2nd time back on the system drive and the problem is solved. Who knows what was the cause of that. :thinking:

i just recently noticed that i have no moving ground traffic from vehicles anymore, neither on aprons nor on any roads between taxiways… finally, I found it almost more immersive to see some of vehicle traffic at least on the taxiway, but it doesn’t seem to be there now.

i also checked at big airports, at O’Hare in Chicago or at Schipol Amsterdam: although there are lots of tankers, baggage trucks or follwo-me cars standing around, i don’t detect a single MOVING vehicle (except for the ones only ordered by me, like external APU or tankers)! There used to be some traffic at the airport after all, now everything seems static or frozen.

i also did a reinstall, but this didn’t help much, it still looks the same, like frozen.

PS: all sliders are at ground traffic on the right! I think that’s why I see so many tankers, buses, etc. but as I said… they just stand around and do not drive!

I had this problem as well. It was caused by an incompatible airport mod. Have a look at all of your airports in your community folder. Remove the ones with a “AirportServices” or a “LivingWorld_Config” folder one after another untill your ground traffic comes back. This worked for me.


Did you ever sort this?

LivingWorld_Config This is the culprit. I found a file i downloaded from that had that file in it and my ground vehicles are back.

1 Like

Good to hear. I would contact the developer as well, so he can update the airport.

1 Like

You, sir, are a legend!!!

Didn’t even know I had this happening before the Fenix A320 came out :sweat_smile: I was exclusively flying GA out of the appropriate remote stands of big airports, and while I seem to have noticed the GA push back guys not appearing anymore, I didn’t make much of it…
Now, with the Fenix out, I have been martering my brain for days why I gan’t get pushback :rofl:

Turned out it must have been caused by one of two minor airports with a, AirportServices’ folder present.
Thank You!

1 Like

Glad it worked for you. :slight_smile: Unfortunately this is a very common issue and not every scenery developer is aware of it. I heard it’s even documented wrong in the SDK manual.


I have the same problem (lost ground services on PC). I have deinstalled Aerosoft Airport ENMH as described in a other thread, and I don’t have LOGL, which is also found as a cause of this problem.
But no effect, the ground services are always missing.
I can not rename or move the community folder, to check if any other addon cause this problem (I have a lot of addons, most from ORBX, but also other). I think this has to do with the long filename problem from windows10 / Explorer.

Are any other addons known, who cause this problem on PC?
Who can help me?

Don’t you have that addon ?

There are a lot of airports/sceneries with this problem, unfortunately it is a not well known issue by developers. There are even some affected airports sold at the mp, so I’m not sure if asobo/ms are aware.

Try this:

  • Open the community folder and use the search function.
  • Search for “AirportServices” and “LivingWorld_Config”.
  • Remove the ones with a “AirportServices” or a “LivingWorld_Config” folder one after another untill your ground traffic comes back.

It is absolutely insane that Aerosoft has fixed that bug in ENMH Mehavn in their shop maybe a year ago…but they have kept ENMH version 1.0.0 with the airport-services-bug for another year in the marketplace for all xboxers to enjoy.

This is extremely irresponsible from a supposedly big name like Aerosoft. In particular since searching for a faulty addon on xbox is a huge pain when no addon-files can be moved, just deleted.

Whoever is responsible at Aerosoft deserves to be slapped across the face with a fresh norwegian salmon. :fish:

I have isolated the problem. ENHM from aerosoft in Version is it NOT. The bug of Version is fixed in Version!
There are in my installation (on Windows PC) 3 scenerys which cause problems:
ORBX Cli4D-Philippines is the most evildoer: it kills the complete ground services world wide!
ORBX NZMC Mt. Cook and Open Source Cli4D - Manila Bay V3.5 / Cavite Coastal folder are causing also problems, but smaller one: They kill “only” the workers on the ground service field. It’s a lot of work to test these scenery for scenery, every time with restarting the sim …

1 Like

I know it’s really annoying. From my 2700 hours in the sim I spent at least 2000 hours testing and troubleshooting :sob:

The strange thing is I have the NZA Mount Cook and the Cli4d Philippines scenery installed without any problem.

Thats mysterious!
Maybe it depends from the sequence of scenerys in loading in SIM.
Is there a file, where I can see the sequence?
No Idea how to check this, cause of my many addons, the possibilitys of different sequences are too much…