Having a strange issue with Oculus Rift

Hey guys, so I just got FS and tried it with my Oculus Rift. Tried searching for this but could not find anything. I’m encountering a weird issue where the view upon first loading in is stuck under the seat on the floor of the cockpit. I tried moving up the view but it just puts me in front of the stick. In addition to this, this weird box appears in the middle of my view. I’m not sure if it’s an issue related to the alignment of the Oculus, but it doesn’t appear to be, as I don’t have any other issues on any other games I play, including DCS World.

Has anyone encountered this? If so, is there a fix you could share with me?

What happens when you hit the spacebar?

It just jumps slightly but doesn’t reset to an appropriate view.

That is strange, are you in Oculus BETA?

I think so? Is there an easy way to confirm that? It’s been a minute since I’ve really played around with any of it

Make sure Public Test Channel is on.

Apparently I was not. So I turned that on. Is there anything else I should check?

Have a read of the following post, very helpfull: [Optimum Performance Settings] For all Oculus CV1 Owners - Virtual Reality (VR) / Hardware & Performance - Microsoft Flight Simulator Forums

Appreciate it, thank you for the help!

Have fun, I know I am :slight_smile:

I’m looking forward to seeing how it develops. There are some many things that can be done with the platform, it’s certainly exciting. Would really like to see more things like managing your own airlines, some sort of sandbox style plot line development, things like that. Anyways, thanks again!

When you defined your viewpoint to the rift did you give it you height standing up or seated? If you gave it your standing height and you’re now seated your eyes would be 2-3 feet lower than expected…

I tried both, the issue was that I did not have the Beta version selected.

I just tried VR this weekend for the first time with the Oculus Rift S and am having the exact same problem.

I ended up being placed with my head inches from the engine gauges on the A320.
No buttons on both my controllers worked, except one on the left.

I get a ‘RESET view’ window, but it does not seem to work either when i click on anything.

Then it takes me to the Oculus VR desktop with a window open, to ‘reset view’. But when i go back in sim, i cant place myself in the captains seat or use any of the controllers at all.

I have the Rift S also and had the same issues but I managed to work them all out. So if anyone is interested I’ll try to be of some help.

  1. Make sure you have the latest graphics drivers installed in your PC. Also take the time to fully update WIN10.

  2. Make sure your PC is fully connected to the headset and controllers.

  3. Sign up for the Public Test Channel under Settings\Beta in the Oculus Software.

  4. I don’t use the Microsoft Mixed Reality and my VR works great. My rig is an >> I9 10850, RTX 3080, 32GB, 2TB SSD.

  5. Enter VR Mode. You most likely will be sitting sideways. No problem.

  6. -Click the Oculus Button. You should see the Reset dialogue.

  7. Click the Reset View button just once. >>>NOW STOP<<< Now to place yourself exactly where you want in the cockpit requires that you use body alignment. So sit in your PF chair comfortably directly in relation to your yoke or joystick and rudder pedals. Do not lean forward or backward just sit up straight. Don’t slouch!! Look directly forward (not left or right). DON’T MOVE. Now click the trigger button. You should now be sitting properly. AGAIN DON’T MOVE. Decide whether you like this position. If yes ok to move. If no, repeat steps 6 and 7 by making slight adjustments in you body alignment. Move [ forward/backward/left/right/up/down ] until you are satisfied.

  8. To remove the [black Recenter Dialogue] I simply recycle out and in VR Mode until it disappears.

Hope this helps.

I am stuck at the VR-Reset button box, after entering VR mode. None of my controller buttons work, except when i click the right Oculus button on my right controller, it enters a box that seems related to the Oculus VR desktop. It states to ‘reset view’ or quit app.

Your help is appreciated. I was expecting the oculus controllers could be used to point at the menu in MFS and also click on buttons in cockpit, but they dont seem to respond.

When i am in the oculus desktop, i can see my hands and they do respond, but they just dont show up in FS

Oculus Guy here. Theres currently no support for the controllers once you switch into VR. Its odd considering they work outside of VR navigating the menus, I guess cause you’re technically in “Desktop Mode.”

If you are asking about how to get out of the “VR Reset” dialogue, you’ll have to set a key bind to it, for it to clear. On mine it did have a default one set and thats what I had to do.

Are you sure that you have set the key assignment correctly?


The mouse pointer will show up differently depending on which flight simulator you are using.

In Prepar3D The mouse shows up as a small circle.

In Microsoft flight simulator 2020 The mouse shows up as a regular arrow pointer.

Let me know how you’re progressing.

Your hands will not show up in flight simulator. Only the mouse pointer shows up when you In VR mode in flight simulator

You have to be very careful about your mouse pointer when you enter the VR mode. The mouse pointer is affected by both the mouse on your desk and your headset. Both of them will move the mouse independently. So when you enter the VR mode be careful not to dislocate the mouse pointer from view either by mousing too far away with the mouse or turning your head to the side. My best suggestion is to center your mouse by desktop before entering VR Mode. Once you enter the VR mode, locate your mouse first before turning your head.

Have some Dramamine on hand . . .

Don’t know if you figured this out yet but I always start out like that and I simply reset my view and it sets me correctly. This is done by first binding a button to reset view in flight sim and then once in VR hit that button. For the black “stencil” simply turn off FOV Stencil in the oculus debug tool before starting the sim.