Help a pilot out before he gives up on MSFS in VR? | Quest 2, RTX 2070 Max Q, i7 10750h, 32Gb, SSD

So long story short I’ve been trying to get VR to work since December without any luck. Watched tons of videos and perused through many of the recommendations here on this invaluable forum. However I’m really at a point of giving up. :warning:

2D Flight sim works fantastic. Awesome visuals and buttery smooth performance, but not so in VR.
I’ve typed out below what I have tried so far and if someone is willing to guide me with any further suggestions / combinations I’m all ears and will be greatly appreciated! :crazy_face:

Not a high end computer, but should be capable enough at least via the VD / SteamVR method.

  • Regards,

a fellow pilot

MSFS is bought via Microsoft store

System Specs :

  • i7 10750h @ 2.6Ghz
  • 32Gb RAM (Dual Channel 2966Mhz)
  • Windows 10 Pro 20H2
  • 2Tb Samsung Evo 970 SSD
  • 1Tb Wd SSD
  • Link Cable → USB-C tested @ 1.9Gbps
  • Router
    • ASUS AX11000 Tri-Band
    • Running Quest 2 on its own dedicated 5Ghz channel (Wifi6 protocols)
    • Showing 1200 Mbps in VD (Virtual Desktop)

NVIDIA drivers I have tried

  • 452.03
  • 457.30
  • 461.40

Oculus Settings

  • 90Hz @ 1.3
  • 72Hz @ 1.7

Virtual Desktop Settings (VD)\

  • 1.18.8 (Sideloaded)
  • Settings
    • Environment Quality - High
    • Frame Rate - 90 fps
    • Desktop Bitrate - 20 Mbps
  • Streaming
    • VR Graphics Quality - High or Medium
    • VR Framerate - 75 Mbps or 50 Mbps
    • Advanced
      • Sliced Encoding
      • Increase Color Vibrance
      • Video Bitrate

OTT (Oculus Tray Tool)


    • Game Settings
      • Default SS 1.6 or 2.2
      • Default ASW 18Hz or 30Hz
      • FOV 0.7 / 0.7
      • OVR Server Priority High
    • Quest Link
      • Presets GTX 1070
      • Distortion Curvat. Low
      • Encode Res. 2352 or 2912
      • Bitrate 250
  • Method of starting | OCULUS LINK

    • MSFS
      • Load a FPL and ready to fly, then pause game
    • Start OTT
    • Start Quest 2
      • (In Quest 2) → Settings → “Oculus Link”
      • “Show Virtual Desktop”
    • THEN back to MSFS window
    • Switch to 3D
      • Plays, but jittery terrain and buildings averaging 16 FPS
      • MSFS Settings for VR
        • Render Resolution - 100 / 90 / 80 / 70
        • Terrain LoD - 50 ~ 100
        • Objects LoD - 50 ~ 100
  • Method of starting | STEAM VR (Not linked via Cable, but wireless)

    • Start Quest 2
      • (In Quest 2) → APPS → “Virtual Desktop”
        • 1200 MBps dedicated 5Ghz connection
      • IN VD
        • “Launch SteamVR”
          • “Show Desktop” in SteamVR (Latency at this point is 0.1ms)
          • Start MSFS
          • Load a FPL
          • “Ready to Fly”
          • Switch to VR (Ctr + Tab for me)
            • Latency 400~500+ms and stutters screen
            • shows both eyes individually
1 Like
  1. Oculus software - make sure your opted into the beta test, leave the device settings at the standard 72hz and 1 in the oculus software.
  2. Use the latest game ready Nvidia driver 461.40
  3. Do not use the virtual desktop as it slows things down a lot.
  4. Tray tool, leave presets disabled to start with (save and restart the oculus service)
    FOV to 0.7,0.7 (click save) you may need to click save again when the oculus pc software
    is running

Do the above without MSFS running

  1. MFSF reset all the graphics settings to default and save. Go into VR graphics settings and
    set everything to low. Start with 70% for the render scaling and save.
    load fight plan etc click fly and pause on the runway.
  2. (In Quest 2) -> Settings -> “Oculus Link” dont go into the virtual desktop.
  3. MSFS switch to VR mode (CTRL + TAB) and see how it looks.

Try the above to start with and see how it looks in VR, it should be relatively smooth.

Once you got it running smooth you can start upping the settings.

Take note depending on where you fly, this can greatly effect the frames you will get. Start by flying from somewhere without to much heavy scenery (a small local ariport out in the sticks). For instance New York will slow down even super fast machines in VR.

1 Like

Would you mind test my benchmark flight:

  • Cessna 152
  • KCLM, RWY13, Port Angeles
  • Weather preset: Few Clouds
  • time: 8 am local time (16 UTC)
  • take off of RWY13 , fly above the town, the sea, towards the mountains.

I get solid 40FPS here (measured via OTT performance meter), without noticable dips.

My setup:

  • PC: Ryzen 3600, 16 GB RAM, RTX 3080, NVME
  • Oculus Link: 80 Hz@5136x2608, USB@2,2 Gbps
  • Oculus Tray Tool: FOV: 0.9/0.9, EDIT: ASW@30Hz, bitrate: 250, Low Curvature, rest on default
  • MSFS: Render@100, Terrain LOD@80, Objects LOD@100, Grass Low, rest on High, AFx8, Texture Supersampling@4x4, Shadows@1024, Bloom On
  • NVIDIA CPL settings: all default

Do you try this updated guide ?

1 Like

I have a comparable PC and I am using Virtual Desktop. Most settings same as you with the exception of streaming bitrate. I have set it to 150 Mbps.

However, the way you describe starting up VD is different… first, You need to run the app Desktop Streamer before running VD. I like it to start MSFS in 2D, create a flpln and load the flight. Only then I put on the Quest and start VD, it shows your desktop. You then need to start Steam VR from the VD menu, not from your desktop. When the standard VR waiting area of Steam VR appears you can switch msfs to VR.

This is what I do as well except I don’t even start steamVR from the virtual desktop streamer. I just load into a flight and when I’m on the runway or ready to taxi I press CTRL+Tab and everything switches to VR and steamVR loads automatically.

Everything runs quite well and I’m running a Ryzen 3600, Radeon Vega Frontier Edition, 16GB@3200 and the game is on an NVMe SSD.

Edit: To add, occasionally I will get VD going to where I can see my desktop in the headset and then load Flight Sim that way. Go through all the menus, setup my flight and then when I load into the world I’ll CTRL+C and get going.

Tried your benchmark airport, but used the low default settings that @monkeymagic2405 suggested since I don’t have your RTX 3080.

I averaged 24~32 FPS which was playable, but at those resolutions (72Hz 1.0 sample rate, 70% render in MSFS it looked pretty bad)

Thanks a lot for the response. I have gotten so deep down the rabbit hole I think that following your advice will seem like the best idea using LINK Cable.

I’ve gotten lost trying to optimize things and sometimes had it working fine then kept tinkering only to find out going back to the previous setting made it even worse.

So back to basics it is… thanks for that!


I will still keep tinkering with the VD method as with my bandwidth (LAN to my router and dedicated 5Ghz channel for the Q2 that’s about 5 feet from the router) this should theoretically be my best bet for getting better visuals.

Thanks for the response. I tried your method.

  1. Reboot PC
  2. Start VD Desktop Streamer (mine starts on windows startup)
  3. Start MSFS
  4. Load FPL (I’m going to keep using KCLM for benchmarking since this is a low graphics environment)
  5. Ready to Taxi I pause the game to the menu
  6. Start Oculus
  7. Apps -> Virtual Desktop
  8. within VD -> Launch SteamVR

Then a window opens up this time with “FS2020” “Waiting”
Finally loads, but at 10FPS its an epileptic nightmare

ps: I did increase my VR Bitrate to 110 (that’s the max it will let me, but no change)

I really don’t understand why I’m the only one having these issues. I’m inclined to to re-install everything, but since its working well in 2D (Mostly ultra except Volumetric clouds) I don’t see how this could be useful.

Thoughts anyone?

I’m a new Q2 user and tried both Link and VD. I find VD video stream quality slightly subpar and uses more CPU resources than the Link. So I usually fly with the Link nowadays (without SteamVR).

That aside, let me try to understand your problem. I notice you don’t show any SteamVR settings, so maybe you would like to check that out. And just to remind you that you can completely shutoff Oculus service with OTT and shut OTT off. They aren’t used at all with VD.

On your VD in-game screenshot, I notice the resolution is way too high (Post 4668x4848, Game 3734x3878). So maybe you can try tune DOWN super-sampling in SteamVR to 120% and game render to 80%. At least that’s the one which work for me.

You can also try lower the SteamVR Super-Sampling below recommended and work your way up. Just remember that every time you change the settings at SteamVR, you need to re-cycle VR mode in MSFS to apply the resolution.

I do find it is easier for me to go into VR with VD. The Link some times need a few reconnection to get things right.

Are you using the patched version of Virtual Desktop that you will need to install via the SIDEQUEST program (separate)? If not you can’t play any games with the default version of VD you downloaded from the Oculus store.

Also, if you want to run the VD method you would not be using the OTT tool That is used if you are using the wired method via the LINK cable and the OCULUS link program.

In terms of just trying to make it work I would not introduce the OTT into the mix yet (that is used for refinement of the quality).

Just start with the LINK cable and Oculus LINK software but if you did run STEAMVR it has already made a change to the registry so you can’t just go back to the LINK cable method without that registry pointing to the oculus location.

Yes it is patched via SideQuest (I run some other games wireles via VD & SteamVR this way like HalfLife:AlyX)

I understand they are completely independent and don’t run OTT unless I’m using link. I only run:

  • VD in Q2 (Apps → Virtual Desktop)
  • within VD → Launch SteamVR
  • then in MSFS switch to VR when ready to taxi
  • then it crashes

I switch back and forth between the runtimes:

  • Oculus when I run the Link cable
  • C:\Program Files\Oculus\Support\oculus-runtime\oculus_openxr_64.json
  • Steam when I run VD

I think you’re monitor res might be too high. What helped me a good deal is running my monitor res in Windows settings at a lower setting than native. Also lower all 2D settings in msfs to low. Sounds strange as this should not affect 3D but it seems to free up resources and it helps switching quickly and smooth in and out of VR.

Furthermore, switch off Live Traffic. I noticed that this is an fps killer in VR.

Thanks. I’d try keeping the resolutions highest as possible while lowering the rest of in-game graphics settings. I’ve noticed that most of them have some impact on FPS and they actually scale very well with the framerate, at least on my system. Among the biggest offenders are buildings details, ambient occlusion, clouds, reflections windshield effect, terrain and object LOD, not sure about the others yet.

For example, using the benchmark flight starting in C152 on RWY13, the FPS settles at:

  • 43,5 FPS in-game meter (35-37 FPS shown on visual HUD performance meter**) when using the in-game graphic settings I posted above;
  • 55,5 FPS in-game meter (42-45 FPS shown on visual HUD performance meter) when using the MSFS VR default settings while keeping render scale@100;

** Please note that the visual HUD performance meter works correctly only with ASW mode set to off.

Thanks. I’ve followed this guide, but missed the part of rebooting the PC. This helped a lot!

I didn’t know that. I strayed away from OTT and now running the ODBT instead with success (ASW off forced 45Hz)

I keep moving up as you suggested and so far so good. thanks a bunch!

This actually did help me . The numbers don’t show that for me, but playing visually there is less “jitter” in the terrain so it moves more smoothly if that makes sense.

FINALLY got good enoguh FPS for smooth simulation and crystal clear cockpit. (Meaning I can read the PFD / MFD and their digital readouts)

Framerate nothing to brag about, but running this on my laptop and VR its definitely impressive. I’m hoping throughout the months the kinks will be worked out for a smoother gameplay. I can actually use this now to scout out airports I haven’t been to in real life.!..

again thanks all for the input!

1 Like

Glad to hear it gets better. I agree that VR quality is not on par with 2D yet, but the added immersion is too good to give up on it…

1 Like

So the Nvidi driver 461.40 is ok for VR?

Btw, what aircraft you trying to fly? FYI even with my “perfect” setup the 787 crashes on me on certain busy airports. For example i can’t fly it at LAX but in San Diego.

Just curious. I think there are some bugs to work out in certai aircraft with VR.

Works for me, but I don’t know the details regarding changes or affect.

My test plane is the 152 with steam gauges (old dials) and the rest is a bonus for me. I think the rest will come over time as they’ll smooth out problems.

Not complaining as I’m running this off my laptop with the specs mentioned in the first post

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.