Quest 2 + 2080Ti + Link + FS2020 set in ULTRA : Best performance simple setup guide

WARNING :
This guide is updated regularly, do not hesitate to come back for the latest recommendations.
Even if you don’t have a 2080 Ti or higher, if you have a 2000 series GPU or a 1080 Ti you can use it by adapting it.
[Last update 2021 Avril 4th]

NOTE :

GPU VRAM >10 Go , a good internet speed and an SSD will reduce stuttering.

FIRST SETUP
___________

Preliminary

Disable windows game mode

Step 1 :
Get last windows update and last “Game ready” NVIDIA drivers (view NVIDIA settings in screenshot below)

Step 2 :
Open oculus app → setting → Beta → set On Canal testing
Step 3 :
Connect your HMD with link cable then Go to Oculus setting → choose Quest 2 → set refresh rate to 90Hz and render resolution to 5408x2736 then save config

If you have a lower GPU , reduce render resolution or set it to Auto

Step 4 :
For Steam users only : Launch SteamVR → Settings → General → rendering resolution 100%

Step 5 :

FS2020 General setting :
Options->General->Data-> Bing Data World graphics = ON

FS 2020 VR settings :

Render scaling = 100
anti-aliasing = TAA
Terrain level of detail = 100
Terrain vector data = ULTRA
Buildings = ULTRA
Trees = ULTRA
Grass and bushes = ULTRA
Object level of detail = 100
Volumetric clouds = ULTRA
Texture resolution = HIGH
Anisotropic filtering = 16x
Texture supersampling = 6x6
Texture synthesis = ULTRA
Water waves = HIGH
Shadow maps = 2048
Terrain shadows = 2048
Contact shadow = MEDIUM
Windshield effects = ULTRA
Ambient Occlusion = ULTRA
Reflections = MEDIUM
Light shafts = OFF (ULTRA if you accept to lose a few fps)
Bloom = OFF (ON if you accept to lose a few fps)
Glass cockpit refresh rate = HIGH (MEDIUM to gain some fps)

Apply and save

LAUNCHING THE GAME STEP BY STEP
__________________________________

Step 1 :
Before each game session, Launch Oculus Debug Tools as administrator (very important) : ODT must staying open during the game session.
Modify only this settings :

FOV -Tangent Multiplier :

  • 0.7;0

Adaptive GPU performance Scale : Off
Asynchronous Space warp : Force 45 fps,ASW disabled
Distortion Curvature : low (try High if you have a big GPU)

Step 2 :
Launch Oculus app

Step 3 :
Put on your connected Quest 2 then Activate link.
Then take off the quest.

Step 4 :

Launch Fs 2020
When you get fs 2020 Home screen , press CTRL+TAB touch to select VR mode then choose your fly plan in VR mode. Don’t launch your fly in 2D mode before !!! Very important to prevent fs2020 from saturating GPU VRAM with 2D textures

Step 5 :

Put on your Quest 2 and Enjoy :wink:

15 Likes

And here i see it again! Everyone with a 2080TI is not having issues :smiley: I have the 2080TI and it runs so good! The card is still a tank! ultra and 100% render fluid motion. love it.

1 Like

Thank you for sharing this. Have you tried to set your render resolution in Oculus App to 1.7X? That should give the native 1:1 resolution to start with, then you could adjust the in-game graphics. This gives me the best graphics fidelity. I can still keep the render scale 80-100% and turn down some settings. I am running 6800XT on 9900K, but 2080TI should not be far behind.

Are you referring to the oculus pc app or the oculus debug tool?

Oculus PC app where you set refresh rate and render resolution.

Could you compare your results with the configuration suggested by this guide?

This is awesome! I did this but use the oculus runtime and I am getting 43 FPS in country and 30-32 FPS in cities. Most of the settings in game are on MEDIUM or HIGH, but I have a 2060 Super. I think I should be happy with these frame rates right?

1 Like

I am waiting for my quest2, it should be arriving in the next few days and i have a 2080super. Do i need to use STeamVR even though i have the Microsoft Store version ?

No you don’t

1 Like

I find it runs better using the Oculus directly. You are going to love it!

1 Like

Can the Oculus runtime/debug tool be used with Virtual Desktop or do you have to use SteamVR for that?

I don’t think you need ODT with Virtual Desktop.
Please refer to this post below :

I can not get rid of the head movement jitter at 90Hz. It is smooth at 80Hz, but I can not max out the settings like that. I am on a i7-8700K, 32GB, 2080Ti.

At 90Hz in Link the jitter is there irrespective of what graphics settings I use. At 80Hz it only comes back on high to ultra settings. Fps is solid 45 at 90hz and 40 at 80hz. Frame time is the same on both refresh rates, 12-16ms.

The jitter totally kills it at 90hz unfortunatley.

So do I need to change the registry key to Oculus OpenXR for best Link performance?

Try the tracking HZ setting on your headset. Not sure if it will make any difference, but it is worth trying. Should match your country specs 50 or 60hz.

Take a look at my last settings

1 Like

OMG you are amazing! Ive got a 2080ti w/ I9-9900k. For about a week since I got VR for MSFS, I’ve been having to run LOW-MED settings thinking thats all I could do for smooth frames. I have tinkered to no end trying to figure out what could make it better, then I read your post…

I am now mostly running HIGH-ULTRA settings for everything now thanks to your guide and man MSFS looks even more amazing now, and unlike my landings; the FPS is butter smooth. :laughing: I cannot thank you enough for taking the time to post this. :trophy:

1 Like

I’ve just tested this with an RTX 2070, and yes, I can have all the settings set to ultra… but it doesn’t look ultra. The resolution seems very low for starters. Presumably, it’s a bit of a placebo effect, having all the graphics maxed out, but it not actually running like a top-end PC would run it?

Which resolution have you tried ?

100%, following the instructions in the original post. I even pushed the render scaling up higher and it looks slightly better, but performance suffered a lot.