Help Optimal Settings - Quest 2 - 8700k RTX 3070

Anyone with the RTX 3070, Please provide your Q2/OTT/Nvidia & in game settings. Currently in VR the sim is shuttering/tearing, seems like melting a lot. Not the case with running @4K TV. it run smooth 30fps lock ULTRA. but in VR it is a shutters show.

I tried this but getting around 10-15 fps

https://forums.flightsimulator.com/t/quest-2-2080ti-link-fs2020-set-in-ultra-best-performance-simple-setup-guide/346291

This one as well

https://forums.flightsimulator.com/t/my-2070-super-vr-settings-and-suggestions-index-steamvr/321913/511

Either its crispy @10 fps, or smooth and blurry with 27fps.
Type C-Link connection 1.3mb

Thank you

Also 3070, but with i5-9600KF. 24RAM and Reverb G2. Same experiences.
Let me know if you find better settings, i’ve playing around forever but have same outcome as you. What makes is worse is that CPU nor GPU are at 100% (50 and 65 respectively) but fps stay around 10. Everyone seems to blame it on Asobo/MS vers. 1.14.60…

TNT Quest 2 settings guide, works pretty well for me, what driver are you on?

I’m on a 5800x and 1080ti so not too dissimilar and get pretty good performance c22-25 FPS but I do do use asw at 30hz in OTT.

If you need specific settings let me know I’ll message you

3070 / 5600X / 32GB here

I found quest 2 too unreliable for MSFS so I got a HP G1 on eBay and never looked back.
I use 60% in OpenXR and 100% render in game with most settings medium and some on high and get 27-30 FPS typically. Stuttering is minimal and generally very smooth.
The G1 just works consistently well. I now spend my time flying and not tweaking.

3070 here too, 32gb RAM, can’t remember what my CPU is but it’s oldish and only 2.9ghz.

After months of messing about, I’ve recently been enjoying some VR flying with decent performance.

I’m using XBOX game pass thing (not Steam)
Oculus Windows app - 80hz, 1.4 (all the way to the right)

I get the game up and running & enter VR in the flight map screen, then hit fly.

I then pause and come out of VR mode.

I then fire up OTT & change the pixel thingy to 1.2
FOV 0.80;0.80
Bitrate 250

In game settings - some on ultra, quite a few on high, few on medium.

could you please share your settings? OTT, Oculus, Ingame?

i5-9400F at 2.90GHZ
32GB RAM
RTX 3070

Capture01 Capture02 Capture04 Capture09

2 Likes

This is TNT Quest 2 Setting thread mentioned above. You can try it.

I would also turn homeless mode on as well in OTT.

Can you tell me what your Frames are in certain areas of the game: I.e London which is very heavy as well as the type of aircraft you are flying.

What does the homeless setting do? I’ve never seen it mentioned before.

The majority of my flying is through mountains, so yeah the frames will probably tank flying over London, but I’ll give it a test. I usually use a small propeller plane such as the X Cub, Diamond, Robin Cap10, and recently a downloaded Savage Gravel.

Turns the oculus lounge room off. You just get a black room to be in when your in the menu.

Ah I see, thanks.

So I seem to get around 25-30 FPS with my current settings, in remote/mountain landscapes.

I tried flying over London. I started getting all sorts of screen tears and flickering. I tried changing ASW to 30 Hz which seemed to help. The photogrammetry wasn’t loading in too well and it dropped to around 20ish FPS. I might try it over a different city too.

OK… Im gonna hit pause on stuffing with my settings for a while now. I think I have something that is more than useable for any one with the following Rig:

  • Oculus Quest 2 - Latest Beta V27 including Oculus Home
  • 10700K - Stock (Scales up to 4.6ghz)
  • RTX 3070 - Stock
  • 32GB Ram - (I only get 2400hz)
  • Windows All up to date as at 10/04/2021 (April)
  • Must haves:
  • OTT - Latest Version
  • NVIDIA - 457.30… Yes Roll back, find it and install it and just hold off until some time in the future we can truly get a Drvier that works for us.

My Reasoning for the following settings:

  • I want to stop chasing clarity and sharpness to an inch of its life
  • I want small GA to fly within 30 - 36 FPS (Note that it can go higher but because of v27 it can’t)
  • I want A320 to Fly within 24- 36 FPS in Heavy Areas (much more tolerant with lower frames cause of the slow movement). (Tested in Sydney YSSY using flyTampa Scenery and Orbx Sydney Landmarks. I got 33-36 frames outside of the Airbus sitting on 16R looking back towards the City and the Terminals)
  • I don’t wat tearing of the screen every time i move my head. I just want to read the dials and look out the window without frustration.
  • I want to be able to look out the left side (90 Degress) of the window and see smooth movement not stutter (Yes i achieved it 85-90% perfect)

Issues:

  • You may get a drop for a little while on occasions but it minor to the overall benefit. stays solid most of the time. Its more the game rather than this setup.

Here are the settings:

OTT
image
image

MSFS - 2D Settings

MSFS - VR Settings


Windows Settings
image

Oculus Home Settings

NVIDA - 457.30
image
image
image

Bonus things you could do:

  • I got these settings leaving Flightsimulator @ normal process priority but you could move to high
  • You could also play with the Glass Cockpit refresh rate to medium or high depending on aircraft

Flightsimulator.exe


image
(Note: I did not have these settings turned on when i got the outcomes above but could provide additional value)

I hope that this Helps those people that just want to fly for a while and forget the tweaking for the next few months until things improve.

My Suggested process for your own individual Use Case:

  1. Pick somewhere that you love flying on a regular basis and your preferred aircraft
  2. Turn all the settings down to the lowest possible setting
  3. Turn on the performance hud in OTT so that you can see your current Oculus frame count. At the lowest level this will be your max Frames capability for the meantime till better drivers and updates and oculus updates happen. (Based on my other suggested non MSFS Settings)
  4. Load into your flight ensuring that you are in VR before you click Fly
  5. Go through each option 1 by 1. click higher then apply settings and review the frame drop if any. Repeat until you get a drop. You want to be aiming for 33-36FPS in outside view in a heavy area (Looking at a heavy scenery area that you like flying regularly)
  6. move on to next setting. You may have to go back to one of the previous settings to lower if you have a preference for a particular setting i.e clouds (a killer).

Always make sure that you load into VR before going into the Flight (Starting the flight). Also when you are in the flight at this point, you will then go back into the menu and do the above steps

Thank you everyone for your suggestions. I finally decided to quit VR and go back to my OLED 4K, VR is no where clear and sharp compared to 4K visuals. The blur in VR is causing my eyes some weird sickness, Tried so many IDPs & settings but still 720p blurry. Guess I will wait year or 2 for VR to be on top level.
(Selling my quest 2, which i bought 5 days ago)

Again thank you.

I’m running a 3090, 10850k and 32 GB of ram.
Since the latest Nvidia driver I’ve found that I don’t need OTT at all and just uninstalled it.
I don’t see any point setting supersampling in OTT, just set your render resolution on the Quest 2 app to the maximun, that’s 5408 x 2736. That’s the actual native render resolution of the Quest 2 corrected for barrel distortion. Then try and get as high as possibly in game render in MSFS. I currently use 80, for a 3070 you might need to use 70 Hz

Regarding refresh rate 72HZ if fine for Flight Simulator and in fact if you’re using Oculus link Version 27 it’s forced at 72HZ regardless of what refresh rate you use. Even if you’re running 80Hz in version 27 you’re still only getting 72HZ.

You want to ensure your encode bitrate in the Oculus Debug Tool is set to at least 350 to eliminate compression artifacts, I use 450 but I’m not sure it makes any visual difference above 350 to be honest.

I’ve noticed that disabling full screen optimizations improves my frame rate. I have GPU Enbabled Scheduling (HAGS) set to ON for the latest Nvidia driver 465.89 as that is what NVidia themselves recommend saying that turning it off can lead to microstutter in VR. Note that is specific to this driver only, most people report better performance with HAGS off with other drives.

In game settings I personally disable ambient occlusion as it offers little visual gain for a fairly sizeable FPS hit, I also keep shadows maps on low, I think 1024 and 256.

My system is running pretty much perfectly smoothly now after having a jittery cockpit for months up to this current Nvidia driver.

Clarity in the cockpit is excellent with 5408 x 2736 and a render resolution of 80, I can read all dials and even the safety warnings in the cockpit very clearly. You might need to drop to 70 on a 3070, but it still looks pretty decent there too.

1 Like

Have you set the encode bitrate to 350 or above? By defauly its set to 150 mb and causes a lot of visible compression artifacts and looks pretty ■■■■. At a render resolution of 5408 x 2736 and high encode bitrate it should look perfectly clear and sharp providing you have your eyes in the right position.

I have a 65in 4k TV and I can’t play MSFS on it all now as it just lacks any atmosphere whatsoever, it doesn’t feel like I’m playing a game, just watching a Youtube video.

Hey ty for your response. Last settings i tried was 90hz max res on oculus app, OTT 1.0 and 1.3 SS. The bitrate was 500 from day one. In game, everything is off or low apart from Texture/trees. HAGS off and game mode off. The cockpit seems to be clear but when i look outside its just blurry and really affecting my eyes. i wear glasses though

Adding it more, the VR display seems to be very dim and dark, lack of colors as well. Any solution for that as well?

Ditch supersampling altogether. Set it at its maximum render resolution 5408 x 2736. That is actually the Quest’s native render resolution and looks better than any other setting. Because we view our displays through curved fresnel lenses that introduces distortion, giving a warped image. You need to render at 5408 x 2736 to correct for the barrel distortion and get a 1 to 1 display to render match for the best clarity.

Regarding it being dark, no that’s just the colour unfortunately. It’s a battery powered device so I guess they can’t have it much brighter than that. I’ve just got used to it.

I’d raise your in game settings a bit. I find reflections and contact shadow options are important to be on although medium is fine. Have the render resolution in game at 80 if possible, drop to 70 if choppy.

Alright. i will try it out one more time, lets see and thank you