Horrible stuttering after SU8

So far this has happened at 3different airports. FPS is normal the entire flight until just before landing, then it completely drops to 2-5 FPS, right when I need a smooth FPS the most. Aircraft is no longer landable after SU8. Anyone else seeing this?


Not for me. Entirely the opposite in fact. The few stutters I used to get in busy areas or on approach have mostly gone since SU8.

I drop down to about 25fps on approach into London City (EGLC) but certainly not seen any drops to 2-5fps.

1 Like

Updates can sometimes change settings, although I have not heard of this with the latest SU.

You can glean a lot from running developers mode. This sounds like a CPU spike, and likely can be addressed by reducing level or detail for terrain and/or objects… and maybe reducing traffic.

Also, FIRST make sure you empty your community folder (new patch… that’s the first step to debug). And clear your rolling cache (second debug step after a new patch).

And make sure you are running in DX11.

As a last resort, if you still have degraded performance a clean reinstall of MSFS. Ugh… I know…

I bit the bullet and did this as SU8 was a CTD mess, and performance was horrific. Fixed both problems. I haven’t done a clean in stall in a while (Since SU5) Guess I was overdue.

1 Like

Appreciate the feedback. I’ll check again in case the update tweaked some settings, but I adjusted the LODs before the update so it was running GPU limited, and I’m still on DX11. No rolling cache either. I guess I’ll start clearing the community folder if the settings look correct.

1 Like

Same on the XBX. Everything is smooth and fluid but when you get below like 500ft to land it starts stuttering and a big drop in frame rates.

Same with take off but not as bad. As soon as you gain altitude the stuttering stops.


THAT is almost certainly a CPU spike issue and the XBOX Series X really needs a performance graphics mode for folks who can’t stand the stutters in 4K.

I have to say that I too had awful stutters after sim update 8, but they have now settled down again to a point where I get a very smooth experience. This is the third sim update in a row where for 3-7 days after the update there has been stuttering followed by panic from me, but they’ve resolved themselves everytime. Someone mentioned it could be related to high load on the servers. Has anyone else experienced a gradual decrease in this issue several days after the updates? Hopefully most of you will find it will resolve itself, though I know each situation is different.

1 Like

Are you using FBW A320 Experimental version? I also had the same issue. The exp version is still unstable. After I switched to the Dev version, the issue is gone.

1 Like

If it’s a third party one, as far as I have seen stutters are granted anytime the airport includes a custom satellite texture. The texture size is so big that game struggles to handle it. I experienced that even in areas with no so much details around. Once you enter the airport area (even at 5 km away from runway) the stuttering party starts.

Either developers avoid using custom terrain textures or Asobo allows compression of the textures, but current method (with file sizes of gigas) is not working well.


1 Like

I definitely experience stutters in SU8, at least sometimes on flights over an hour say. I’ve noticed my RAM usage slowly climbs from the low 30’s to highest so far after over 2 hours was 62%. Looks like a memory leak to me. FPS is always pretty OK from 30s-40FPS on the ground to 50+ in the air. Typically I’ll start off a flight very smooth, then gradually the stutters will increase, and are worse aloft, generally less at airports. IN my case in Dev mode it looks like the Graphics card has all the stutters (GTX 1080 Ti) at 1440p, whereas the CPU (i7 11700k @5GHz) is OK.

I was given this advice in another thread and it worked for me. You can try it while another solution comes up.

You are desribing exactly what happened to me - similar rig specs by the way.
Turned out to be an addon in the Community File I hadn’t noticed. It was a DEM file (third party scenery improvement) which obviously doesn’t like SU8 as the problem disappeared when I deleted it.

Which DEM was it?

When after update, CTD’s or stutter, I immediately delete \Official and re-download the whole thing

British Columbia.

But I’ve dropped all DEMs that I had downloaded on the basis my rig doesn’t really show much difference and the sim scenery is getting better.

Same. I deleted my NZ mesh today, before realising that it was just Australia that got a world update. I figured NZ isn’t too far behind.

Yes, and after I went through about a 3 hour process of elimination (removed various items from Community), then moved over to the dev version of the A32NX and it fixed it! Never saw this type of issue with the mod before, so didn’t think to start there with the troubleshooting. Even the exp version has been really stable for me.

I suffered stuttering after sim update 8. Partly due to the powerlines and solar farms addon, but also I didn’t know a windows update was happening in the background. Yesterday my performance went back to silky smooth as usual - the update had finished downloading and was ready to install. May have affected others so just throwing it out there.

For me, it seems that the updates screw up the installation. Not saying this is true for everyone. So ever since SU 5 I do a full reinstall with each sim update and the problems are much less and some things fixed.

Had a crash with a button that crashed the sim. Reinstalled and it was fixed, very frustrating but for me the only way to “bring” the sim to same performance and expectation is reinstall with SUs.