How do I skip a leg in the G3000?

I flew from KRDD to KFMN the other night:


While attempting to find frequencies for RNAV05 , set the approach, etc. as I neared zenfo, I made a complete mess of things and somehow “missed” zenfo. So I’m halfway to ovpue by now and decided to bail on the APR button and just went back to the NAV button. The little pink line dutifully sent me back 240KM to beryl!!

I couldn’t figure any way to “forget” the last two waypoints, and make ovpue the next waypoint, so NAV off and hand-fly the approach.

So in case I mess up again: How do I skip a leg in the G3000?


1 Like

Did you try using the secondary console screen between the pilot and copilot? Use MFD soft key, then flight plan and scroll down to approach. Click on the waypoint and remove.

I’ve not tried it But it should remove the waypoint. Next you can select a waypoint and “make active leg”

This issue has been noted in this megathread.

The devs have also formally acknowledged this problem in their September 3rd update.

Hopefully the devs improve upon all the Garmin avionics functionality with the next update, for now the old adage “hurry up and wait” seems to be the only advice to give you as the direct to function is very broken.

1 Like

Yeah; I failed to mention that I tried clicking on the waypoint and deleting it, but I never got an option when clicking on any of the waypoints. Should also be able to simply choose the “next” waypoint and go direct to it. That doesn’t work either (no options pop up when clicking the waypoint).

So looks like it’s a bug (thanks for the post link, @TBCaptain!) and I’ll have to live with it for now.

Thanks for the responses!