How’s your CRJ experience going?

Normally you should be able to switch to NAV mode. Did you try that?
If that doesn’t work, check on your PFD in the lower left corner, if the FMS is the Navigation source. If not, switch to this Navigation source and try again to engage the NAV mode.

1 Like

Have it set to FMS 1 but nav mode refuses to come on

Maybe it struggles because you are off the route. Try to copy the next waypoint you wanna go to in your scratchpad and paste it again on the top of your route. The FMS will then draw a direct line from your current position to the next waypoint. Try to engage NAV mode again and see if it will follow then.

Hi, at the start of every flight if I click and drag both throttles, I’m able to then move my throttle with my hotas. Seems I have to interact with the mouse first for it to become active. You can try this method, might help.

I have done about 10 flights in vr by now. And it is the best optimized airliner by far in terms of smoothness and performance. I have a G2, so the displays are really sharp and I have no issues reading font. Only a few areas have cli
I7-8700K 4.9GHz
GTX 1080 Ti
100TAA + 50 SS

I wasn’t off route until it overshot a waypoint without turning and I noticed then it was in ROLL. Ended up getting lag and had to end my flight early but would like to figure out how to avoid that from happeing again lol


might bring some reassurance

Did you have any cautions on the CAS?

I’ve had this happen before and it seems to be an issue with sequencing waypoints (potentially after amending the f/pln in flight). I just went direct to the next logical waypoint then it would let me enable NAV.

It shows FMS1, but no Waypoint below that, which it should. So it’s definitely a waypoint problem. I’d check for discontinuities or other obvious problems with your flightplan.

1 Like

Yes, that’s necessary, because in the CRJ, the engine Shut-Off is part of the throttle movement and to not risk a pilot shutting off the engines mid-flight, you have these red lock-things that make sure to get the throttle between Idle and max power.

So before you can use your Hotas, you have to click on the red throttle-locks and put the thrust levers into idle manually. After starting both engines and having both throttles in Idle you can fully use a Hotas.

Also, the CRJ is AMAZING in VR. Especially in the Reverb G2. I have the Render Resolution set to 60% and ingame to 110% and can read everything fine. Lower resolutions are probably tough, but you can always use the “hold right mouse button” feature to zoom in on everything.

1 Like

Having exactly the same problems. Yesterday everything worked fine, today I can´t start flying. Tried it about 5 times, restarted meanwhile → No Help

Seems to be randomly working for me. Have had a few succeful flights. Noticed if I loaded another plane first then went back to main menu the CRJ would load. It seems to CTD just before approach the last few times I’ve managed to get it in the air!
Bar these issues, I do love it a lot. Hopefully the cause of the CTDs here shows itself soon! Will be nice to get a full flight in successfully :grinning_face_with_smiling_eyes:

1 Like

I am a lucky guy, as written above disabling AI traffic avoided the CTDs.

1 Like

Weird issue just discovered. I run Pilot2ATC on a 2nd monitor.

I got the CRJ all powered up and ready for taxi. Realised I forgot to connect P2A so Clicked the connect button on P2A and the CRJ all powered down!

So far it has been a good experience for me, few teething issues in the beginning. None of my controls would work, did a complete system reboot and that fixed it. Set up my throttles as per the manual and it works good.

I have never flown a CRJ in real life, but have lots of Dash-8, 737, and corporate jet time. It flys very similar to the Gulfstream G280, but without all the fancy automation.

By todays standard the CRJ cockpit is old, the Proline 4 is a good platform however, the CDU is similar to the Proline Fusion in the G280 and Proline 21 we have in our King Air.

It’s a fun airplane to fly and has become my MSFS favourite so far.


Overall, it`s a great aircraft. But I have trouble with the Logitech/Saitek Panels, especially the autopilot, the light switches don’t work.

Doesnt seem to be the full solution for me. 6 out of the last 10 tries have been succeful though! So definitley narrowing down my problem :slight_smile:

Edit: seemingly loading more succefully now. So seems to have been the main issue. Also the waco no longer causes CTD. Bonus… Getting a much smoother flight too wothout AI. Bit lifeless but can get by for the time being wothout it.

1 Like

anyone have an issue with the AP following a straight line from WPT to WPT when winds present at cruise? it keeps adjusting left and right, pretty weird. I don’t bother putting in the wind info in the fms but I think that’s a little too much adjustment.

When I try to introduce the arrival on the FMS the plane freezes. Sometimes the screen gets stock there, other times I can move the image but every button I press it doesn’t make anything. This only happens when I try to insert the arrival manually. Anyone has this problem?