How to Get the Update to Appear in Windows Store

Worked for me too. Still not going to buy an XBox.

Actually it failed with no surprise

Why can’t XBox App be uninstalled? To reinstall instead of eventually giving in and having to uninstall a full game?
I’ve tried resetting it, repairing it, Uninstall is grayed out.
At least it’s not saying I need expanded access anymore.

The upgrade is still not available in the store

I’m about to say some nasty things about opening this up to the console crowd

What a bunch of endless ■■■■
Why a disc if I bought on line???
So sick this is

Thank you, work for me.

I started updating this since noon and it is 11 pm and yet on it
This is a joke
And despite I installed it, it continues crashing
What a nightmare

Where is the update process broken? MSFS? MS Store? Xbox? If the Xbox app is REQUIRED, why doesn’t MSFS or MS Store tell users this important information?


It took me half a day to managed to Install the Update !
I couldn’t get the small Update in my Microsoft Store . I tried several times to sign Out and Sign In , I Disabled my Firewall , Restart my PC , Check my Widows Updates and downloaded the latest version !! Nothing helped .
I searched through the forums and i read that i should download the Xbox App ! No idea what was that ! I searched and and found the application . After i downloaded it , i run it . I then checked my Microsoft Store and the Update Appeared !!!
Everything is working fine now :smiley:
I never had such an issue in the past !!
Could someone tell me what happened with the latest update this time and it took me sooo long to find the solution ?

Normally it happens when the server is down for any reason

Is the Xbox app required to receive MSFS updates from now on?

Oh God now it seems I have the game installed twice

I can’t stand this

I dont think it is possible… Maybe was just a bug of geforce experience

I have it installed in C and in D
I originally installed in D and nothing new is intalled or updated there.
All stuff dated Set 7 is in C
I’ll unintall everything

Today when I clicked on get updates in app , the download happened. I did this yesterday but no response. I wonder if downloads was not functioning yesterday? Just a thought.

I was so hoping you were right, but it wasn’t there.
Would be so hard to do it old-school, when I bought games between the 90s and up to a few years ago, you only had to look online download the executable from the official website, MSFS 4 through to FSX included. The acrimony that Asobo is facing now would probably be easier to handle. Let the XBox Consoles do it this way, let the PCs get on with enjoying the game.

Yes that happened to me also

Did not work for me…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.