How to Get the Update to Appear in Windows Store

Here is what worked for me: Close the Windows store. Open the Xbox App and then close it. Then reopen the Windows store and click on “get downloads and updates” in the menu on the upper right. The update appears and downloads. Mine was 509 MB.

-Joe

8 Likes

did not work for me …

I reset Microsoft Store cache and update appeared
https://flightsimulator.zendesk.com/hc/en-us/articles/4405345181202

5 Likes

This seems to have worked for me too!

1 Like

Hmm, sorry about that. It worked on my end. I also pressed the Win + R keys and ran the command “wsreset.exe” to reset the store cache.

But it wasn’t until I opened and closed the XBox App (not the XBox game bar) that the download appeared.

Good luck!

4 Likes

Try this:

11 Likes

that was the final solution for me! Thank you!

2 Likes

Thanks for the help

1 Like

I had to go into “Manage installs” in the XBox app to trigger the update.

They’ve had forever to test this thing and it crashes in the first lap before the first turn. Totally Disappointing.

1 Like

Thanks, worked for me👍

1 Like

thanks this helped. First time since early alpha that an update wouldn’t automatically start for me. Strange…

Running the xbox app seemed to fix it for me. Thanks.

1 Like

worked for me!

Here’s the best fix to solve this problem. Never buy games of the Microsoft store since it’s ■■■■. Buy the game on Steam and you will never have problems

1 Like

Now that I have yet another app that I don’t need (Xbox), I’m finally downloading the update. If I didn’t love flying this thing so much, it might not be worth the effort. Plus, with as much money as I sank on the purchase, I’m not giving it up…

2 Likes

I have tried all this…downloaded the app and nothing happens. What a waste of time…quite simply a pain in the ■■■■!!! :rage:

1 Like

Can you uninstall the xbox app after updating the flight sim and will it still launch/run afterwards without the xbox app? I like to keep to a minimum the number of applications installed to help the flight sim run smoothly.

Of course you can

And of course I got a download loop on the biggest package… #48/56 - progress bar went from 98% all the way back to 38%. I quit the program, deleted the uncompressed stuff, and I’m trying again now.