How to remove the trees in the approach path of St Barth ? Doing it with sdk doesn't work


I fly regularly to St Barth in MSFS (I have the the premium version of MSFS with Asobo’s St Barth scenery installed) and I am very annoyed by the trees right in the middle of the final approach path. IRW, there are no trees. I tried to use the SDK to remove them with either an exclusion rectangle or a vegetation polygon and negative settings, but nothing works.
Any idea on how to remove these trees for good? Is it because I am trying to modify a 3rd party scenery (even if its made by Asobo) ? Thanks for your help!

1 Like

I think 3rd party sceneries cannot be modified as you need to open the project files which are not provided by payware developers.

1 Like

Consider putting in a Zendesk since the airport does not match the real world. They will get to it since many of us have flown into that airport.


Thank you guys !

I will report it then.

1 Like

Yes…it’s terrible isn’t it! not at all realistic.

1 Like

One of the most well known approaches on the planet thanks to YouTube. What was the point of Asobo hand crafting it, to then leave it almost unusable like this? And no attempt to fix it.

1 Like

If you delete the handmade version you end up with a bare hillside so the developer especially added it just for us.

This is an unusual decision.

I would suggest making an exclusion and naming the folder with a ‘z-’ at the start so it loads higher than the original and might override it, but I don’t think that’ll work for an Asobo one.

As it stands I think the airport would have to be remade completely, and since you can’t use the buildings unless the airport is present as a package you’d have to remake the entire thing from scratch.

1 Like

Id it’ Is Asobo’s scenery, you don’t Need special naming, because Community sceneries are loaded After them (loading order Is from Content.xml file)

You can exclude pretty much everything you want based on priority, Asobo or 3d party,
In this case those seem like default trees, of you can exclude them with a polygon vegetation set to zero (maybe with a priority set to 10) you can exclude the polygon generating the trees with a ExclusionRectangle with the excludePolygon option

I had a play with it.

A vegetation polygon turned down to zero didn’t delete the trees. It did make them black for some reason.

Maybe we need to know where the whole original polygon is located. I presume partial coverage won’t work.

1 Like

I hope you guys can come up with some solution. Will keep my fingers crossed as I am also annoyed by those large trees on the approach. Sending Zedesk ticket may work as well as Asobo corrects usually those kinds of issues when reported.

Can not help further atm,
You can try to enable Debug shapes in the Dev menu, (Will show any polygon with colorful outliner)
It Will also tell you what Is that package that generate the shapes

if an exclusionrectangle Is needed, Remember that It only works when compiled and placed in community (and are known to work poorly with exludeAll option, so avoid It)

Ah. Good idea. That’s a tool I never really use.

It is possible to extract the original buildings with ModelconverterX so someone could make a new project with their models if all else fails.

Hmm. That’s another nope even when locating the original polygon, overriding it, increasing priority and making the mod folder load first.

The Bijan studio tree mod has dealt with this, but that’s filled with witchcraft.

If it’s bijian special trees, the 3d models, than you can use ExclusionRectangle with exclude Library objects
Look like a nice challenge,if don’t succed i Will give a try too :blush:

Unfortunately he solved this with his mod rather than caused it.

This is all original Asobo annoyance.

I’ll have one final fiddle and then toss my cookies.

Thank you guys for your help ! Keep them ideas coming !

This area can only be fixed in SDK as I did here:

1 Like

Which of your four season choices are you using in this shot?

1 Like

It should be all same since this area doesn’t change much in different seasons. This was spring.

1 Like

Trying it now… great job. Thank you