How to turn off the Registration Number with the Panel.cfg file (from YMF5 livery discussion thread)

See Solution below.

Original text, edited: The only current known way to get rid of the Registration is to use the panel.cfg hack.
Unfortunately, since about 3 updates ago, this hack requires a panel.xml file to also exist or some instruments won’t light up. The panel.xml would tell the gauges which electrical circuit to access.
Unfortunately Carenado encrypts their config files, so there’s no access to the panel.xml file, or the config files we’d need to write one ourselves.
It’s one thing to write a panel.xml file for the Asobo planes. But I spent a day trying to write one for the Mooney and got nowhere.

So far, no one has come forward to describe another reliable way of turning off the Registration decal. Until Now… See below

An alternative solution would be to have Asobo activate the atc_ commands in the aircraft.cfg, most of which currently don’t work as of the 12/23 update. I have submitted a bug report to Asobo Zendesk asking them to activate the atc_id_enable in the aircraft.cfg file. In past versions of FS, this key would turn off the decal, but still allow the use of the atc_id key for setting the Registration number for use by ATC.

There is no problem with handling this aircraft for me it is a taildragger and does what a taildragger should do: keep the stick back until the tail comes up and use rudder on take-off (and maybe tail wheel lock) and keep stick back after landings and use rudder and NO brakes! until you are almost at a stand still.

Informative video about the whole plane: No brakes!

Center of gravity display in the sim should just be ignored as some devs use tricks to get the plane to behave like it should atm. (this will probably get a fix in the future)

There is no problem with panel.xml or gauges. (when using the edited panel.cfg)
You can use the original gauges by linking to them in the panel.cfg:

You have to use this method for all Carenado xml gauges.

And use something like this in the panel.xml:
<Include RelativeFile="../../Carenado_WYMF5/panel.02/panel.xml"/>

Then all gauges work and you can change colors/registration.

I did make an example for Cpt-Moustache that was working on this livery: link to example livery


Awesome! Thank you so much! This is the info I’ve been looking for.

I just tested it on the Carenado Mooney, and it worked great!

To be clear on the solution (it took me a couple of tries to figure it out), there are two steps. For any gauges that exist in directories in the panel directory of the plane, you have to change the path to them, as @MikeFear303 noted, in the gaugexx= lines of the panel.cfg file. You do not need to change the path for default gauges (like the KT76c Transponder).

Then you need to create a panel.xml file add a line with to include the default panel.xml as outlined by @MikeFear303 above.

Yes I meant the edited panel.cfg
You can study/use the example for making your own liveries.
The include should be the only line in your livery panel.xml

1 Like

So there are 2 ways: 1 you described, and 2, after all other modifications are done to the aircraft.cfg file, open the file in word, goto the atc_id line where it says “” or you would put “Nxxxxx” to give it a specific id number and in the quotes goto “insert”, “symbol” and make sure the symbol types are under basic Latin, there should be an empty box nearly in the center of all the options. It will look like a space is there. But it’s nothing just a blank spot. Save and test.
Its important to not save the file from any other programs after that, or it will put a random symbol in there and overwrite your blank one.

Mike i had trouble in some liveries using the panel file because it would link com1/nav1 and com2/nav2 together, when you changed one you changed the other. Have you experienced that?

No each of both radio gauges has it’s own index number in the panel.cfg make sure they have ?index=1 and the other one ?index=2 at the end of the html gauge link .


Last time I checked, this is not a valid solution.

I like to use ATC. I want to apply a default Registration number for the plane that matches the number on the outside of the plane that ATC uses. This method will not allow ATC to use the Registration number.

I can’t use the in game ATC, it hasnt worked since the 2nd update for me. So didnt think of that. I use vatsim only.

Mike, I’ll have to check that out, i think the classic 172 may be different.

1 Like

In the classic 172, it should work if you use

<Include RelativeFile="../../Asobo_C172sp_classic/panel/panel.xml"/>

Edit: oops, I spoke before looking at the example… corrected below

into a blank panel.xml file in the panel directory in question. The comm1/comm2 callouts are in the panel.xml file for the Cessna.

Edit: Unfortunately, while it works for other planes, I cannot use this method without it linking the two nav/comm radios together :frowning:

You are in the wrong topic for the classic 172 :wink:
As my solution was custom tailored to the WYMF-5 but the same linking/include methods can be used on most planes but take a look at how the code/cfg works first :slight_smile:

Given this is a general solution, I was going to change the title of the thread to General panel.cfg Registration hack solution.

But, he’s right, I’ve tested this solution in multiple ways and for some reason it does not work with the C172 Classic. I’m at a loss to figure out why.

1 Like

You’re right, I am in the wrong topic. I assumed (wrongly it seems lol) that the problems I had with the 172 extended to all the other planes. I am glad to know that it doesn’t. :slight_smile: sorry if I misled anyone.

Nope, it is now the correct topic :grin:

I just changed the title since I own the thread now :slight_smile:

And, once again, @MikeFear303 came through for us again!

In the case of the C172 Classic, you need the panel.xml. For some reason, “Inlcluding” the default panel.xml doesn’t work as far as the radios being linked. But, as Mike pointed out to me, if you download the Aviators livery, it contains the panel.xml file we need. Asobo must have found the bug, too, haha. So, anyway, copy this panel.xml file to your livery panel directory and add it to the layout.json file and the radios will no longer be linked!


Thanks! that’s awesome, thank you both. I have lots of liveries to update now lol.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.