HP Reverb G2 VR Headset - Bad News for AMD Motherboard Users - Error Code: 1-8

Hi all,

I just received my HP Reverb G2 Headset and was super excited to experience flying with it. I tried to connect it to my PC for more than an hour but it kept giving me the Error Code: 1-8.

I ended up calling HP Support. They informed me that the dongle and the cables that come with the headset do not support AMD motherboards. They took my contact information and my shipping address to send me a new cable that supports AMD systems. :hushed:

I appreciate that the are taking care of the issue by supplying me with a solution cable, but I am disappointed at the same time. I hate that after the long wait and the shipment delays from the lack of supply that all buyers had to go through, AMD users will have to deal with this and wait extra time. The new cable will take at least one week to arrive. It may take longer with the holidays being after tomorrow. They said they will not be using fast shipping, but only regular speed shipments.

:nauseated_face: Update!!: 12/31/2020

I called HP because I never received a tracking number for the new cable. The rep told me that the new cable in on backorder for March. He said that I could request to return my headset and get another one as that might be a problem with my current unit.

Today I received a replacement unit and unfortunately, this has NOT resolve the problem. Still showing me Error Code: 1-8

1 Like

Are you using an AMD graphics card, AMD CPU or both?

If you have an x590 M4 motherboard try to disable PCIe 4th gen inside your BIOS, and instead set the PCIe port to 3rd gen.

Yes, I am using AMD GPU and CPU.

I have a B450 Gaming Pro Carbon Max Wifi motherboard. Would that still work?

It’s been a nightmare for me. There are some AMD GPU users who are having success. But, then there are many including me who haven’t even been able to get the headset turn on. As soon as you plug the USB and DP cable, it will crash the system to BSOD with memory_management error. Works fine with NVIDIA cards. If you have AMD GPU, I would advise you to wait. The cable doesn’t exist. HP doesn’t have any parts, nor replacement unit reserved for RMA. They are selling everything they receive and the wait for replacement if you send yours back is about 3 months. I am even surprised that you received the acknowledgement from HP that their cable is not compatible.

1 Like

I think this would be for the x590 only - it made it work for me (before doing this I would get random errors when using Reverb G2)

2 Likes

I have the x570 board and I tried the PCIe to USB 3.0 method. Worked for 30 mins then Reverb G2 kept closing and then PC restarted.
No BIOS option to revert back to Gen3

HP has a replacement cable as the solution for a fix??? Interesting.

1 Like

I had problems with my mortar max until I put a pcie usb 3 in. Works great now apart from the odd ‘please connect your headset’ , so I disable and re-enable the Renesas driver in device manager and all is well again.

1 Like

I have the same is no problem with NVidia RTX 2070 super

1 Like

I’ve got HP Reverb G2 with ryzen 5 3600, ASUS Radeon RX 5700 XT ROG STRIX OC 8G, motherboard MSI MPG X570 GAMING PLUS.
And MSFS 2020 & VR works on it fine.

2 Likes

I had this issue on my msi x570 tomahawk but I found if I use one of the fast usb 3 ports at the back with the dongle it works, pcie 4 enabled. It’s only one port that it works on consistently, the adjacent red port doesn’t work.

Specs:
Reverb g2
X570 msi tomahawk
Amd 5950x
3090 FE
32gb 3600 CL16 g.skill kit running at 3800
Lian li lancool 2 mesh
Corsair rm850x

Can you explain what you mean by the Renesas driver in the device manager?

It’s not the GPU though, it is the AMD compatible motherboards that are not supporting this ■■■■ headset. Shame!

Asus Prime x470 Pro, and RTX 3080. Had to plug USB into an expansion PCI USB card for it to work, but it has been fine since

The G2 only worked on the front panel USB-C port on my MSI x570 Unify. Not the rear USB-C port, or any of the USB 3 ports with the adapter. And then it only worked for 2 days. Now I’m getting an error saying it can’t make a USB 3 connection at all no matter what I try. Waiting for an expansion card to try, and if that doesn’t work I’m sending this piece of s*** headset back for a refund.

Sorry I have to correct you on this. There is a separate issue with AMD GPUs. I have intel system with z390. Somehow some G2 will crash with BSOD memory_managment stop code no matter what system you use. It only happens with AMD GPUs all the way up to the latest 6800XT.

I had the 1-8 error on my Intel system and fixed it.

The USB 3.0 eXtensible Host Controller driver was the problem. In Device Manager I uninstalled the OEM driver and installed the generic Microsoft driver.

Hi everyone.

Although it sounds somewhat unrelated, have you tried updating your network interface driver to the latest, or at least change to the NIC chipset manufacturers driver (eg. Intel not Asus’ version etc)? In the past there have been some issues with the NIC driver somehow interrupting the USB 3 ports under certain conditions.

i ve an “old” Z170 Asus Motherboard with Intel 6900K on. I had many issues with the Reverb G2, starting by not being even recognized when on USB3.0 port… after many attempt on tweaking Bios changing the port it was connected to i successed to make it being recognized ,…win10 then load some …drivers …
At this point i had : G2 recognized , making the trick with XPlane and MSFS but not working with the G2 demo stuff like “Halo REcruit”. IT fact i can start the Demo then i had i eye black for seconds , or both eyes in black for seconds /minutes, sometime the sound was dong some strange noise …
Well …something ws WRONG.
After reading forums here an there i tried to buy and use a specific USB3.1 10Gb card (PEXUSB312IC form startech) plugged on USBA port. (not forgetting to provide power via sata powerline)

IT WORKS !!! ( only after installing the specific driver).

NB: I ve to say that all my tests looks like a kind of “Magic”. CALL TO PEOPLE WHO MAKE NORMS : MAKE IT BETTER

1 Like