HP Reverb WMR motion reprojection only 20FPS problem - solved

I’m sure many of you rejoiced with me when support for FS2020 VR was finally released. I was a bit apprehensive about it, but it ran at surprisingly usable speeds on my old machine with my HP reverb VR glasses. Of course there was a resolution downgrade and a compromise in quality, but OpenXR motion reprojection helped make it enjoyable. Fixed the setting, since 90hz is an underdog, and bliss.

Everyone knows the GPU price situation, but I finally gave up waiting and settled on an AMD 6800XT card. My previous ASUS ROG STRIX 1080TI card produced well over 2x the speed of my previous card under VRMARK, for example, so I had very high hopes for the roughly $1000 dollar investment (if I sell my old card!).

After starting the FS2020, however, I was dismayed to find that the framerate was still around 20 FPS.
I tried every trick in the book, lowered the render resulution, lowered the graphics quality, moved the image enhancement settings to the AMD driver from the FS2020 settings, nothing help. I was very suspicious of the 20FPS, I suspected it was artificially limited by something, however the HP reverb reprojection is 45 and 30 FPS, so it doesn’t match that.

Finally I uninstalled all VR related programs (WMR, OpenXR, OpenXR for dev) , cleaned everything and after a restart I just reinstall the minimum with default settings - and I got 50+ FPS under VR!

I then started to research what could have gone wrong. I won’t go into boring details, but rather share the results.

OpenXR for WMR brought an “innovation” (microsoft kind of) this spring, 22.5FPS motion reprojection.
“VR Flight Sim Guy” posted a short video in April to celebrate this:

Well, while on paper OXR will switch to 30 and 45 FPS if the machine can handle it - it doesn’t actually happen, it gets stuck in 22.5FPS mode. I ran a round that could affect this, registry, config file - nothing. However, I remembered that there is Motion reprojection under SteamVR, and there is an option under dev mode, OpenXR runtime. Well, that was the solution!

So, under OpenXR developers tool, turn everything off.
Windows Mixed Reality for SteamVR should be installed under SteamVR, of course.
Under SteamVR Settings/ Developer settings, set OpenXR runtime to SteamVR. (turn on the advanced settings!)
Under Settings/Video, set VR resulion to 100% (or less). Under the per-program setting, look for Flight Simulator. If it is not there, start the simulator, it will appear in the list. Set the resolution to max 100% and the motion smoothing to “always”.

If done correctly, head to FS2020, and depending on your machine in VR mode you may see it set to a stable motion reprojection FPS. For me for example, without it it produced 50-55FPS, so I set it to a fixed 45FPS and get a wonderfully stable, continuous image with the machine below:
10600K (4.8Ghz all core), 32GB DDR4, M2SSD, AMD 6800XT

So, in nutshell. Forget about the OpenXR for Windows Mixed Reality - use SteamVR!
Perhaps, in the (near-far) future it will be fixed. But NOW (aug. 2021) this is the solution if you like to make more FPS in VR mode.


Thank you for sharing, however i find that oxr produces clearly better results than the steamvr api. The only thing that i think steamvr is doing better is producing motion reprojection without distortions. The performance however is better with oxr. Well, i am running an nvidia card though, so perhaps with an ATI card the results may be different. Best regards

Hi, theoraticly you are right, less middle-man program, better result. This is why I bought the FS2020 in MS store and not in Steam, do not need steamVR. Perhaps, if they fix the reprojection bug, I will step back to “native” WMR as well. But ATM the OXR limit hurt, so for me the SteamVR give a better result :slight_smile: I do not know how strong your rig, but give a try to my suggestion, perhaps you will get a better result, too.

1 Like

Tried this and its way more stuttery than through wmr. This is with a 3090 5950x and 64gb ram, reverb g2 headset.

SteamVR motion reprojection works well for DCS but for msfs I’d much rather go through OXR and no motion reprojection.


i only have rtx 2070, but the result is the same. Way more stutters. I’m just really sad that there’s so much less distortions with steamvr MR. I wish OXR MR knew how to handle the reprojection without producing as much distortion.

Hi BunnyHU,

can I cask what render scale setting are you using within msfs, and other graphical settings?

My experience with 3090 / 3080 and 5900x is the same as the other posters where WMR-OpenXR is noticeably smoother than SteamVR-OpenXR. (using MSFS 100 render scale, objects and buildings ultimate, both LOD settings 200, most other settings at low)

I wish I could get steamVR-OpenXR to run as well as WMR, because turning up the VR world scale looks awesome.

I using 100% render scale, 100/100 both LOD, others usually medium / high except textures that is max (16GB far enough :smiley: ). I tried 80-90% render scale, but the cockpit readability is a bit worst. But because I have a fix 45FPS, I do not want lowering the scale. If you need, I can make screenshoot from setting, but the card is very new, so I am in the middle of the optimalization. My goal is stable 45fps with the maximum quality as I can.

How can you read the instruments with a render scale of 10???

1 Like

Sorry , 100%. There is no 10%, 50% is the low :slight_smile:

1 Like

I’ll join many others here and add that I find the experience smoother directly via WMR/OXR rather than SteamVR with the G2. There is still the possibility there is a difference between AMD and NVidia GPU here, but I’d be surprised it is because AFAIK SteamVR is using the NVidia OpticalFlow lib for the motion smoothing (Oculus is using the same), and this uses the Tensor Cores specifically to tap into otherwise dormant silicon.

I’ve posted my latest findings with the G2 and SU5 here for reference:
My 2070 SUPER VR settings and suggestion (Reverb G2 - WMR) - #703 by CptLucky8

1 Like

I’m not convinced either. I have a 6800XT and a high end rig and Steam VR didn’t work as well as WMR OXR for me. It’s early here, but I’ll give Steam VR another go later this morning and see how I go.

G2 headset
Ryzen 5600X
32 GB CL 16RAM
2*1 TB m.2 drives on mobo, + 2TB SATA SSD
570X mobo

I’ve read on other forums that HAGS ON is better for WMR reprojection and HAGS OFF is better for SteamVR reprojection.

Haven’t had a chance to try it for myself yet so take that with a pinch of salt.

I do have stutters in PCars2 with SteamVR motion reprojection on and HAGS on (Reverb G2), still have to test it with HAGS off.

It might be worth a try

You can try all of these tips and tricks until you’re blue in the face. The fact remains, Asobo needs a team on VR and it needs optimised.


With the correct settings, it doesn’t need optimizing - I run at 90fps using OXR reproj - you don’t have to be a rocket scientist just follow some simple guidelines which have been posted by a lot of MSFS VR YouTubers out there, but you have to compromise a little visually - no PC can run MSFS 90fps without reproj and it will never be optimized to do that, not any time soon anyway. :slight_smile:

1 Like

Well, I tried Steam VR again last night and it was no better than the last time. I get a much smoother experience with WMR and OXR. Instruments are perfectly readable and no stutters.

My problem that why this post born is the OXR stuck on 22.5FPS but my rig can make more than 45FPS. This is why I suggest SteamVR that can use 45 x 2 MR.
I got much smoother experience under SteamVR 45 x 2 than OXR 22.5 x 4.
I really want to know it someone can hit the 45FPS x 2 in OXR what rig, maybe what driver version, because I try everything but for me the OXR used only the low FPS!

1 Like

what is your rig, maybe what driver version, because I try everything but for me the OXR used only the 22.5 FPS! I got much smoother experience under SteamVR 45 x 2 than OXR 22.5 x 4.

I’m using an all AMD rig. I have most things on high or ultra and get high 30s to low 40’s. I hate motion reprojection so have it off.

Ryzen 5600X
32 GB CL 16RAM
2*1 TB m.2 drives on mobo, + 2TB SATA SSD
570X mobo

Ah, ok, without MR I have more than 50FPS. Can you please turn “alway on” the MR for me and check what FPS you got under native WMR + OXR?

You have a super duper computer BunnyHU, if getting 50fps and more with 100% settings etc :smiley:

1 Like