Huge FPS drop in world menu (and workaround). May be related to general FPS issues. 1.14.5

If I immediately go to the World Map as soon as the home menu appears, when I select a departure location, my FPS drops to 12fps, if I proceed with the flight, the FPS remains sub 20fps.

However, if I wait 10 seconds before going to the World Map (when the sim first loads), or if I exit the world map, and re-enter, the FPS remains normal.

Edit: This may have a bearing on the latest 1.14.5 FPS issue.

I can do this consistently every time I run the sim.

It seems that there is some house keeping going on while the Home Menu first appears, however, if the user immediately goes to the world map and selects a departure, something adversely effects the performance.

So far, I have reproduced this on my AMD 3950x, but not my Intel 4970k. (the 3950x has an older nVidia driver for VR reasons)

Not a biggie, but I have raised a zendesk report in anycase.

Edit: Zendesk have accepted this report forwarded on to the dev team.

What cards are you using since you have two different rigs?

You may need to cherry pick GPU driver versions as automatically updating doesn’t necessarily mean best performance.

I have this exact same problem sometimes when in the menus and flying.

https://www.flightsimulator.blog/2021/03/07/dramatic-fps-drop-issues/

I’ve had this issue happen with the two previous versions also.

3950x / 2080ti, and 4790K / 1080ti

Just waiting for a moment at the main menu avoids the issue for me

Well, just a thought… everybody was complaining that the GPU and CPU were maxed out while in menu system for no reason. This might be Asobo’s first attempt to reduce resource requirement while in menu system. Because, although the world map is effected sometimes, the resource usage has been reduced while in menu system

I have experienced the same behavior.

After updating the Geforce-Driver to the latest hotfix release the issue was solved for me.

GeForce Hotfix did not solve the issue in my case.

I have had laggy menus since UK update, but it is even worse after latest patch.

Interesting, that might explain why I haven’t seen it anymore as I usually start the sim and walk away. (Takes 5 minutes to load to the main menu) By the time I come back it is done ‘house keeping’

I get it too when zooming in all the way to where the parking spots appear. That has always been very laggy and since the update I had that ‘stick’ after zooming back out again. Normally it is smooth again after zooming back out.

I haven’t had any issues in the last few days, but also haven’t planned any routes to major airports. (Air strip hopping through Papua New Guinea)

With an empty community folder this happens for me too, adding aircraft addons like the FBW A32NX and WT CJ4 the home menu FPS goes up.