I cannot load any different airport and plane - always the same airport and same aircraft - non ascii windows 10 account name

Hi all! The developers need some help in trying to duplicate this issue. The topic just got updated to #need-your-help !

What would be helpful is (from those who are NOT using the “Beta version: Use UTF-8 for language compatibility” in Windows settings):

Assure you have the required US English Language pack installed for Apps & Websites:

  1. Do you have the US English Language pack installed?
  2. What is your regional language on your PC?
  3. What letter or letters are in your Windows user account?
  4. Does loading saved flight plans work for you?
  5. Is your installation location default on the C: drive or another drive?

What we know from this entire thread is that deleting the default saved flight files allows you to select another airport and/or aircraft.

Any details you can provide will be of great help in assisting the developers to duplicate this issue.

1 Like
  1. Do you have US English Language pack installed?
    Yes

  2. What is your regional language on your PC?
    Main language is Spanish (Paraguay), which when installed automatically installs the Spanish (Mexico) language pack
    Regional format is set to Paraguay
  3. What letter or letters are in your Windows user account?
    My user path is C:\Users\Matías so there’s a í in the path, my PC account was created with a microsoft account from what I can remember.
  4. Does loading saved flight plans work for you?
    No, even if the .pln file is located in a path with ascii characters only (tried with D:\)
2 Likes

Hi. For long time we know that a computer set with an account name that is using non English letters prevent msfs from delegating the last flight saved info causing the flight to start at the same airport.

Is there any intention from Microsoft to solve this issu? For users of non English language this is a major issue.

Thanks

Moshiko

I don’t think so honestly… bacause seems it is the problem or limitation: Windows 10.

Asobo will look into this. @Moshiko218, can you help by filling out steps 1-5 I posted above?
https://forums.flightsimulator.com/t/i-cannot-load-any-different-airport-and-plane-always-the-same-airport-and-same-aircraft-non-ascii-windows-10-account-name/302113/139

@ECTLG The same steps would be helpful.

Thank you!

2 Likes
  1. Do you have US English Language pack installed?
    Yes.
  2. Russian
  3. User account: Сергей, user directory: C:\Users\Сергей
  4. No
2 Likes

This is getting really tiring. I hope this is fixed soon. It’s a huge pain in the butt to have to restart the sim each time I want to do a new flight

  1. English Languiage
  2. English United States
    3.English Letters in my user account
  3. Loading a saved flight plan works.
2 Likes

I don’t know how far back this issue goes, but I experience it too. In an age where so much fuss is made about every little difference among us humans, it’s beyond sad to see that a huge company like MS still assumes everyone is American and everyone speaks English…

Hi all! I’m curious for those that have this issue, is how you installed MSFS.

Is your installation in the “default” location or have you customized the install location to another drive other than C:?

1 Like

I have installed in a disk other than C! in my case disk D! The app itself is always installed in C (although you can later move the app via windows to another disk), right ?
After the app itself was installed, I chose disk D where community and official are!
I myself have had this problem and had to create a local new account with only us English letters to make everything work!

This sounds interesting and I hope for a solution!

2 Likes
  1. English pack - OK
  2. Hungarian
  3. László
  4. No
  • Do you have the US English Language pack installed?
  • What is your regional language on your PC?
  • What letter or letters are in your Windows user account?
  • Does loading saved flight plans work for you?
1 Like

I had it installed on the C drive

1 Like

Hi could you solved the problem ?

Hi, I just bought the Flight Simulator Premium Deluxe and experience a bunch of bugs.
One of the bugs is the one described here: I cannot choose another start airport and it drives me nuts since hours!!!
I am using the Steam version on a PC with locale de-DE and having umlauts in the username.
Deleting the mentioned folder %APPDATA%\Microsoft Flight Simulator\MISSIONS\Custom only works once. Then the game is stucked again.
Is there any progress on the bug ticket? If such a simple thing does not work, I will simply return it.

A work around can be found here:
ref: All versions - Sim freezes or crashes before loading fully – Microsoft Flight Simulator Support (zendesk.com)

CHANGE SYSTEM LOCALE

If you’re using a non-English Windows 10 set-up, change the system locale.

  • In the “Type here to search” field type “Control Panel
  • Click on the “Administrative” tab click on “Change system locale” and set up Current language for non-Unicode programs to “English US

– OR –

CREATE A NEW LOCAL PROFILE WITHOUT USING SPECIAL CHARACTERS

If you have special characters (such as à, ù, Å, ò) in your Windows Profile, create a new local user or administrator account in Windows 10 with no special characters and run Microsoft Flight Simulator from that profile.

2 Likes

Frankly both ideas are not an option, since the 1st seems to mess with other games and the 2nd is making stuff may too complicated. Living in a world of 2022 we still got unicode problems on a flagship Microsoft product… yaaay. Such a shame!

Where is this I cant find it, please help this is stressing
me out

I cant find this man

This is about as complicated as it gets:

create_new_user

Still didnt get it working. But a different user requires additional security configs for all related internal/external drives. If you have the game files spreaded across multiple drives you need to add the new user to all Volumes + DIrectories and give him the same access rights as your original account (e.g. put him into admin group).

Currently the game is getting stucked after pressing “Ready to Fly”. Then after a while it crashes to desktop.