I Promise, I've had no CTD AT ALL for a while until this last World Update

It is getting really good to be able to enjoy study level airplanes. however, i am getting really concerned about how unstable MSFS is becoming. it is almost a tradition now that each update breaks the sim even further. Can we please do something to make these updates not mandatory anymore !


There is a wishlist topic here you can contribute to:

World Updates are not mandatory. Those you don’t need to install if you do not want them. You can also uninstall them.

Sim updates and nav data are mandatory.

1 Like

The World Update CONTENT isn’t mandatory. But the sim did update a bunch of stuff, and I suspect it was more than just the advertised AIRAC cycle.

I didn’t install the WU content. Yet after installing the mandatory parts of the update yesterday, I CTD’ed 4 of my 6 flights following the udpate. Even with a reboot in safe more with no addons, I still experienced a CTD. I haven’t had any significant CTDs since the SU7 hotfix in January. The only difference between the stability of my system on Monday eventing when I last used it and yesterday was this new update.

And now we’re seeing a multitude of reports of folks who had no issues (both PC and Xbox) prior to the Worls Update who can’t even get to the world map without a CTD. Again, the only difference for them is the new World Update.

1 Like

I am also experiencing CTD after the mandatory update. I would occasionally get one CTD after multiple flights, but I could deal with it. Now this update has made it worse for me. Every flight I have tried CTD. This is very frustrating. I have owned different versions of flight simulator through the years. I don’t remember having CTD problems.

1 Like

Sorting my folder by date, everything in the bottom half of the window was part of the launcher update.

When the sim loaded I updated my NXi, which is in the middle of the red lines.

Then everything about the top red line is WU9.


“fs-base-nav” is the AIRAC update I expect.

1 Like

The World Update changed no core code. If you believe it is giving you issues the best course of action is to remove the update using Content Manager.


You are probably right. Even if you take in to account the “fs-base” I listed above, when you drill down it looks like only the localisation files in that folder got changed, and nothing else.

I couldn’t tell you whether “fs-base-genericairports” was there before, but every single file in there has changed, as well as “fs-base-ui-widgets”. They could be causing issues I guess.

It’s perhaps more likely an issue with the Nav data? That might also explain why some users are having problems, and others are not. If you fly, and don’t make use of a GPS, or communicate with ATC, perhaps you would never encounter such as issue.

It may also explain why some people that use Navigraph, like myself, may not see such errors. If that is a cause in the first place.

I haven’t used in game ATC since SU7. I was trying to do some circuits with the 310 to practice smooth landings. I used no ATC, flight plan, nor GPS and I was having CTD shortly after takeoff. Didn’t even manage to get into the pattern. Even reloading in safe mode with no addons nor my Air Manager instruments running produced the same issue. CTD shortly after takeoff. Happend in 4 of my 6 flights. I’m also using Navigraph (except in safe mode), so that’s the nav data I’m using, not the sim’s.

In any case, something in the files that got pushed is causing issues because XCloud version of the sim is also experiencing serious CTD issues. And we can’t blame user hardware or addons for that. Not saying that you WERE blaming users in any way. Just saying that this kind of rules out issues on the end user side of things if their cloud gaming is also experiencing similar issues right after the WU9 update.

1 Like

Yes, point taken. I wasn’t suggesting it either, just looking for situational differences, things that might explain why some users have crashes, and other don’t. Addons are a popular target for that.

Agreed. I’m sure addons are the cause of a lot of issues. Perhaps even the majority. But when you experience the same issues in safe more, there’s something else at play.

My sim was rock solid after SU7 hotfix in January. It was the best experience I’d had to date. I’m not even sure I had a single CTD after that update until last week’s SU9 hotfix. That update brought a performance degradation and some minor stability issues.

But since the WU yesterday, it’s not been pretty and I feel like I’m back to where I was a year ago where I could barely ever get off the ground without a crash. And I don’t even have the WU content installed. Just the mandatory part of the update.


So as far as I can see that leaves the four folders I listed above. Hang on, let me have a quick look in the hidden .EXE folder as well…

So all the files, and folders in “C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.25.9.0_x64__8wekyb3d8bbwe” have the same datestamp, 07/05/2022, so nothing changed there either.

So it has to be those four folders, or an online component.

Considering all the server issues people have been reporting since the middle of last month that still haven’t been addressed beyond “investigating”, that’s certainly a possibility.

I’ve said many times over the past year or more that I’m convinced that many of the crash issues we have are due to a combination of server issues and insufficient error handling routines in the client. Server either fails to return something or returns something corrupted / improperly formatted, and the code ■■■■■ the bed because it doesn’t know what to do with the reply it got, but tries to execute it anyway.


I too had my first CTD in a very long time following this last WU. It occurred while zooming on world map. I know, doesn’t make sense.

1 Like

I’m also in this boat.

I’ve been rather lucky since launch really. Minimal CTD’s…quite sporadic. Usually it was pretty easy for me to pinpoint the culprit (New addon, new overlay, etc…). The last couple of months especially have been a complete joy…absolutely ROCK stable for me.

Since Tuesday’s update…I’ve not successfully completed any of the 4 flights I’ve attempted. I’ve either crashed prior to getting airborne while setting up my aircraft, or I’ve crashed at some point in flight. Absolutely NOTHING has changed on my end other than updating to the latest Nvidia driver (which I have now since reverted). I’m extremely conservative and vigilant in terms of addons. I do fly in VR, but again nothing has changed from that perspective. I’m positively sure of it.

It’s very frustrating to have no idea where to start looking for a solution.

I had read yesterday that resetting the Microsoft .NET Framework had helped many people solve some issues within the sim, so I tried that this morning and will test tonight. Hopefully between that, and my GPU driver revert, something will stick. We’ll see.

1 Like

Two more today. They definitely changed something in this WU.

1 Like

About 80-90% into an hour and 11 minute bush flight leg… CTD. Disappointing to have that happen on such a beautiful VR flight in the Andes.

Theres a hotfix beta out now:

I haven’t had CTDs yet but has anyone tried deleting rolling cache?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.