ILS Approach Waypoint runaround

So did anybody worked out a work around? Placing waypoint somewhere around airport probably is our best chance I guess.

Yeah when it happens I just delete the flightplan, assign direct to the airport and then add a waypoint, usually the one of the approach entry point and then load the approach, it works but it is ugly. Not so simple with airliners though and the CDU, those are even uglier to do.

2 Likes

If the localizer is messed up and you add your own waypoint, you don’t get your glide slope do you?

You have to delete the flight plan, do a direct to the airport, then set your waypoint a little bit away from the airport then contact ATC ask for clearance to land and pick your runway and then load the approach. It will load the ILS nav and Loc for you since we have no way of getting them in sim.

thanks … much appreciated

If you have experienced this bug please go vote on @AZRedneck33 thread to try and get some attention on it going forward:

3 Likes

Any fix on this? Quite fustrating that when you enter the approach specified by ATC the aircraft will turn 180 deg and you cant delete the “user” waypoint

2 Likes

If I’m flying under a flight plan that doesn’t have a pre-assigned ILS approach, what I do when ATC assigns the approach is manually do a “direct-to” to the assigned waypoint that way I don’t have the issue with the 180-degree turn-around.

Obviously that’s for ILS. For RNAV it’s a different story since the entire approach is GPS based. Unless there is no ILS approaches available, the ATC usually assigns ILS over RNAV. If you want to do RNAV, look up the weather data ahead of the flight (it’s what real pilots do) and anticipate the RNAV approach during the flight planning stage, that way it will already be there when it’s time to transition.

I look up the weather before every flight, problem is the ATC does not follow headwind RW assignments. It appears they just pick one at random so when they do assign you an approach you either have to load the new one or request your original RW and approach from the menu.

The direct to is a workaround yes but airliners you would just load the approach and it should pick up wherever you are on the plan. ATC is assigning approaches way too late and the GPS waypoint following logic for approaches is “always start at the beggining”.

I preconfigure my approach because ATC is useless in MSFS2020.

So if thats the case… is the wind of the destination airport on the sims flight planning correct for approach selection? Like if its showing 270 at 15 knots i will select the approach for the nearest runway bearing?

This works most of the times: after you load or activate the approach, open flight plan and select a leg you like in the approach sequence (for example the leg to the FAF) and press MENU. After that, an option to Delete the Flight Plan choice appears. Now, it sounds crazy, but press the fms knob ONCE, as suggested in the message below Delete Flight Plan. Be careful because you risk a crash to desktop. But if you are lucky you have the option to activate the leg you selected.

Another update and we continue with the same problem.

2 Likes

Yes, I’m very disappointed. Still love the sim but this bug in particular is becoming very annoying.

I started on a cross-USA trip in the Bonanza, and selected the eastern and westernmost airports in the contiguous US. In my second leg I had about a 2 hour segment leaving the east coast and crossing New York. I used live weather so it was night, scattered clouds, a stiff wind, and was flying IFR.

I simply forgot to select an approach, and realized it when ATC gave me my expected approach. If it worked correctly it wouldn’t be a problem, just plug it in and activate.

I was prepared to fly it manually, but in the process of fiddling with it, the game did a full CTD because of a related bug when you click around in the approach options. So a 2+ hour flight ended 20nm from the destination airport with the program just vanishing. Oh I also discovered when that happens, the flight does not get put in the logbook.

I don’t want to be toxic like many here, MSFS has such great potential, but I am very unhappy navigation is in such a state. To me this is much more important than updated scenery. I could care less about a better modeled Japan, make the planes primary systems work. When the flight part of Flight Sim works, then we can ohh and ahh over scenery.

If you read this and agree, I’ll reiterate my request to go get this voted higher in this thread linked below. It’s only got 68 votes right now. Also find and vote on any thread concerning Garmin bugs, as it’s probably a linked issue.

4 Likes

It’s not brilliant, but the workaround here checks out: https://www.youtube.com/watch?v=W1DwRRSjJ_M

Whilst that video focuses on the Garmin, I’ve tried it out in the A320 and it seems to work.

4 Likes

Developers, please fix this!

Everyone, please vote on the aforementioned thread to help get this resolved ASAP.

1 Like

Yes please vote on this issue because with the announcement Garmin fixes are being pushed out to Update 9 (for context, we are waiting on update 4 next week, so that’s well into next year I think?), it would not be amiss to stress this is not a “Garmin” problem. It’s there in the airliner MFD’s as well, so it’s the back end navigation system set up incorrectly.

While I would love an upgraded Garmin experience in the sim and look forward to seeing what they release with update 9, I’d love for them to fix what is already in place as implemented so we can use it in the meantime. It would be quite functional as is if it worked properly, and would probably ease some frustrations.

Does anyone know if this has been reported on Zendesk support as well?

I have. Everyone should to enhance visibility

Can you please explain how to do this in the A320? I can’t seem to get this fix to work.