ILS Approach Waypoint runaround

It’s not brilliant, but the workaround here checks out:

Whilst that video focuses on the Garmin, I’ve tried it out in the A320 and it seems to work.


Developers, please fix this!

Everyone, please vote on the aforementioned thread to help get this resolved ASAP.

1 Like

Yes please vote on this issue because with the announcement Garmin fixes are being pushed out to Update 9 (for context, we are waiting on update 4 next week, so that’s well into next year I think?), it would not be amiss to stress this is not a “Garmin” problem. It’s there in the airliner MFD’s as well, so it’s the back end navigation system set up incorrectly.

While I would love an upgraded Garmin experience in the sim and look forward to seeing what they release with update 9, I’d love for them to fix what is already in place as implemented so we can use it in the meantime. It would be quite functional as is if it worked properly, and would probably ease some frustrations.

Does anyone know if this has been reported on Zendesk support as well?

I have. Everyone should to enhance visibility

Can you please explain how to do this in the A320? I can’t seem to get this fix to work.

It is the error that I hope with more desire that they solve

I don’t know about most people here but I been flying the Microsoft Flight Sim, since I had 7 colors on my computer. I have bought a few planes made by other persons, and they seemed to function normally. I remember when Microsoft said there will never be another Flight Sim program. When this program was announced, all I expected was to see were better graphics, aerodynamics. I had no problem with ILS flying with any of my other planes ever. So why fix, or redesign something that has never been broke? The airplanes should have been 100% functional, before any flying was attempted, and I paid more money to get what I thought a working B 787? When I want to see visuals of cities, I’ll use Google maps. You don’t really have time to sightsee when landing a jumbo jet, and that’s what I bought this thing to fly. Lucky I didn’t buy copies for the rest of the family who have MSFS.

Please continue to vote on the thread linked above please guys.

1 Like

I do this, too, but I will often be assigned a different approach. Then I can’t get a response from ATC when requesting a different approach.

1 Like

I have found a few of those. In that case I just ignore ATC and land anyway. Appears to be a mismatch when trying to select a runway in updated nav data to one that did not exist when the scenery was made.
Example is Tulsa 36R 18L is a new runway with ILS, updated Navblue and Navigraph data you can fly the approach and land but ATC doesn’t know it is there.

If you look at bing maps the pics were taken when the RW was about 90% done. Baltimore Airport has one that is that way as well.

Was this solved with the last update?

Sadly not :frowning:

Was this solved with the last update?

Just tested. No, unfortunately.

Problem still exists and it’s still annoying. They really need to fix it, but I don’t think this is even on their radar.

You can get around this problem, but it does require a few steps

  • Set HDG to current course
  • activate HDG mode
  • Activate approach
  • If that new “ghost” waypoint is added behind, go to your flight plan in the FMS and activate the next leg, fly towards it in HDG mode to intercept it as you would an ILS approach
  • re-enable NAV mode.

It’s pretty quick and easy to get done on the G3000. Takes a lot of fiddling to get it working on the G1000 though. That navigating via virtual knobs can be a bit awkward.

In any case, this bug is getting old and annoying. The GNS530 mod fixes it in the planes that use that unit. I wish the Working Title guys could fix it in their mod as well, as Asobo either don’t know it’s there, don’t thing it’s a problem, or don’t think it’s a high priority.


Yeah at this point at least some acknowledgement would be all I ask for. Say, yes we know and are working on it, it will be part of the Garmin update (although it’s not exclusively a Garmin problem, assuming that covers the nav system.)

This is a fundamental misunderstanding of how IFR works, this is not some minor bug or faux pas, this is a blatant, glaring experience breaking fault in how the system works.

But, at least they put adding trains to the sim on the roadmap, I know how important that was… /sarcasm

I can live with it because I know how to work around it, but it’s still annoying. I don’t expect we’ll see it fixed until the major Garmin / AP fix. And then we’ll have to wonder what new things will be broken.

Although now with them doing 1 update per month and potentially having closed beta testing, with some luck we’ll see fewer of these blatant issues go unaddressed for months.


Downloading update, can it be they fixed this before the Garmin update!

Lets test it out!

1 Like

I too get the u turn. I have tried flying from Boeing Field (KBFI) to Portland (KPDX) on the HELNS Six arrival to the ILS 28 L approach with the REEDI transition. The last fix of the arrival is the Battle Ground VOR (BTG). Then the plane will get to REEDI, then either try to fly to HELNS fix or when it goes to the next fix HPSTR then it loops back to REEDI over and over. I did fly from KHIO to KPDX last night VFR coming into the BTG VOR and then ILS 28L approach with no problem. I am going to try flying from KBFI with manually entering the HELNS Six approval and see if it flies fine. I am thinking there is some bug where the sim thinks the arrival is part of the approach and gets confused as I have done approaches into smaller airports that don’t have an arrival just an approach and have had no problems.

but just now saw the update, so hopefully it will fix the u turn