I'm seeing all airports as uncontrolled after updating to SU5

Yes… I had this issue with Navigraph… even though I removed everything from my community folder… but unfortunately SU5 screwed up my registry to the point I had to do a complete computer wipe… new Windows, new everything. So after downloading the clean fS2020… no issue with missing frequencies

Perhaps you didn’t read my previous posts where I described making an IFR plan, trying to follow it, and not getting directions from ATC after takeoff? This is the reason I made further efforts to resolve it.

1 Like

Content.xml in ContentBackup.xml (%AppData% … ) FIX also my ATC problems (totally silent first).

FIX also a problem with my Garmin (530 and G3X) where the last leg in flight plan was always selected and I could not change it.


Thank you!

1 Like

It’s best to keep bug reports focused on a single topic. The devs can only keep track of/work on one problem at a time. So any off topic bugs reported in a thread will get lost / not seen.

Is this bug I reported what you ran into?

Those using Navigraph Beta Nav-shizzle. Just reinstall this! It fixed these issues for me too.

Installing the Navigraph navdata and toolbar didn’t help my problems at all.

No, the frequency never switched after takeoff and there was no way to receive further instructions. No additional options were given in ATC window except for asking for the next waypoint or changing altitude.

1 Like

I uninstalled Flight sim completely and deleted Flight sim folder in AppData. Then complete re-install (again). No success, all airports are still shown as uncontrolled on world map. How did that mess of an update pass the QA? Didn’t they even test one single IFR flight? I think, we’ll have to wait weeks or months until this will be fixed. The hotfix release notes don’t even mention this issue (not even as known issue).

1 Like

Well, that procedure didn’t resolve the world map for me either, so you’re seeing the same thing I am.

Hotfix didn’t fix the World Map, and in fact it regressed: all navaids and airspaces are gone again, so I’m back to the original bug situation.

Trying resetting the Content.xml again… ok, navaids and airspaces are back, so I can set up an IFR flight. Let’s try one…

Ok, ATC is working but the separate altitude problem still remains, which means anything above a few thousand feet will have problems with ATC. Awesome.

Ah well, no change for this particular bug then.

OK, so I placed NavGraph Panel and Data folders back into Community and ATC/full navigation/flightplanning is now working. Be sure to update the Nav Data folder, mine was empty for some reason.

For Navigraph Users:

Do NOT manually delete the Navigraph folders in Community folder. ALWAYS manipulate the Navigraph folders using only NavCenter app. That’s install, upgrade, remove the AIRAC.

That way, Navigraph will correctly update Content.xml and the sim will correctly load all custom content on next start.

1 Like

That didn’t resolve the part of the issue where all airports show as brown (no published procedures), even after resetting everything, reinstalling MSFS, and reinstalling Navigraph data through the helper app.

Understood. But I see a lot of posts where folks just delete the folders. That will definitely complicate troubleshooting. And there was another recent thread where it did solve an missing ATC.

Thanks! Have you reported the issue to ZenDesk/Asobo as well?

I should emphasize that Asobo’s instructions say to delete your Community folder before updating.

Not me. I’m working okay as a Navigraph user. ATC is functioning for me.

I empty my folder - I copy all the mods (minus NG NavData) to another one on the same physical partition. Then copy them back after a successful vanilla run. Worked so far since last August.

I’m a bit confused; I thought you just said that doesn’t work.

Ah I see – you’re not following the Asobo directions, you’re following the different directions.

Which part?

For NG, add/remove only using NavCenter.

For everything else, manually remove.

Restart sim to rebuild Content.xml.

I also am seeing the brown airports on the World Map. I tried deleting the Content.xml file and restarted the sim. This did not appear to work for me.

Alright, so I did some more testing. For me its all visual, basically ATC works as normal. KLAX shows as magenta untowered on the mini map when flying. However, I still have ATC services at KLAX!!!

I can still file IFR under World Map and view every approach/departure. All Navaids are also showing up. ATC is giving me frequency changes as well. KPHX shows as towered and so do all the normal towered airports in the Los Angeles area.

I have the same issue, everything seems to work fine but in menu all airports showing with brown icon… created content file, cleared community folder… no luck.