IndiaFoxtEcho F35 Lightning

Hi Speed. Saw the A model at a Langley AFB airshow in July, flow by Hill AFB demo pilot. Was the loudest AB I have ever heard plus she did things with that bird that would normally (F-16) be impossible.

Best Regards,

Jack
RL Pilot with 8,000+ in 52,T-33, etc

1 Like

updated and now the set speed doesn’t work for me… in the AP … Anyone else have that problem?

I dunno what the heck has happened to the AB sound. It was fine before the update. Now it just sounds like somebody switched on their BBQ grill…

Can someone tag the developers pleas? Not sure what callsign or pseudo name they are using

anyone else having problems with the landing gear not working (but works using the “G” key) but i have controllers that i want to use them

i do not know how to start a new topic but i will do it this way, i also have not yet seen a post on this bug,
when i want to hover with the F35B i engage the STOVL mode and it transitions succesfully to STOVL but when i want to engage hover it bugs and does not do anything.
i have tried everything, reinstalling, restarting, different times, weights and liveries.
i sadly cannot add a screenshot or video since im a new user
i hope anyone knows a solution.

STOVL mode is only half the battle. You also need to click on the “HOVER” icon on the panoramic display, left of the side view silhouette of the F-35. That will only work if the gross weight of the aircraft is below 40,600 lbs. Hover mode is only available on the F-35B. The A and C models don’t have that capability.

Also to keep in mind: you lift off the ground vertically by pulling the stick back, not by adding power via throttle.

1 Like

Hello, not sure if I did something wrong, or it’s a bug, but yesterday I decided to do a flight in the F-35A. I was cruising at, 36000FT with both AP and AT engaged. I had the speed hold set to hold the speed at mach 0.92 which worked at first, however at some point I noticed my speed had fallen to mach 0.70 even though the AT was still engaged and was in level flight. I then entered a new speed in the speed hold box, and the plane immediately began to accelerate to the new speed. So it almost seemed like the AT fell asleep at some point and stopped trying to hold my speed.
Any ideas on what could cause this?

Also, is there a way to start a flight at the gate but have the already turned on and ready for taxi/takeoff

Thanks.

anyone have experience the problem with afterburner engage on the quadrant throtle thrustmaster? its simply does not work with f 35 .

Hi,
I use the Hotas Warthog trottle and I followed the instructions in the manual and everything works correctly. But in my case the L-AXIS-Z assignment is repeated in the throttle 1 and 2 axis assignment item. This could be a solution to try.

coming soon

3 Likes