Insert MSFS game disc

I know this has been an issue and I have read some of the discussions.
However I’m still stuck wit this issue and honestly it reduces the fun flying MSF2020.
I never had this issue.
I recently switched over to a new PC and unregistered my old PC. The new one has been registered and listed in my Microsoft account.

Any help resolving this problem would be much appreciated.



Just restart the PC and it should be ok


If you have yet to resolve your issues, here is a link to a support article for the matter:


Here’s what I found (that actually worked for me) after trying all of the listed options.

I clicked on start and selected my Windows account and then under related settings I selected manage my account. What I found was several of my PC builds and also my most recent / current.

I deleted the old PC devices from my account (as these were no longer in use and just an artifact in my Microsoft account). I rebooted my PC and it worked like a charm.

Hope this helps anyone else that is experiencing the “please insert disk” anomaly.

Take care and all the best,


Hi Scott,
I have this problem since I have switched to a new PC, rebooting has happed multiple times now.
I have re installed the Xbox app still no success.


Hi Dean,
Thanks for the reply, I’ll give your suggestion a try… thanks for your prompt input. :+1:

Yours Frans

1 Like

Update OS via windows update.
Install gaming services.

Just had a look, just one PC registered.
I have synchronised my account several times.
So far bad luck. the annoying thing is that I don’t have a fixed CD/DVD player in my PC so I have to use my USB external one.
I’m actually getting pretty frustrated and most likely will sell my MSF2020 with the key and part from the Microsoft MSF2020 platform.
I would expect that I you buy something with a genuine key that the buyer has the control, but the real world of MS it seems to completely different.

I also use Xplane 12 with zero issue’s, after restarting my PC, XP12 came up with the question enter serial key, copy paste the key and the new registration took effect. XP12 works like a dream.

If there are any other suggestion regarding insert the MSFS gane disc I’ll try it but have doubts regarding the result.


1 Like

I am saddened to hear that you are still having this issue. As I mentioned I had tried all of the methods provided without success and was forced to think outside the box and discovered the solution I provided that worked for me.

Have you had any success since you replied back to me?

Hi Dean,
Many thanks for your reply.
No solution yet, tried all your suggestions and no luck so far, its getting a more and more frustrating issue, so I have decided to leave it as it is and invest my time in XP12 which give’s me more joy.
It is so silly and complicated how MS handle these things.
If people ask me on recommendations I truly discourage the purchase of MSFS2020, due to many more issues I have had in the past with MSFS2020.
Perhaps I will preform a complete un install and re install, but loosing all my settings while doing that keeps me off doing this.
It just consume 140gb on my drive which is not a big deal so I try to be ZEN and when the time is there a may spend a few hours more on the issue.
Thanks for your assistance and input, I really appreciate that and I’m thankful for that.

1 Like

I have the store purchased Version and I do not like having a disk in the drive or handling it all the time.
I have simply made a ISO file of the MSFS disk and before starting FS I simply open the image in explorer. This way the real disk is not needed and FS starts without any problems.

Your settings will not be lost, they are kept in the cloud and will be restored with a new install, provided you have the same login name.
They are also stored on your PC, and can be copied if you so wish.

This might be an option, funny thing is it has worked in the passed.
My option I make a fresh and new installation and see what happens.


Tnx for the info, I’ll install MSFS fresh.
One question, does it work if I download a version and use the Key I got with the the DVD’s?


I’m not 100% sure on that, you may have use the disc.
When you go to the MSStore library, does it show up there as a purchase?
If it does and it is downloadable, I sure would try.

Thanks for the tip, although I did not have to go through all the steps you mentioned. I first logged in to Microsoft store. I clicked windows start, clicked my account name and saw an account error message, clicked on the error message and the problem was resolved without me doing anything further.


Most certainly welcome!
Glad any part of it was helpful and you are back in the simulated FS2020 skies :+1:

Thanks @Aerojive that did the trick!

I Don’t understand why so many people are saying to uninstall and reinstall the game with an error. Many times you can find a quick solution on Google which saves a lot of time. Also with reinstalling a lot of addons won’t work properly anymore.

I finally came to the point that I quit using MSF2020 period. The CD issue has never came to be resolved!
And now after the Dune update MSF came in al continuous loop of searching for updates.
Time after time it came up with the Dune splash screen and there it stopped.
I have tried all suggestions which have been posted here on the forum and finally my MSF icon has disappeared and get the message that the game can not be found on this computer.
I’m now on Xplane 12 and which works FB.
Thanks for the replies and support, my CD box will be for sale.
Yours, Frans


Hi there!!
I have read this thred and as you maybe understood I have been in the same situation.
Thursday I flied between MYNN and MYAN and all looks fine.
On Friday I should contunue my tour in Caribia to MYAK but as you probably guessed MSFS ask me to insert the game disc.

Well I search on the web and found this thread and maybe something other not so useful stuff. I wrote a note to microsoft.
As I understand this is caused of lack of “Digital Ownership” and that is handled of the XBOX-App (I am running MFSF on a PC) and of some reason when MSFS ask XBOX if I have ownership it not respond or say no.
I goes out on Microsoft Store and check my installation and it seems to be good there. I was owner and it was installed. As a part of the installation it was a “Digital Ownership” that the help function said was handled of the XBox App. Someome in this thread say that it was not nessecary to reinstall all - just the license. But I could not figure oout how to do that. Have anyone done that (reinstall just the Digital Ownership) please tell us step for step how to do that?.
I descided after I read in this thread that almost everything is stored in the cloud to Uninstall and reinstall the MSFS. I began yesterday noon and it was ready this morning. around 18 hrs.
The most imortant things was restored. What I loose was my flight scool (0’% done now 100% done before) and also all Landing Challange (also 0% earlier 10%) but my bushtrips was up to date and also configuration of my Yoke and XBox-controler and my pilot profile and loggbook
All Settings in General Option and Assitance options was gone but it was not a big deal.
Now I hope that this never more will happen but I just chack a little on disk how the digital ownership is handled.
I found out that on C:\XboxGames I found a directory that seems to have with the Digital Ownership to do.
Name was Microsoft Flight Simulator Digital Ownership.
In this a bounle of files can be found with cryptical names (keys) and now I wonder if it is any Idea to backup this folder and that If this happen again just copy it back? I had no idea how it works earlier and do not know if this folder exist during my uninstalled MSFS.
I will be very frustrated if this happen again and If I easily can prevent that I am happy for any advise
Erland from Sweden