Installation fails with error 0x803fb107 and 0x80073d0d

Microsoft Store version of MSFS2020 Premium Deluxe Edition

Following update, I observed that the photogrammetry and ‘handcrafted’ airports were not updated at all. I uninstalled MSFS2020 to conduct a ‘clean’ install in some hope to remediate yet another faulty update that MSFS2020 is becoming conspicuously known for.

Installation hangs with the following error codes:

  • Microsoft flight Simulator: Premium Deluxe Edition - 0x803fb107
  • Microsoft flight Simulator - 0x80073d0d

I have followed all the Zendesk troubleshooting checklist with no change to the outcome.

PC Specs:

Windows 10 Pro (64 bit) (Build: 19044.1503)
Intel Core i7-9700k @3.60 GHz
32.0 GB RAM
nvidia Geforce RTX 3080ti!

Here is a procedure I developed from “fixes” that have been posted here on the forum.
Some of this is a duplicate of things in the Zendesk article.
It may be some help.

Ensure all addons are removed from the Community folder, and any 3rd party plug-ins such as Navigraph etc., are uninstalled.
Remove any overclocks you have set up.
If you have used the Google map replacement, uninstall it using it’s uninstaller.
Ensure any third party antivirus programs (Avast, AVG, etc) are shut down.
Ensure you have an open path through the Window’s firewall.
Ensure all Windows updates are installed.
Make sure the time and zone in your PC settings are correct.
Sign out of the xbox app on your PC, and shut down Xbox app.
Sign out of MS Store App, and shut down same.
Shut down computer.
Unplug all controllers, except mouse and keyboard.
Restart computer.
Open and sign into Xbox app.
Open and sign into MSStore.
Reboot computer again.
Try sim.
Plug in controllers.

Thanks for the reply.

As you say, most of the suggestions are covered by the zendesk solution.

I have uninstalled everything linked to Flightsim, and formatted the hard drive (D:) where MSFS was installed.
My firewall (bitdefender) was completely uninstalled.
All Windows updates are done, time & date is synced and correct.
Signed out of Xbox and MS Store, and closed them both, and reset MS Store.
No controllers installed.
PC rebooted and install reattempted.
Although having to go through such a significantly painful process with every update, this had no change to the outcome.

1 Like

I’m disappointed they weren’t much help!
Another simmer added this post. Read it and see what you think.
If all else fails, the best advice I can give is to go to the support tab at the top of any forum page and enter a Zendesk request.
Best of luck!

Op and all, had something take out system Friday last. So tonight, I am attempting to reinstall MSFS.

  1. I had to remember to login to the Store and Xbox app.
  2. I had initial install error of 0x00000001 - Ran at admin command prompt.
    a. SFC_/Scannow when finished, found errors and fixed them
    b. DISM.exe_/online/Cleanup-image/restore health
  3. That fixed that one. Then got 0x800 something cf
  4. Uninstalled Zone Alarm Firewall and antivirus.
    That now has at least cleared the basic install file to be downloaded.
    Additionally, I made a complete backup of C:/myprofile/apps/local/packages/Microsoft FSxxxxxx folder to a SSD drive I keep on the shelf. I then copied all that back to system, and we will see how that goes. If I have to download and reinstall it takes 6 days to do that, and I am not going to waste that time doing it again. I will report here results. The game should self-repair once initial file is on system.
  5. X-Box start file (whatever it is)-game launcher installed. I clicked on it and game opened, doing 1.90 GB of downloads now. Won’t mess with content manager tonight. So far all is good.

Uninstalled and re-installed all C++ runtime files, but this also had no change either.

Fix Forza Horizon 5 Installation Error Code 0x803FB107 On Xbox App/Microsoft Store Windows 11 & 10 - Bing video

See if that helps. MS71

After following the directions in the video, there is no change.
I am at a complete loss.
Seems that Microsoft Store is a massive barrier to facilitating updates for customers. The extra level of control is nothing more than an obstacle.

1 Like

Try this, find VCRUNTIME140.dll in System32 directory. Move it to desktop. Go to MS site and download C++2015 both 32/64-bit versions. Restart PC. Errors but OS will load.

Install C++2015 and it will build new VC runtime file. Restart PC,
Try again to install game.
As last resort, you could run regedit, and take out any reference to MSFS-2020 and then try to reinstall game again, not sure that would fix your issue.

Agree with your sentiment, this game is a Pain to get to work and install. No other piece of software on this planet, is as convoluted to get/install/make work as this one is. I took the whole MS FS folder and copied to a separate drive on the off chance my PC might crash. Last Friday it did, used my OEM USB Recovery Windows 10 disc to restore to factory. MSFS last thing to get reinstalled, and yet, it again took several hours to figure out and fix errors system reported in that recovery effort. I am old, life is short, this is way more work versus the benefit we receive playing this game.

Thanks for your assistance.

I have completed the steps you detail, but the same issue remains.

Does this link offer any help:

Hi, it seems I have tried all the suggested techniques. I believe it is time for the software engineers at Microsoft to determine and remediate the reason why the MS Store periodically blocks customers from accessing the software they have legally purchased licence to.

1 Like

this is indeed a very weird issue, why are only some users xpereince this??

0x803fb107 and 0x80073d0d both have one common denominator.
They are both caused because your PC cannot read some required files in your system.
There really isn’t much a software engineer can do to fix that.
That could come from actual corrupt files, or just permission issues that prevent your PC from accessing the files.
One way to fix the issue is to google search the error numbers and try some of the “fixes” (there are quite a few).
The other alternative is to go to the Help icon (bottom left of the MS Store screen), and request help from there.
Let us know how you make out!!

1 Like

I’m getting the same error 0x803fb107 trying to install MSFS on a brand new Win 11 Pro install.

All other MS Store applications have updated and installed fine. Now suddenly after a required “Gaming Services” update, this issue has occurred.

Note: The Gaming Services update was required in order to download / install MSFS Premium Deluxe.

I’m not saying GS broke things… but it’s quite suspicious, and has been known to be problematic in the past.

Log out of store.
Shut down MSStore.
reboot PC, start store and try logging back in.

If that doesn’t work try the advice in these two posts.
They are based on Windows 10, but the advice is the same.

1 Like

After two re-boot’s, MSFS finally downloaded & installed without issue… Weird, but I’ll take it!


1 Like

Please refer to this blog which helps me corrected it.

[Microsoft Store安装应用时出现0x80073d0d的解决方法 | 炒饭的小站]

I searched the English resources in Bing and tried the sfc scannow/wsreset/windows update/signout store/reboot/shutdown firewall things — they all failed until I found the Chinese resource above in baidu.

Here is the thing… The target volume you install windows apps into encountered unexpected configuration and became ‘offline’, you have to make it ‘online’ to install windows app again.

Take myself as example, I installed MSFS 2020 in a portable SSD drive D:\ a long time ago. I found my volume D:\ often could not be safely removed due to the occupation of windows store. I had to make the computer sleep and then unplug my SSD. It was so annoying that I had to brutally delete the relevant windows app folder in D:. I reinstalled MSFS in my hard drive E:\ and again I uninstalled MSFS because I was busy and did not want to be distracted by games. Today I want to reinstall MSFS in D:\ (how funny). I stuck at 99% and encountered 0x803fb107 (xbox) and 0x80073d0d (windows store) problem.

I opened PowerShell in administration mode. I used ‘Get-AppxVolume’ to find the label of the offline volume and used ‘Remove-AppxVolume [offline volume label]’ to remove it. Finally I fixed the problem.


Finaly a fix that worked. :smiley: thx so much dude

I can confirm this fixed my issue right away, no need for restarts, logouts, etc. I removed an offline AppxVolume that I had, clicked download again in the store, and worked perfectly.