Installation stuck at file "asobo-aircraft-c172sp-as1000-0.1.82.fspatch"

INSTALLATION MANAGER is stuck at decompressing file “asobo-aircraft-c172sp-as1000-0.1.82.fspatch” (and .83 to .91). It is repeatedly downloading and decompressing the same group of files.

My first install attempt reached 40% Complete before getting to the above file(s). After rebooting and restarting the download, these file(s) are now the first, and I cannot get past 0% Complete.

Another reboot and installation is still at same files.

Nothing in my Community folder. All of my peripherals are unplugged. Cessna 152 with default livery in my hangar.

So, after nearly a year of using the sim, it looks as if I need to submit my first Zendesk trouble ticket.

EDIT: I tried using a VPN, with servers in Montreal, Miami, and Charlotte. No difference in behavior.

EDIT: Zendesk Request #112028

EDIT: I deleted all files and folders containing c172sp_as1000 and retried. No difference in behavior.

Yes, I am having the same issue. I am also stuck at decompressing file “asobo-aircraft-c172sp-as1000-0.1.82.fspatch” (and .83 to .91). Repeatedly downloading and decompressing the same group of files. Frustrating!

Same here, stuck on decompressing asobo-flight-tutorials-arrival-0.1.8.fspackage
Here we go again.
UPD. I tried to unzip manually this file and got CRC error on some wav file.
I deleted all *.fspatch, then started sim again, files was redownloaded but again stuck on this file and again CRC error. ■■■?
UPD. I repeat that process (delete all *.fspatch → start update → stuck → kill process → repeat) several times and fifth one was successful. Nice soft, Asobo!

Stranded all night on the 208b grand caravan

I deleted, in OneStore all the files of the aircraft in question, closed the download window, by the X, at the top left; Relaunch MSFS via the Store, and the download is restarted.
If it helps …

So, my update was stuck on the (asobo-aircraft-c172sp-as1000-0.1.82.fspatch). I deleted that aircraft in Onestore file and it continued to download. However, now its stuck the same way on the Caravan 208 aircraft…Deleted that aircraft and download continued. Keeping fingers crossed but may have to delete other aircraft if it gets stuck on them. My question is will MSFS automatically reinstall those deleted aircraft when updating??? Anyone know?

Check if your disc isn’t full

Disk is not full, plenty of space.

Ok answering my own question here. It apparels that the aircraft I deleted were reinstalled when updating. Looks like the update just gets hung up on certain aircraft. Deleting the aircraft in question and attempting to update again seems to fix the issue of stalled progress

I was also stuck (possibly for 30 minutes before I noticed) on the Caravan files. I hit Pause and closed the Sim Installer.

Restarted - it wouldn’t connect. Hit Pause again and exited the Sim Installer.

Started the sim again, it finished after another hour of slow but steady downloads.

This has happened consistently to me since SU4 - I find that the Installer has enough “logic” built into it that it’s trying at first launch to “decompress” on the fly while downloading more files - my guess it’s an attempt to be efficient and maximize the number of client connections while reducing idle time during download. After it senses a disconnect for whatever reason, it reverts to sequential action where it downloads, downloads, downloads until all parts of the file are complete - and only then does it do an integrity check and decompress if it passes.

The key, in my opinion, is to Pause and cleanly disconnect/exit.

Mind you I was doing this at 1400H ET several hours after the update was released into the wild. So I was in the middle of “Rush Hour” for lack of a better term. It was slow, but steady until I got into the infinite looping. And it remained slow and steady after I troubleshooted the loop.

I am now many hours into this download / decompress / download / decompress troubleshooting session. I’ve lost count of the iterations, but it’s likely more than 30-ish times I’ve attempted it today.

I spent about 6 hours yesterday and, so far, about 4 hours today. I don’t mind the hours so much, but it’s the lack of any real progress that’s getting to me.

I am still stuck at the same set of files (topic title) as when I started this process, even though I have repeatedly removed files from OneStore, removed c172sp folders from wherever I find them, performed the various Zendesk-recommended (in the auto-response email) steps and checks on my PC, and even though I have more than 230GBytes of SSD space.

EDIT: I decided to Uninstall / Reinstall MSFS 2020.

Finally after deleting all the aircraft that install got stuck on, I finally completed the install. Had to delete around 6 aircraft for it to be able to pick up installing properly. Good luck!

Same issue as well decompressing and nothing downloading. Raised with Zen desk. Sigh

This is not an issue with deleting folders or files. After exhausting all suggestions found online, I decided to just bite the bullet, uninstall, and re-install. Now, I am facing the same issue, but have 100gb or so more to download. This is a giant dumpster fire. Would be pretty neat if Microsoft provided some kind of response to this issue ASAP.

I too uninstalled / reinstalled the whole thing (standard/premium/deluxe) - successfully.

From start to finish it took exactly 3 hours, including USA World Update and my planes and airports.

My settings and profiles are completely intact and as I left them.

Now I am sitting in the c152 at my home airport in NC, USA. Seems fine.

Time well spent. I wish I did it this morning.

This was MY Solution.

I’m having exact same issue as OP. The asobo-flight-tutorials-arrival package gets stuck because it has two CRC fails. Running a separate scan on the archive file after download indicates:

CRC failed in ‘asobo-fligh-Tutorials-arrival\ Missions\Asobo\ Tutorials\VFRNavigation\Anival\sound\de-DE\Avrival_Dlg_lntegrate TrafficPattem8_MALE.wav’. File is broken.

CRC failed in ‘asobo-fligh-Tutorials-arrival\ Missions\Asobo\ Tutorials\VFRNavigation\Anival\sound\ru-RU\Anival_Dlg_lntegrate TrafficPattem8.wav’. File is broken.


So then I tried uninstalling the whole game and started a fresh install only to find that other files are now also failing with exact same CRC checks (across different files now though) - the whole installer just hangs. Terrible! Come on MS/Asobo … this type of error handling is not good enough.

I had the same problem, I just paused it, closed flightsim, and restarted it, happened about 3 times… but eventually got it installed over a time period of 2 days, it was so frustrating!

I get the same problem, except it never says Please Wait. When the installer gets to asobo-aircraft-baron-g58-livery-01.01.1.6.fspatch, the download speed starts dropping until it reaches 0.01 Mbits/s and then loops. I have run through checklists, uninstalled and reinstalled multiple times, done dozens of Google searches, watched several YouTube videos, and nothing works. This is really bad.