Issue: New Alpha Flight Controls XPC, Honeycomb XBOX Hub, Bravo Throttle Quadrant

Trying out the Xbox today for the first time, I found:

Devices: Xbox Series X, Alpha, Bravo, Thrustmaster pedals

  • If I plugged the TM pedals into the hub, the Bravo fails to work at all, except for the Throttle 1 Axis ( far left)
  • Default bindings seem to have Throttle 1 Decrease and Throttle1 Axis bound. Unbound a re-bound all throttle controls, and the sim works.
  • Controls Options page isn’t picking up the throttle value in the UI, but the sim seems to work correctly.
  • No lights for me either on th Bravo.

Thanks for the TM HOTAS tip. I’ll try that for rudder controls.

1 Like

Was your Bravo plugged into the Alpha via the Honeycomb hub, or directly into the Xbox X? Mine is plugged into the Alpha via the Honeycomb hub, adding more axes and buttons to the Alpha. This screenshot shows how it all appears as one device for me. Note the picture on the right hand side is all of the devices as a unified device (despite the fact that I don’t have the Charlie rudder pedals.)

1 Like

So I used the bravo last week. This weeks Canada update did something. So now Bravo and my rudders are not showing up in control options

Mine is working now. Bravo doesn’t show up in the controls options. But the white bar is moving when I move the levers

I’ve connected the bravo both ways as you mentioned, and I get ZERO connection from the bravo quadrant. I move every single lever, touch every single switch/button, and nothing.

So my hotas one came in and I connected the rudder pedals and it worked. I’ve got everything working except my bravo quadrant, still get no connectivity

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

My experience is much the same as most of the above. A non working Bravo I’ve changed cables with umpteen combinations and nada. I’ve sent emails 5 in total to honeycomb support with no response. Thinking the quadrant was faulty I downloaded a copy of x plane 12 demo to check and see if the bravo was seen by my studio Mac, low and behold all buttons ,knobs,leavers, even trim wheel worked which to me points to the hub and or xbox x/s. I hope this isof use to someone

1 Like

Do you have the Thrust Master rudder via Hotas plugged into Honeycomb hub or directly into the Xbox usb port?

I have tried both ways with no luck but finding things that do not work one time work the next. Wonders never cease.

I have the HOTAS plugged into a 4-port hub which plugs into one USB port on the Xbox. The Thrustmaster pedals plug into the HOTAS.

Also plugged into the 4-port hub are the Honeycomb Alpha and a memory stick for image & video captures. The second USB port on the Xbox has a Logitech unifying receiver that supports a mouse and keyboard.

The Alpha yoke has the Honeycomb hub attached, into which is plugged the Bravo throttle quadrant.


Thank you for the picture and before seeing it I tried that combination and the rudder pedals do work now by going directly to the xbox.
So far the XPC yoke is fine and all the switches there work.
The Bravo, it works but still few bugs which most have already experienced and documented.
My switches do work (but no lights) but so far only work with the default settings) tried to map them differently with no luck. But am flying and hoping for more updates to get lights and other bugs working.
On a side note Honeycomb is no help at all, no reply to several emails, and before figuring it out also no reply for a RMA to ship back. Silence is not good for a company trying to promote a new XPC product line.


When I first installed the Bravo on the Xbox Hub, I thought the same. No lights anywhere. No indication it was connected or working.

But although the Bravo Lights still do not work (yet) it WAS connected and I found the throttle DID work. I had to do a lot of button mapping because the default out-of-the-box configuration did not work. But now that I have mapped all the buttons, I am happy.

1 Like

Hi I would welcome some support on how you set up the bravo and mapped the control - I’m on X Box X and connected via the XBox hub - alpha working fine but can only use one throttle on the bravo nothing else works - I can’t work out how to create a new profile and map the bravo controls - so frustrated that after waiting a year to use it Honeycomb ship the hub and and it’s this complex to set up - their sales/after sales are the worst I’ve ever experienced no support or communication at all

I sometimes need to restart my Xbox and MSFS in order for peripherals to properly be detected by MSFS.
Make sure you connected the bravo and the hub as shown in some further post.

Do you have the same issue if you follow the OP’s steps to reproduce it?

Connected Bravo to Hub then Hub to XPC then XPC to XBOX.

Provide extra information to complete the original description of the issue:

The XPC seems to work but the Bravo is making no inputs in the control options menu or in the game itself
If relevant, provide additional screenshots/video:

Anybody found out ■■■ is happning with this? Getting exact same issue only 1 throttle working zero buttons are letting me map them

It took me hours to sort this - it will try your patience and you have my sympathy. The hub and Bravo do work but it’s not straightforward and it’s not intuitive at all.

Out of the box the bravo can appear not be connected at all. There are no lights and moving throttles doesn’t seem to work. I tried re connecting several times (I almost gave up thinking the hub was faulty) when I realised that one throttle lever was working. Also the Bravo doesn’t always connect - it can be fine then on next start up nothing - it’s very hit and miss. You just need to restart again and it will work eventually!

Once you know that it’s definitely connected as one lever works (there are no lights - these do not yet work on XBox as an update is needed first which is yet to happen) mapping can begin. Trying to work out the numbers for the various throttles and buttons is trial and error. At some point I may have a go at labelling them but on XBox I found that nothing matched any numbered diagram I could find for PC and most You Tube videos were for set up on a PC.

The good news is once connected I found the gear lever and most of the Autopilot buttons corresponded to the aircraft (a320 and Cirrus) I fly most often.

I’d recommend:

  1. Keep trying to get a connection till you find one of the throttle (mine was the left middle lever) on the default airbus. Go into a flight and move the throttle

  2. Once connected use trial and error to map the other throttle levers and flap controls - you can save this as a new profile don’t delete the original profile rename when prompted.

Don’t expect any lights on the Bravo to illuminate they may flash on and off briefly when connecting.

This isn’t what we expect from a plug and play device it’s frustrating and long winded but it does work (Mainly) - I don’t think you’ll find any support direct from Honeycomb there customer service is largely absent sadly. Hang in there!

1 Like

They released a flight guide that shows the button mapping for the alpha xpc and the bravo here: Alpha XPC Flight Guide – Honeycomb Aeronautical

1 Like

Excellent! Good find​:+1::love_you_gesture:

Thank you so much great find!