Issue: New Alpha Flight Controls XPC, Honeycomb XBOX Hub, Bravo Throttle Quadrant

Now all we need are the lights to work!!

You probably already have checked it out…but my limited understanding is if a key is bound to the same action as another key…they both will not work. you have to find and eliminate the one you dont want and delete it. Hope this helps

Yes thanks - discovered that during my many experiments! :wink: good point for others trying though

Hi all, I too have been playing with the Honeycomb Alpha, Bravo and some Thrustmaster T.Flight pedals on my Xbox X.

I found that if I connect the pedals to the Hub the Bravo doesn’t work at all… but I can still get the pedals and Bravo to work if I plug the pedals in via the Thrustmaster HOTAS one joystick… as long as I remove the left and right brakes from the Honeycomb profile!

I then changed the levers on the Bravo to reflect a single engine GA: throttle, prop, mixture.

Mapping buttons often includes ‘spurious’ inputs. I discovered these get included if any of the switches are in the on position: including the lights, magnetos or Bravo panel lights. Occasionally the Bravo levers get added as inputs too: cancel, move them, then try again!

Finally a question if I may. I suspect my Alpha unit is a bit broken: the yoke shaft has no play in the horizontal axis (ie if I try to push it to the left or right) but moves by a couple of millimetres up and down. Do others have this?

To be clear, it’s not the unit as a whole wobbling, it’s the metal shaft as it enters the body with the honeycomb logo above it. Thanks in advance!

If I load the default config for my Honeycomb Bravo Throttle Quadrant, I have essentially Complex Twin controls that work. If I copy that profile to a new one and call it Complex single, and then delete throttle 2, throttle 1 axis no longer functions. This is a repeatable issue. Current version is 1.29.28.0.
This issue arose some updates ago and I’ve been hoping that latter updates fixes the issue. I did have multiple configurations for many aircraft types that all worked.
The fact that the default config works perfectly would suggest it’s not hardware related.
If I create a throttle profile from scratch, the axes are not recognised either. The buttons are though.
I have Windows 10 V 21H2 build 19044.2251 and going into the control panel and testing the axes work as expected.
I have contacted the vendor of the Honeycomb and the manufacturer, neither have responded.
I used @rmags video to set up multiple profiles 18 months ago and all worked until a recent update.
I have also tried to make a profile from scratch but none of the axis bars move, they are all stay at 100%. The default profile always works though.
I’ve also tried using Throttle Axis", Not “Throttle 1 Axis”. Doesn’t work. Looks like I’ll be flying a twin for a while!
UPDATE… I did what TJTurner said and loaded a plane and they worked. When I went back to the configuration in controls, the bars all moved. Defo a glitch!

Why does my auto pilot panel on bravo work for one airliner but not the next? I dont get it😑

Irks me too, but that depends on the makers of the aircraft. E.g., I love the CJ-4, but I am forced to use dashboard buttons with a mouse for many autopilot functions since the authors did not employ standard sim command syntax.

Hey guys. Flight Sim noob here. I have the Xbox X and I am considering purchasing the Honeycomb Alpha and Bravo along with the TFPR pedals. Has using the button mapping provided by Honeycomb solved most of the issues with the throttles? And by connecting the HOTAS joystick does that enable the pedals to work correctly now? Also, I have seen posts where people talk about using a keyboard and mouse. I was wondering what the purpose of that is with the Xbox. Thanks for the help/advice.

I got the honeycomp alpha xpc for sieries x and also bought the xox hub and the honeycomp bravo throttle.
If i plug in the alpha xpc i works as soon i plug in the bravo via the hub the alpha xpc just turns off all the light go out and its dead. When i unplug the bravo from the hub ore the hup from the alpha xpc it turn on again after a few sec.
Same happen if i look in controls section of the sim. Alpha only shows as soon the bravo gets connect the alpha is not recognised. ??? No plan whats causing it but its to much money invested to not work.

Anybody on xbox while using alpha and bravo paused the game? When you unpause it the plane shuts down mid flight anybody had anything similar ?

Do you have the same issue if you follow the OP’s steps to reproduce it?

No but have a similar issue

Provide extra information to complete the original description of the issue:

My throttle quadrant is recognised by the Xbox however if I configure the throttle to a two engine airlines throttle 2 keeps resetting to 0% thrust. Anyone else had this issue?

If relevant, provide additional screenshots/video:

Does it go to 0% when the other one goes to full power? If so, maybe you need to reverse the axis in the controls.

Just adding my experience here from last night. Had the same issues as most here, Alpha XPC worked fine, Bravo didn’t respond.

I tried what others suggested and just kept booting into the game, trying all buttons/axis in flight, turning off the xbox but it didn’t really work. I was then experimenting with turning off the controller pad, creating a new empty profile for both the pad and the XPC, launching into the game via the yoke with controller turned off (to try and remove conflicting assignments as a cause) but that didn’t really work either.

Lastly, and here is the interesting part, I noticed the little usb cable that came with the hub looked a little dirty or corroded. I dug out a different usb-c to usb-c cable and while in the game menu switched the cable from the Alpha XPC to the hub.

The after plugging in the new cable the red backlight on the Alpha XPC flicked off and on, first time I’d seen anything like that happen. From this point the Bravo worked.

Sorry for the long windedness but I included all my troubleshooting steps in case they had an effect. It could have been simply disconnecting and reconnecting the supplied cable in the menu that would have fixed it, but it could also have been the new cable or another step I took.

Like many of you I think this is a bug and you have to find a way to somehow jolt the simulator out of it.

Hopefully the above helps anyone that finds themselves struggling for hours trying things from this thread like I did.