Joystick won‘t react when pressing the right mouse button in cockpitview since sim update 5

I have what I think is the same issue.

For me though it doesn’t involve the mouse.

On my Thrustmaster Warthog, I’m using the trigger as brakes. If I hold the button, the brakes work as expected. However, if I hold that brake button, I can’t press any other button on my joystick. That includes buttons to pan the view. As soon as you hold 1 button, it appears to block all other input. For things like holding the brakes, there are very good reasons for having to send 2 inputs from a single device at the same time.

2 Likes

Is there some solution to this bug i missed except using the middle mouse button?
It still extremely annoying but no one talks about it anymore for some reason.

I have the have the Thrustmaster T16000 FCS w/Throttle. For around a month I’ve been going nuts trying to get my hat to look left, right, etc. in the cockpit BUT no joy!!! It works fine when outside the aircraft. At the same time all this happened, I lost the ability to ‘Zoom’ with my mouse wheel. I’ve been on the phone w/Thrustmaster, downloaded updates, calibration is fine. Problem seems to be the game or settings. Doesn’t matter whether in Legacy or not, same issue either way. If it’s settings then I need some help. If it’s the game then we all need some help.
PLEASE HELP
My Dad flew for the Air Force, I was Air Crew in the Navy and had a private ticket. To expensive to keep going so this game filled the spot. I’ve switched to the business 400 speed d/l from Spectrum and just waiting for Costco to stock up again with the Xbox series X and I’ll hook it up to my TV.
But… this controller thing is sapping all the joy out of the wait !!!

I’m thinking Microsoft doesn’t monitor this thread, haven’t seen them respond with any helpful suggestions.

No they don’t.
You need to open a ticket with Zendesk (see top right of forum for link)

Source https://forums.flightsimulator.com/t/bug-logged-freelook-with-mouse-causes-controls-to-freeze-after-su5/426349/144

Same issue for me. I can work with the “middle button” solution, although that’s not great as the middle button on my mouse (like most I guess) is also the scroll wheel. For me its only been an issue since 1.19.9.0.

I have the same issue. If I hold the right mouse button to manipulate the eyepoint I lose all controllers. I have Saitek X45, Rudders and Throttletek G-Throttles. Nothing responds when the button is depressed.

I have opened a ticked, but it is immediately flagged as “SOLVED” which it is clearly not!

Same issue here, using a TCA Sidestick. My dad who uses a Saitek X52 however don’t have this issue at all weirdly (nor the disappearing mouse cursor/setting it to the top left corner when panning view). could it maybe be a hardware dependant issue?

All this and now I log on to a message in the sim that I have no internet connection. I log off and back on to the same message. So I check and I am connected w/very good speed over 400.
The latest updates have added more glitches than updates IMHO.
2021-10-07T04:00:00Z

If I’m in the wrong place please let me know but it seems nothing is being done to correct these issues. The game / sim is so hard to use now that the joy of practicing navigation or approaches is turning to anger in that every time I log on, nothing is fixed and more is broken. Can someone with clout speak to what M/S is doing???
Please respond to the frustration I’m having

Hey there, is any workaround known?

I am re-training myself (after 20 years) to use the scroll wheel button to manipulate views.
This should be easier as the scroll wheel zooms the view.
I just need a workaround so that momentary press/hold operates move eyepoint, instead of toggle move eyepoint.

Only 40 votes. I guess nobody looks around and and hand flies the aircraft at the same time or everyone just uses toggle look around. What a shame.This will never be fixed again.

You are wrong :wink:
Latest bug-logged topics in Bugs & Issues - Microsoft Flight Simulator Forums[BUG LOGGED] Freelook with mouse causes controls to freeze after SU5 - Bugs & Issues / Miscellaneous - Microsoft Flight Simulator Forums

https://forums.flightsimulator.com/t/cannot-steer-aircraft-when-using-mouselook-right-click/426665/2

2 Likes

Yes this has been an issue since SU5 and I hoped that SU6 would fix it. ZD tickets from me too…

1 Like

Another issue is trying to bind right mouse button AND scrolling up/down for zoom (to prevent the accidental zoom when changing an altitude or frequency for example in legacy mode). It works, but then prevents only right mouse button for panning. This worked from Nov 2020 until SU5. I hope they address that too!

By the way, the OP issue only affects the aircraft in the cockpit now. SU5 affected both inside and outside the aircraft (IIRC).

The middle mouse button ‘workaround’ is much more difficult to push.

1 Like

I asked this question on the Q&A today (November 17 before SU7) they said to monitor that it ‘‘should’’ have been addressed in SU7 if not they will take a look at it if prominent!

Good news is that atleast they seem to hopefully be aware of this now.

they are aware but seems like they forget about it :smiley: