Jumping Throttles

I am having a problem with my Saitek thrust levers which developed after one of the earlier updates. As an example, in the A320neo with throttles in full reverse, everything is fine but as soon as I move the throttles forward to the zero thrust position they take on a mind of their and start leaping forwards and backwards, not together, but in some random fashion. If I advance the throttles a little everything becomes tranquil and they operate as the should but at that point the aircraft will move forward unless I hold it on the brakes. The problem in present in all of the aircraft. I have tried every way in the calibration section to solve this but I can’t. Any help would be much appreciated.

is it also jumping around in the calibration window of windows? if so, it most likely is dirty potentiometers. In that case spray some wd40 both on top and bottom part of the levers, move them around a few times and let it drip for 30-60 minutes

This really isn’t an MSFS issue, so it probably shouldn’t be in the bugs and issues section.
Some moderators are pretty fussy about that.
You should move it to the “Self Service” “Peripherals” section.
We can probably get you some advice there.

I should add that the throttles are behaving perfectly well in both P3D and DCS so yes, I think this is an MSFS issue, the problem started after an earlier update.

It is hard to do a back and forth conversation in this section of the forum, as posts are often closed by the moderators if they don’t meet the rules.

Here is a quote from the forum rules (found on the index page next to where you probably clicked to enter this section).
" This section is dedicated to bugs & issues for the core sim (not mods or 3rd party content) – Utilize the voting system and only post if you do not see your bug listed. Please post one bug per topic and don’t forget to report bugs officially to Zendesk."

Your throttles are third party content, so if this post gets closed, well, you were warned.

Behaving well in other sims doesn’t mean they will do so in MSFS.
MSFS is very fussy with all controllers.
This is a well known fact.
I have the throttles, as do lots of others, and you wont see any posts here on this, so it isn’t a throttle problem. If it was, there would be lots of posts in here.

Here are some things to start with:

These are the first steps to take.
With the sim running, if you are on the start up screen, from the top heading, select “Options”, or if you are already in the sim, press “ESC” on the keyboard.

  • Under “General”
    Set “Flight Model” to “Modern”, not “Legacy”.
  • Under “Assists”
    Set all “Piloting” assists to “Off”
  • When you are in the sim, from the “winged” sim icon, Open AI Control (icon to the right of the yoke
    icon), and ensure that “Control Aircraft” is “Off” (button placed to the left).
  • Next, and quite important, is to add deadzones to each axis for all your controllers. - including your throttle. Approximately 5% should be enough, but there have been instances where significantly more was needed.

Do not assume, even if you know how you had these already set, ensure these are this way now.
The last few updates did change some user settings.

When you get all this done, (the above need to be anyway if more troubleshooting is required) and if the issue is still there, let us know.

Hi,
I’m suffering from a similar issue. Up till this afternoon, my throttles were working properly. Then, when I started my afternoon flight in the Bonanza, the throttle started moving all over the place.
Since then, the throttles are all firmly at the full throttle position.
I’ve tried a lot of trouble shooting and there is no evidence of any spikes and when I transfer the throttle to another lever on my throttle quadrant, the same thing happens.
Currently I’m flying GA aircraft, but I just tried the A320 and the result was the same, i.e. 100% with the thrust levers at idle.
I have FSUIPC7 and using their calibrations produces the same result.
I also have checked on my other flight sim program FS9 and there’s no issues.
So, currently MSFS is unusable which is very disappointing as I think that it’s fantastic (apart from the throttle issue).
Do you think that I should re-install the program?

Have you update any mods, or added anything to your community folder recently?

I’ve not updated any mods recently and the only files in my Community folder are some repaints for some aircraft, some scenery, Navigraph navdata and working title G1000.
I use the MSFS Addon Linker to control the number of files in the Community folder so that at any given time, I’m using the files that I actually need (scenery, mods to aircraft, etc.)
I realised since my previous post that the other engine controls (mixture, etc.) that are also controlled by my throttle quadrant are working fine - it’s only the throttle that’s giving me the problem.

I would empty your community folder, and give it a try.
(Just rename the folder - the sim will make a new Community folder if it doesn’t see one there)

Also:
In FSUIPC, there is a check box to help with spiking, place a check in the “Filter” box.

Hi,
I restarted MSFS disconnecting my CH throttle quadrant before starting MSFS. I’m pleased to say that it looks OK so far.

Many thanks for your help.

Hopefully, I won’t be back!

1 Like

Don’t be concerned about posting here,
This is just one huge learning experience.

There are always good folks here willing to help!

Hi,

The problems still there intermittently. The throttle and best twitches and at worst it just moves anywhere.

I even disconnected my throttle quadrant and I found that the throttle would move to about 50% by itself. When I moved the throttle using the mouse to move it to 100%, when I let go, it moved back to the 50% position. I then moved the throttle to idle and again it moved to the 50% position.

I guess I’m stuck as I have no idea what to do except to reinstall MSFS.

That most likely won’t help, as most settings are kept in the cloud and restored when you re-install

You should look in settings and see if you have any duplicate command settings that may be throttle related.

Yesterday, I disconnected my throttle quadrant so I only had my contr

Sorry about the last post - I started to write something and then I realised that I hadn’t done the check as had been asked of me.
All I wanted to say was that I had disconnected my throttle quadrant so I was using a logitech controller to increase/decrease the throttle. I had also cleaned out my community folder. I then made a flight with the Caravan and although I completed the flight, with the throttle at a low setting, I still had this random movement of the throttle to about 50%. During the flight, with the throttle moved forward it wasn’t a problem. On approaach and taxy, it was a major head ache.
After the flight, I then did a check with the controller also disconnected and the same thing occurred.
I guess the thing that puzzles me is that I had no issues for about the first 50 hours of flying but it occurred after then and I’m still trying to fault find with no success.

It sounds like something is interfering with the commands.
That’s why it could be a conflict with literally anything in your community folder.
Emptying that and trying was my first thought, as this is quite common with mods (even sceneries and liveries can cause it, not long other mods - though they are the prime culprit)

If that didn’t solve the issue, it could be the throttle was not assigned to an axis, but was using the keyboard commands.

Hi,
The mystery deepens.
In the Controls, I removed all the controls for the throttle (keyboard, throttle quadrant and controller) so when I entered the cockpit and tried to move it with any if these means, it didn’t react. Then as if by magic the throttle moved again by itself to the 50% position. I moved it back using the mouse and then 20 seconds later it moved again.
I then ran FSUPIC7 and I could move the throttle OK again. And then it moved by itself again.
As I mentioned in my last message, there is nothing in my Community folder.
So I don’t know what to do next.
Any help would be gratefully appreciated.
As I mentioned earlier I flew for 50 hours and had no issues.
I can record a video if it helps.
Any suggestions will be appreciated.
Best regards,
Peter

Plug in your controllers and unplug your keyboard when you can.
Could this be a stuck key in the keyboard?

Hi,
I unplugged the keyboard and kept the controller unplugged.
The throttle moved straight away.
I also noted that the yoke was not totally still as it seemed to be in some kind of “tension” - like it wants to move but can’t.
Best regards,
Peter

1 Like