Just Flight Hawk T.1

Just wanted to share a nice guide to the Hawk T1/A done by Chuck:

Note: This is a guide for the old Hawk T1/A DCS mod, but it applicable to the Justflight nevertheless (it is the same plane after all). It provide some additional information w.r.t. the Justflight documentation.

4 Likes

And the aircrew manual can be found here:

You have to scroll down a bit, but there is a manual in four parts and a checklist document (reference cards). These documents probably contain a lot more than you ever wanted to know :smiley:

2 Likes

Yes! The L-39 was one of my favorite aircraft to fly and I missed it dearly. The MB-339 was a good substitute for it and is a great aircraft in its own right, but the Hawk really hits the spot with stellar modeling, sound and is just plain fun to fly!

Anyone with a soft spot for fast jets (or even a mild interest) should consider the Hawk. You will not be disappointed.

2 Likes

Was at RAF Valley today as it’s my local airbase and Reds 2 and 3 turned up :raised_hands: they dropped one jet off and left together in Red 2








17 Likes

Has anyone had any trouble loading up a flight with the Hawk? Had no problems when I first got it, but since the other day I can’t load into a flight. The blue bar goes all the way to the right and just hangs. The info text keeps changing at the bottom of the screen so the sim hasn’t crashed or anything, but because it hangs like this, the only option I have is to force close the sim.

There’s a large number of folk reporting the blue bar hanging issue, though it seems unrelated to mods as its effecting people the same even after fresh installs and clearing cache and community folder and trying with default planes. There’s a few different topics on it, I’m not sure which is most active but I think it’s this one

1 Like

Fair enough, I’ll have a read through that thread. It just seems strange that it only happens when I select the Hawk. It happens at different airports too.

Since Su5 I have had problems with the blue bar hanging about 99% of the way but it happens with any plane.
The common factor for me is if I am trying to spawn at an addon airport, either 3rd party direct download or from marketplace.

For example I have the orbx London City addon from marketplace, I can fly over it or land at it but I cannot start from there.

Same since I recently downloaded the Duxford 3rd party addon from flightsim.to.
Can’t start from there anymore it just hangs.

No issue starting at Duxford for me using the flightsim.to version, hawk or otherwise… have you tried deleting the folder fully and re-installing?

@musefan12345 I haven’t seen any problems with using the hawk and hanging at loading, so I don’t think it’s likely to be related to the Hawk specifically… could be a conflict it has with some other addon? Perhaps try leaving only your Hawk installed in the community folder to help rule out any conflicts?

1 Like

Yeah I’ve tried emptying my community folder (apart from the Hawk of course) and having the same issue. Sometimes it happens with other aircraft (rarely though), but at the moment, it always happens with the Hawk. Haven’t been able to fly it at all in the last week or so. I’ve tried loading into different airports too, both default and addon.

From the thread @RadicalCavy linked looks like there are a few potential workarounds to try… seems most successful is setting graphics options to low and then changing back to high once it’s loaded.

Hope you find something in there that gets you flying until the issue is fixed! No hawk = no fun!

I had same issue, I went in to options, data, and deleted my rolling cache and then it worked.

I also see this issue but it affects other aircraft as well, not just the Hawk. For me, it seems to be on the first attempt in MSFS. When it happens, I close down MSFS and start it again with the same aircraft and airport choice and it loads in fine so there is definitely nothing on the Hawk stopping it from working indefinitely.

I have rolling cache switched off so unfortunately that won’t work.

Thanks for the suggestions guys, I’ll investigate a bit more tonight,

Hey… I was wondering about the native support for the PMS GTN 750 mod. I have the mod installed correctly and I was under the impression that it should be an option in the EFB if it had native support. I see no option there. Maybe you initialize the 750 some other way?

So tonight I tried loading in and it worked. I have no idea what changed, but everything seems to be working now lol

1 Like

When’s the update drop?

Alpine Magic Returns 12 years later to MSFS2020 Next Week: Thursday 1900UTC at LOWI.

Further info at hawk-drivers-coming-soon-alpine-magic

But I’ll leave you with this as a Teaser,

KR, IslandControl

6 Likes

Will we get a version with HUD?

The Hawk T1 was never equipped with a full HUD so our version will only be available with the basic gunsight.

Martyn - Just Flight

2 Likes