KADW - Andrews - CTD Analysis by Community contributions

The “NO FLY ZONE.”

Database.

:o)

What does that mean ?

Can confirm I was approaching Washington National ILS 01 from the north which loops around Washington over Andrew’s AFB. As soon as crossing the river it CTD’d. Airbus A20n.

At the time of the CTD I was at 5000’ descending to 2500’ to begin my final approach to ILS01 at Reagan.

No mods, no scenery, no add ons, default aircraft and livery.

Cheers

Actually There’s a couple zones around the Great Lakes area like where a lot of ships and planes went missing Creating many Bermuda Triangle areas in the Lakes

image

There is supposed to be a hospital in this area. Perhaps create a building with a helipad on top and call it a day?

@N6722C & @Nirgal2776

I created a simple scenery mod- not attached to an airport.
I used a fairly large area (rectangle) that would include all of the red circle covered in this post.

I used two “rectangles”:

  1. An exclusion rectangle that “excluded all”
  2. A rectangle whose sole purpose was to “exclude buildings”, i.e. OSM buildings.

I did not set the scenery as an airport. I did not use any of the other options for the rectangle properties.

The scenery built OK and installed successfully in the community folder. It’s location in the community folder would overwrite anything in the sim base scenery data that may be causing the issue- if indeed the items ‘excluded’ are causing the crash.

As I say, it didn’t correct the issue.

A number of possibilities exist:

  1. The issue is caused by something that can be excluded by the method described but lies outside the region that was excluded;
  2. What I hoped to achieve and what I actually achieved are two very different things;
  3. The issue can’t be resolved by this sort of approach.

In the end I thought “I’ve spent enough time on this:grin:

2 Likes

Thanks
I think it is 100% clear that EVERYONE with SU#6 is getting this CTD error.

One thing that is not publicly commented on in the forums, is it those Testing the Reno Beta version, also get this same issue @ Andrews

I doubt that it is relevant as per:

I think that is what a LOT of owners of MSFS think – you are not alone.

Forgetting the debate that MSFS is a “SIM” or a “GAME”, certainly trying to run it successfully is 100% a GAME

Maybe, if you are willing to try again, make an exclusion area, and then add in something like a Tower, or Windmill, so you can be 100% sure that that scenery mod is loading correctly.
Also, initially, make the Area really BIG, just to make sure it covers where the issue is. Maybe initially as big as the Outer circle of the FP graphic !!!

If it then works, one can always start making it smaller, and zeroing in on the exact location.

Great idea… but I am going to leave that for someone else due to the time involved in going through that process… versus the benefit achieved.

Unless it works, I wouldn’t be able to see any scenery created there as a ctd results when loading into that area to check if the scenery added exists. Also, each time the package gets rebuilt, in my experience MSFS needs to be closed down and restarted to load the new package to then test that new package. All in all too time consuming for me…

1 Like

Just to the south west of that Medical Center there is a Building with TWO HeliPads on the Roof. 91MD

91MD Largo Prince George Regional Medical Center Heliport

They show up in Google Map, ( Red + 's on the roof)

If MSFS is about to add helicopter, it would make sense that they might be updating and adding HeliPads to support them, and this “COULD” be what is causing the issue … very Wild Guess, but those TWO HeliPads are at exactly the right location, and what may unique about them, is that there are TWO, very close together.

FYI: List of HeliPads in MD (wonder how many are in MSFS SU6 ?? )
http://www.airnav.com/airports/us/md?type=H&use=R

OH well, seems NONE of these HeliPads are in MSFS (yet)

Agreed — MSFS is a Time “Black Hole”

i don’t think issue is a helipad, i had remove all bgl from fs-base (0302 folder) concerning this area and CTD occured also.

1 Like

the error seems to occurs with file grammar.pggmod, related to Blackshark (propably the grammar to transform building footprints to 3d buildings

How did you determine that grammar.pggmod was causing the issue ?
Did that file change in SU6 ?

Could the pre-SU6 file be substituted as a temporary fix.

(Wonder who still has backups ? :roll_eyes: )

The current current one 10/19/2021 is exactly the same size as the one from 7/27/2021, and Bcompare says they are IDENTICAL

it was the last file loaded before CTD if i believe in crash report

i will try again the CTD with procmon running to monitor activity

its a joke or pun

no fly zone database is a database with no fly zones in it

I do not think the issue is with the “grammar.pggmod”

Not that one should – but -
I tried replacing both the “bf” folders in Official with version from back prior to SU6 (modding their versions so they did not update), and it made no difference.
All worked as expected, until entering the "CTD Zone)